Jump to content

TWiST

Member
  • Posts

    32
  • Joined

  • Last visited

  • Donations

    $0.00 
  • Country

    United States

Posts posted by TWiST

  1. I've been doing the same old stuff as before (add the runtimes etc) and my vb6 app wont work inside of the new winpe but it was fine in the xp sp2 PE ?

    I also use a menu building program for my main interface and that as well worked fine in the xp sp2 WinPE but won't launch on the new Winpe. I'm getting extremly frustrated and am hoping someone is having better luck then I.

    I was really excited about the ramdrive and what not in the new winpe, I even got my ramdisk working inside of the ramdrive so I can write to files, but now that my vb6 app wont run and I cant get my autorun to work (which is the piller of light in my setup) I'm losing faith. :(

    Hope someone has some ideas.

  2. Im very upset with the new WinPE 2005 (Win2k3 SP1). So im trying to do the old add explorer to WinPE trick and its giving me a very strange error. I've attached a screenshot of the BSOD im getting. It seems like the new winpe cataloges the files its suppost to have in it and if there are extra files it dosent like that. But im really not sure it just happened and I havent had time to experiemnt with it I figured I would post about it and then do some more work.

    The error is.

    STOP: c000021a {Fatal System Error}

    The Non-DLL file included in KnownDLL list. system process terminated unexpextedly with a status of 0xc000036f (oxe1174060 0x00000000).

    The system has been shut down.

    Any ideas ?

    EDIT:

    I've been playing with it a bit more and it seems to have alot of stuff allready in the registry and seems a bit more functional then the previous winpe's but Im not sure, and if thats true then why is it having such a hard time.

    post-81-1107516340_thumb.jpg

  3. Im not sure what you mean by that first sentence about ghost but I know that ghost is one of the only ways for me to REMOVE the lock so that I can use paragon for example to wipe the drive and reformat otherwise winpe has it locked. So for me ghost is great but I shouldnt hafta run ghost for just a sec to "UNLOCK" my HD it dosent make sence. espicalley for a product thats suppost to deploy an OS. I mean microsoft hasnt really said this is for recovery even though there heading that way but from that standpoint, its horrible to have anything write to teh drive if its crashed er what not, and your trying to recover data.

    I hope someone here has a solution to this, cause I would love to know as well, I havent played with teh new WinPE enough, I mainly have used the WinXP SP2 one so maybe this has allready be rectified, I wont know till I try.

  4. I don't have an answer to your question, but I think the new winpe 2005 (Win2k3 SP1 OPK) has a ramdisk built in and I am pretty sure they have one for 64. But I have never used WinPE 64 myself. Is it any cooler (meaning faster better, features etc ?) then the 32bit ?

  5. WinPE for some odd reason takes the primary master drive and somehow puts files on it or uses it for something and so when your dealing with the primary master HD when using WinPE from a CD or DVD it does a lock on the drive cause it is using it. Why it does this I have no idea, for data recovery its not good at all, and from my standpoint it screws me all up cause when I try to use like a partitioning tool or what have you, I get a similar error. When I launch ghost32 and try to do something it it, it can override the lock and give you back control. But its kind of lame to hafta do that just to get it up and going. I would love to find a way auround this. I am currently using paragon for my partitioning needs and when I try to use it I have the same issue, unless I go ahead and do the ghost method of unlocking it first. Hopefully someone with more experience in this will chime in with a wonderful answer to make both our lives simplier.

    But this is definently something that has been bothering me as of late.

    Even curiouser is that WinPE works fine without an HD, so why if there is one, does it have to interact with it unless I tell it too.

  6. I have just recieved my WinPE 2005 OPK cd its the new WinPE for windows server 2003 sp1, the build I recieved was for the RC 1289. Upon checking the docs before I even dig any deeper Im greeted with these new features.

    New Features in the OEM Preinstallation Kit (OPK)You can configure Data Execution Prevention (DEP) by modifying the Boot.ini file or by using Unattend.txt. DEP is the no-execute page-protection (NX) processor feature. DEP can help protect against some kinds of buffer overrun and exception handling exploits. For more information, see Customizing Data Execution Prevention (DEP).

    You are no longer required to install Step-by-Step Interactive (SBSI).

    Changes to the Windows Preinstallation Environment Version 2005

    You can boot Windows PE from USB flash devices (UFD). Use the FormatUFD comand-line tool to format the UFD. For more information, see Booting Windows PE from a USB Flash Device and FormatUFD Command-Line Options.

    For more information, see New Features in Windows PE.

    Changes to Answer Files

    For information about what is new in Unattend.txt, Sysprep.inf, Oobeinfo.ini, and the Windows Welcome APIs, see Changes in Answer Files and Changes in Windows Welcome Files.

    Now these new features are cool, the only one which really intrests myself is the boot from USB Flash Drive, but sadly ive been doing that for a while now allready, took MS long enough to catch up.

    Now this is a far cry from what we were expecting a few months back when MS announced the new WinPE versions, I dunno if any of you remmeber but the WinPE 2004 was suppost to support all this stuff and then the WinPE 2005 was suppost to be what they were calling the Interim OPK, which added support for the new WIM image based deployment method (what Longhorn uses to install) The SMS Beta introduced some of the WIM tools but they were very specific to using the SMS to deploy them.

    I dunno about the rest of you but im pretty dissapointed. Let me know what every1 else thinks and if anyone out there has played with this new verison yet.

  7. Hmm, and its stability isnt so grand either, ive used it I know. Well I suggest you get creative with XP and winpe2004 cause your just wasting time putting any energy into an old a** build thats not compatible with anything. Whats really intresting is what are u asking anyways ? How you can use winpe as a basis? I suggest you get yourself more familar with WinPE in general if you plan on spending alot of time with it, it can get frustrating. :wacko:

  8. Umm Who care about 3718 it's soo dawm old ? I dont understand. Any1 that spends extended time with OLD builds, is wasting there time considerably. I suggest you move on to more recent things, or better yet wait until something worth while is out to base your whatever on. When I hear people doing mods and what not to 4074 I laugh and its the most recent build (that most have), and its over 6 months old as well.

  9. I didnt realize the HP tool supports NTFS, thats cool I just used the default option of FAT, and I did not include the DOS. If you have used the HP tool there is an option for including the DOS files from a external DIR, I DID NOT INCLUDE DOS. Also I just did a regular format I didnt tick Quick format, but it was just as fast as a quick format. Hope that helps

  10. Well I got it working on my main system here, I havent had the time to try it on other systems yet. I used the simplest method and it actualley worked so suprised. I had been trying alot of diffrent methods and none of them where working except the simpliest hah. So I used the HP tool to format the drive just regular NOT with DOS files. Copied over the windows PE files before an ISO build. and put the ntdetect.exe in the root renamed the setupldr.bin to ntldr and put it in the root also and deleted the other files except the winbom.ini and it boots like a charm. This perticuler bios supports boot from USB HDD, USB Floppy, USB CDROM and USB something else. So it has the compatability, im gonna go ahead and try it on a few of my other systems and let you all know how I fare. But to say the least im pretty stoked.

    BTW. I have a VisionTek 1 GB USB 2.0 Flash Drive. Just to let the people that are trying to do this but have not succeeded yet, it is a pretty slow solution even at USB 2.0. It will take a bit to boot but once its up it runs pretty nice. It does have a bit of a lag but its not that bad. Also I was reading for the really hard up folks with no bios support for USB I was reading you could use a floppy disc or even a cdrom really thats bootable to load just the usb drivers and then continue to boot from the USB , but I havent tested that method as it has not applied to my situation yet.

  11. Ive been trying diffrent methods for getting this to work on my visiontek 1 gig flash drive and I can get dos to boot but not for the life of me will winpe boot, sometimes it hangs, sometimes it gets like cant boot errors. Its very strange im still messing with it. :hello:

  12. Now I hope its just the MS ramdrive that has those above listed issues cause the first 1.

    a) There is no harddisk attached

    Dosent make any sence at all the point of a ramdrive would be so I have a place I can read and write to files without needing a HD. That just dosetn make sence to me and I hope its only with the MS driver cause I dont use the MS one. I mean Ramdrive not working unless there is an HD ? dosent that seem lame to any1 else ?

  13. Yah I have ghost 9 I think I see what your talking about but kinda off subject my ghost 9 disc booted fine but none of the progs on it ran, Also while were talking about ghost 9, am I the only one upset by the fact that there is no ghost 9 but drive image 8 ? what happened to ghost32.exe etc etc. its now drive image thats branded symantec its very dissapointing. But thats all for another thread, time to get down with this PE madness. :w00t:

  14. Ok so you do need a ramdisk to accomplish this still. Thats where I got confused cause I thought you could do it with read only media now. Atleast thats the feeling I got from earlier posts in this thread. Now Im a bit better armed to continu.

  15. This is great info Metzen im gonna give it a go in a few here. Ill let you know how I fare. Also I am wonfering if I need a ramdrive or not for this, In the end I will be adding a ramdrive but im wondering if it is required to get explorer running still. I was under the impression with winpe2k4 you dont need to have a ramdrive to get explorer working but I dont know for sure.

    Oh Funny while I was posting the above you were posting a sequal to your post heh, We musta been typing at the same time. I have just as an expirement taken and I did this in levels not all at once so I can see what effects it. but Ive added all the files from windows the whole dawm dir haha I have a 740 meg winpe right now (Just for experimentation of course) and I am still missing ALOT of Explorer stuff, I know alot of it lies in the reg but Im not sure where, I know most of the reg or the backup I guess is in c:\windows\system32\config so I tried to import them over to PE just to see since I have 740 megs of files in there as well, and a couple things fix them selves but mostly I get more issues hehe. But im gonna give ur info a go now Metzen and see what happens, Thanx Again!

  16. Well I was up all night trying to get it working I ended up adding all sorts of stuff and it gets a little better but still very very far from perfect. Ill post some screenshots and stuff of my failed attempts in a little bit. But until then I think there is something new in the new WinPE that im missing er something.



×
×
  • Create New...