Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
trodas

Modify Windows default IDE latency

Recommended Posts

This is a advanced question of how to modify windows to not set the default 128 latency timer for SiS 730 chipset IDE access, but use 144 instead.

Reason - overclocking the chipset (150Mhz) beyond specs (max 133) lower the PCI clock to 30Mhz and it is unable to run stable when on load with latency being only 128. 144 make it rock-stable.

Partial solution - run Latency configurator - LtcyCfg.exe and at startup change the IDE latency to 144. (latency could/should be changed only for multiply of 8, so 128 + 2 x 8 (for safety not only 1 x 8)

Results - machine is stable after the setting.

Problems - booting is still not stable and sometimes just stop, even the machine booted up (with the latency 144 set for IDE) is rock stable.

Bios solution? Not work. There is bios option in the advanced Honey X bios for the PC chips M810L board this thread is all about that set the PCI latency. However having set "PNP OS installed = Yes" you give the OS the power to override the settings at it seems fit - as drivers define?

Setting it to No will insist on the bios settings, but then the machine not boot to windows at all. Futhermore changing the settings does only change the Ethernet latency time, and the Ethernet stuff is pretty happy with good fast latency 32 :) Setting the Ethernet latency to 160 (128 and then 160 are in the settings) did not help anything, of course.

With PCI latency only 128 (hell, that is plenty, but still not enough there...) Prime 95 test always crash at this and always that fast:

m810lerrormj5.gif

That is what the orginal latency settings look:

m810llatencyhx8.gif

Setting the IDE interface latency to 144 make the mainboard stable. It is working stable for 24h now :D

So, who can tell me, what and where to change the PCI interface latency in Windows XP SP1.0a I use on this folding machine, so the latency 144 are there since the IDE driver does load?

What informations are need from me to gain?

Share this post


Link to post
Share on other sites

This is a advanced question of how to modify windows to not set the default 128 latency timer for SiS 730 chipset IDE access, but use 144 instead.

Reason - overclocking the chipset (150Mhz) beyond specs (max 133) lower the PCI clock to 30Mhz and it is unable to run stable when on load with latency being only 128. 144 make it rock-stable.

Partial solution - run Latency configurator - LtcyCfg.exe and at startup change the IDE latency to 144. (latency could/should be changed only for multiply of 8, so 128 + 2 x 8 (for safety not only 1 x 8)

Results - machine is stable after the setting.

Problems - booting is still not stable and sometimes just stop, even the machine booted up (with the latency 144 set for IDE) is rock stable.

Bios solution? Not work. There is bios option in the advanced Honey X bios for the PC chips M810L board this thread is all about that set the PCI latency. However having set "PNP OS installed = Yes" you give the OS the power to override the settings at it seems fit - as drivers define?

Setting it to No will insist on the bios settings, but then the machine not boot to windows at all. Futhermore changing the settings does only change the Ethernet latency time, and the Ethernet stuff is pretty happy with good fast latency 32 :) Setting the Ethernet latency to 160 (128 and then 160 are in the settings) did not help anything, of course.

With PCI latency only 128 (hell, that is plenty, but still not enough there...) Prime 95 test always crash at this and always that fast:

m810lerrormj5.gif

That is what the orginal latency settings look:

m810llatencyhx8.gif

Setting the IDE interface latency to 144 make the mainboard stable. It is working stable for 24h now :D

So, who can tell me, what and where to change the PCI interface latency in Windows XP SP1.0a I use on this folding machine, so the latency 144 are there since the IDE driver does load?

What informations are need from me to gain?

I didn't have that problem with the PCI underclocked to 30 mhz with my Asus A7V8X-X, which is Via KT400-based.

It was rock stable without touching any latency settings!

I gotten the same error before, on my MSI 845E Max and Northwood 2.4B, simply because of my FSB OC'ing. Likely because of the RAM latencies. I saw that error occur with one of my PC2700 DDR SDRAM modules OC'ed to at least 160 mhz and at 2.5-2-2-6. I think that mine required being loosened to 2.5-3-3-7 when beyond 156 mhz.

Edited by RJARRRPCGP

Share this post


Link to post
Share on other sites

I do additional settings, but mine ram/computer is Prime stable, when the delay is higher, so... That it is. I just need to adjust the delay early in to bootup process - hence modification of the drivers is need... :blushing:

BTW, most modern chipsets has PCI locked up at 33Mhz, so...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...