Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
trodas

HFSLIP 1.3.1 created BS :)

Recommended Posts

/RANT

I don't know, what the hell you guys do. Like year and half there is possible using nLite optimize WinXP (czech) SP1.0a install and it worked pretty well. Like year ago I can run HFSLIP and instegrate to SP3 and SP2 Win2k DX9.0c and IE6 flawlessly, together with some register settings and stuff. And it WORKED. Todays NOTHING work. nLite crashing and did not producing anything usefull w/o the critical option... HFSLIP did not crashing, but the resulting install end in BSOD after like million error messages... WTF!!! Please make something that work, because one is pretty angry at winblows itself, so at least your tools are supposed to ease the pain, not intense the pain a lot! :realmad: :realmad: :realmad: :realmad:

/END of RANT

As it is clear, I tried the latest HFSLIP and the results are, well, less that satisfactory. Now let's get to the details. HFSLIP 1.3.1. Win2k updated the SP4 - I used the clean install, so I know it works well and never show me one single error diring install. It also instal lots of bloatware, but whatever...

Now using this Win2k SP4 (czech, always assume czech in my - Czech guy - case) with HFSLIP to do these things:

1) slipstream IE6

2) slipstream DX9.0c

3) slipstream DX9 extended stuff

4) integrate WM9/10 codecs (wmfdist.exe)

5) add this only fix: Windows2000-KB904706-DX9-x86-CSY.exe

6) use edited winnt.sif.txt file + empty sfcfiles.dll file

So, what are in the folders?

FIX - sfcfiles.dll, winnt.sif.txt

HF - Windows2000-KB904706-DX9-x86-CSY.exe, wmfdist.exe

HFCABS - Apr2005_d3dx9_25_x86.cab, Apr2006_d3dx9_30_x86.cab, Aug2005_d3dx9_27_x86.cab, BDANT.cab, BRANDING.CAB, Dec2005_d3dx9_28_x86.cab, DEC2006_d3dx9_32_x86.cab, dxnt.cab, Feb2005_d3dx9_24_x86.cab, Feb2006_d3dx9_29_x86.cab, IEW2K_1.CAB, IEW2K_2.CAB, IEW2K_3.CAB, IEW2K_4.CAB, Jun2005_d3dx9_26_x86.cab, MAILNEWS.CAB, OCT2006_d3dx9_31_x86.cab, OEEXCEP.CAB, SCRIPTCS.CAB, WAB.CAB

HFSVCPACK - w2k.reg

HFTOOLS - modifyPE.exe, MSICabExtract.exe

Contents of winnt.sif.txt:

[Data]

AutoPartition=1

;AutoPartition=0

MsDosInitiated=0

UnattendedInstall=Yes

[unattended]

UnattendMode=ReadOnly ; a little less automated (Windows asks more questions)

;UnattendMode=ProvideDefaults ; a little more automated (Windows asks fewer questions)

ExtendOemPartition=0

FileSystem=LeaveAlone

OemSkipEula=Yes

OemPreinstall=Yes

DriverSigningPolicy=Ignore

;NonDriverSigningPolicy=Ignore ; This setting has NOTHING to do with how WFP treats system files

Repartition=No

TargetPath=\WINNT

[GuiUnattended]

; asterisk means admin password is BLANK!

AdminPassword=*

OEMSkipRegional=1

OemSkipWelcome=1

;

TimeZone=35 ; United States - East Coast

;TimeZone=145 ; Russia - Moscow

[systemFileProtection]

; these no longer work post sp-1, here for illustration of how this used to work

;SFCDisable=ffffff9d

;SFCShowProgress=1

;SFCQuota=1

[setupparams]

; found these two below in SETUPLOG.TXT at "SpSetupLoadParameter", some appear to be undocumented?

;optionaldirs=

skipmissingfiles=yes

;UserExecute = ; It is generally unwise to use this, esp. with registry tweaks, as Windows is FAR from done with setup

;UserExecute = %systemroot%\System32\rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 %systemroot%\Inf\YOURINF.inf

[Networking]

InstallDefaultComponents=Yes

[GuiRunOnce]

; An application that requires the Windows Explorer shell to install, or that reboots, will not work here.

; To run an EXE file:

; start /wait %systemdrive%\myfile.exe

; To run an INF file:

;"%systemroot%\System32\rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 %systemroot%\Inf\myfile.inf"

[Display]

BitsPerPel=4

Xresolution=800

YResolution=600

Contents of w2k.reg:

REGEDIT4

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\atapi\Parameters]

"EnableBigLba"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters]

"AutoShareWks"=dword:00000000

"AutoShareServer"=dword:00000000

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control]

"WaitToKillServiceTimeout"="5000"

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem]

"NtfsDisableLastAccessUpdate"=dword:00000001

"Win95TruncatedExtensions"=dword:00000000

"Win31FileSystem"=dword:00000000

"NtfsDisable8dot3NameCreation"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]

"TcpNumConnections"=dword:00fffffe

[HKEY_CURRENT_USER\Control Panel\Desktop]

"MenuShowDelay"="0"

[HKEY_CURRENT_USER\Control Panel\Desktop]

"AutoEndTasks"="1"

[HKEY_CURRENT_USER\Control Panel\Desktop]

"HungAppTimeout"="40"

"WaitToKillAppTimeout"="200"

[HKEY_USERS\.DEFAULT\Control Panel\Desktop]

"HungAppTimeout"="40"

"WaitToKillAppTimeout"="200"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]

"SFCDisable"=dword:0ffffff9dh

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]

"NoLowDiskSpaceChecks"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment]

"DEVMGR_SHOW_NONPRESENT_DEVICES"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\Global\MediaCenterTray]

"NvCplDisableBalloonNotifications"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\I/O System]

"CountOperations"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dnscache\Parameters]

"MaxNegativeCacheTtl"=dword:00000000

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]

"MaxConnectionsPer1_0Server"=dword:00000004

"MaxConnectionsPerServer"=dword:00000008

[HKEY_CURRENT_USER\Software\Ghisler]

[HKEY_CURRENT_USER\Software\Ghisler\Total Commander]

"IniFileName"=".\\wincmd.ini"

"FtpIniName"=".\\wcx_ftp.ini"

"InstallDir"="D:\\WinCMD"

I let HFSLIP delete the obsolete files and that it is. No ISO image creating, I just drag&drop the files then to bootable ISO image using WinISO and burned with Nero, as usualy I do. Instalation was started. It went pretty normal, frankly I expected that the "press F6 to install..." and loading of some usualy useless stuff like SCSI adapters and such will not be present, but they are there. Nevermind. The pure fun started whe file copy begin. I started to writing witch files it need that the CD did not have.

Files missing during DOS copy part:

cdaudio.sys

cinemst2.sys

cnbjmon.dll

dvdplay.exe

icam3.inf

pjlmon.dll

rca.sys

srgb.icm

swenum.sys

tosdvd.sys

tsbvcap.sys

tsbyuv.dll

usbcamd.sys

vdmindvd.sys

wowfax.dll

wowfaxui.dll

ksproxy.ax

ksuser.dll

pid.dll

mskssrv.sys

mspclock.sys

fsvga.sys

lvcam.sys

lvcodek.sys

lvsound.sys

usbintel.sys

wbfirdma.sys

ks.sys

Files missing during HW detection stage:

usbui.dll

swenum.sys

ati.sys

cirrus.sys

et4000.sys

mga.sys

qv.sys

s3legacy.sys

wdvga.sys

weitekp9.sys

audstub.sys

Files missing during ending installation stage:

ks.sys

msh263.drv

ksuser.dll

ksproxy.sys

ksinterf.ax

ksdata.ax

ksvpintf.ax

ksclockf.ax

dxver.inf

diactfrm.inf

dmusic.inf

dsound.inf

dinput.inf

ksrec.inf

dplay.inf

dxdllreg.inf

bdaplgin.ax

dsound.inf

dmusic.inf

inetcomm.dll

oeimport.dll

msoe.dll

Files missing buring HFSLIP stage:

dxdllreg.exe

Result:

While booting the installed windows always crash at BSOD, complain that it can't load redbook.sys file.

I still have the source ready, so, witch files list someone want to fix these problems, or it was my fault that I missed something?

Edited by trodas

Share this post


Link to post
Share on other sites

:hello: I'm sorry HFSLIP has given you a lot of trouble lately. However, I would advise you to try the following things...

Recopy your SOURCE folder. Make sure you are burning your disc properly and the drive on which you are running HFSLIP is not broken. Are your hotfix and CAB files corrupt? Make sure your WINNT.SIF file does not have the .txt extension.

These are very basic and simple things, but you'll find out that they matter the most when dealing with scripts like HFSLIP. Good luck! :thumbup

Share this post


Link to post
Share on other sites
I still have the source ready, so, witch files list someone want to fix these problems, or it was my fault that I missed something?
- HFSLIP.LOG

- DOSNET.INF (SOURCESS\I386)

- DRVINDEX.INF (SOURCESS\I386)

- TXTSETUP.SIF (SOURCESS\I386)

Thank you :)

Share this post


Link to post
Share on other sites

Super-Magician - Well, I installed with the source directory files and my HDD is not faulty, so there is no need to checking too much. All the files need for my machine must working well. But yes, I checked all the cab files and yes, I discovered that there is a nasty error in driver.cab file. ****. The error damaged only these files, tough:

3cisati.sys

3cpciadi.sys

3cwmcru.sys

40291730.ppd

40293930.ppd

4mmdat.sys

8514a.dll

a_pnt518.ppd

a1base.sys

a1base.usa

aap1200.gpd

abp480n5.sys

acpi.sys

acpiec.sys

acq32.dll

adicsc.sys

adicvls.sys

adm8810.sys

Obviously I did not need them. But I look out for fixing this problem and replacing these files with good versions. Let's hope my friend send me them, so I can replace it inside the cab file to got a good drivers.cab file :)

The txt extension was my fault, indeed, but could it contribute to such great damage done to the whole install?! Really? It can explain install complain about the missing files, but can it explain the BSOD?

Neverless I still not figured out many things in the winnt.sif file. First at all, do the display I defined correctly?

[Display]

BitsPerPel=4

Xresolution=800

YResolution=600

I copy it from some person, complaining that he still not get 1024x768x32 in VGA mode (!) ater install, lol. But I would ques that the first line should be BitsPerPixel... but maybe I'm wrong.

Second, what are the correct timezone code for my GMT +1 (Prague) timezone???

TimeZone=35 ; United States - East Coast

;TimeZone=145 ; Russia - Moscow

But for GMT +1 ...?

And the keyboard settings - my primary keyboard should be czech and secondary the USA one. (USA international, IIRC...) How can I do it? In the sample file there: http://www.vorck.com/data/winnt.sif (when I save it as, the IE added the txt extension, so you see, this is where I get the extension...) are this:

[RegionalSettings]

;

; United States - East Coast

;

LanguageGroup=1

Language=00000409

;

; Russia - Moscow

;

;LanguageGroup=5,1

;SystemLocale=0419

;UserLocale=0419

;UserLocale_DefaultUser=0419

;InputLocale=0409:00000409,0419:00000419

;InputLocale_DefaultUser=0409:00000409,0419:00000419

...so it seems that I need to know the LanguageGroup number for czech language (how to get it?) and the Language ID number. Obviously 409 is the US english international, but what is Czech one and how to arrange the numbers there - this is complete mystery for me ATM...

Tomcat76 - very well, here you go, sir:

http://ax2.old-cans.com/hfslip_files.zip

(upload finction DOES NOT WORK for me, in FF v1.0 preview)

Let's hope it is all my fault...

Share this post


Link to post
Share on other sites

Did you provide the DOSNET.INF, DRVINDEX.INF and TXTSETUP.SIF files from SOURCESS\I386 or from SOURCE\I386? They seem like the original ones to me...

Share this post


Link to post
Share on other sites

Comparing the old DRVINDEX.INF with the new one, it seems as though DRIVER.CAB could not be extracted completely. Do you have enough hard disk space? The Windows 2000 DRIVER.CAB package is almost 200MB large when extracted. If you have WinRAR or 7-zip, also try manually extracting DRIVER.CAB to see that it isn't corrupted (right-click > "Extract to DRIVER\").

Share this post


Link to post
Share on other sites

Well, it was done on duron machine (check the elapsed time, lol) and yes, the driver.cab contain some files that are damaged, but they are probably not used at all, since my current install working stable too and it is the same as I used in the source dir...

But I get these files now, so, I'm ready to give HFSLIP another run. Just now how to pack all the 3422 files into one single driver.cab file :rolleyes::wacko: Makecab seems like to pack only one file, bur maybe I'm wrong... :unsure:

Any possible help with the winnt.sif file questions I have anyway? :hello:

PS. Ah. cabarc n x.cab D:\files\*.* create a x.cab inside of these files directory, but it preserve the path... and the file is also 81MB big, not 52...

Edited by trodas

Share this post


Link to post
Share on other sites

You can try this CMD file:

@ECHO OFF
SETLOCAL ENABLEEXTENSIONS ENABLEDELAYEDEXPANSION
MD D:\_drivercab
ECHO>CABBER.DDF .Set Cabinet=on
ECHO>>CABBER.DDF .Set Compress=on
ECHO>>CABBER.DDF .Set CompressionType=LZX
ECHO>>CABBER.DDF .Set CompressionMemory=21
ECHO>>CABBER.DDF .Set FolderSizeThreshold=5000000
ECHO>>CABBER.DDF .Set MaxDiskSize=CDROM
ECHO>>CABBER.DDF .Set CabinetNameTemplate=DRIVER.CAB
ECHO>>CABBER.DDF .Set DiskDirectory1=D:\_drivercab
FOR /F %%I IN ('DIR/B D:\files') DO ECHO>>CABBER.DDF D:\files\%%I
MAKECAB/F CABBER.DDF
DEL/Q/F CABBER.DDF SETUP.INF SETUP.RPT

Share this post


Link to post
Share on other sites

Okay, thanks, but... it keep reporting that the directory D:\_drivercab already exist...

...and not it reporting that maximal recursion level was reached... :blink: That did not looking too good... :unsure:

After few moments it in one line reporting the dir already existing and on other line the maximal recorsion level reached... :blink: My makecab version is v5.00.2134.1, 81 168 bytes long. Time for update, or there is a error in the batch? :wacko:

I wonder if it come to some meaningfull end anyway...

...so after like 15 min it did not come to anything different, so I Ctrl + C stopped it... Any suggestions?

Edited by trodas

Share this post


Link to post
Share on other sites

You get the "directory already exists" message because I didn't anticipate you running the script more than once. It shouldn't cause a problem but if you want to get rid of it, change the 3rd line to:

IF NOT EXIST D:\_drivercab MD D:\_drivercab

Try changing the value of CompressionMemory from 21 to 18. This could indicate a memory issue...

Share this post


Link to post
Share on other sites

Whoa :thumbup Worked like a charm, thanks! :)

(just with the 3rd line change... not need to use smaller compression, in just few min it was all over...)

The resulting driver.cab is 50MB in size, smaller that the original, but let's hope the win during install did not mind.... :blushing:

Time to another slipstream try, right?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...