Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


pankajtakawale

Imagex apply windows 2000, xp , 2003 images

Recommended Posts

Wait.. how do you modify the sysprep.inf file before the reboot? This is the part I'm confused about. Is your sysprep file sitting on the network share or WDS server or is it sitting on the sysprepped machine?

Personally, I use a HTA or VBS script. The sysprep.inf is on the imaged machine, once you apply the image.

Share this post


Link to post
Share on other sites

This is very interesting so I tried it out in VMWare.. here is what I did..

1. use ghost to layed down a Syspreped image onto a new VM Machine.

2. Boot up PE and run imagex /capture c: and saved the WIM to a network share.

3. created a new VM machine, and boot up WinPE.

4. Diskpart the new drive and format it to NTFS

5. run imagex /apply the.wim back to C:

In the VM preped with ghost in step 1, a reboot will cause the VM go into mini-setup, but in the VM applied with ImageX, it bluescreens at me.

anyone have any suggestions? Is this a VM issue? thanks.

Share this post


Link to post
Share on other sites
This is very interesting so I tried it out in VMWare.. here is what I did..

1. use ghost to layed down a Syspreped image onto a new VM Machine.

2. Boot up PE and run imagex /capture c: and saved the WIM to a network share.

3. created a new VM machine, and boot up WinPE.

4. Diskpart the new drive and format it to NTFS

5. run imagex /apply the.wim back to C:

In the VM preped with ghost in step 1, a reboot will cause the VM go into mini-setup, but in the VM applied with ImageX, it bluescreens at me.

anyone have any suggestions? Is this a VM issue? thanks.

I tried it on VM instance only.

Only difference between your and my steps are:

Instead of your (1) step , I install OS on VM manually - then syspreped it.

You can try followin steps:

1. deploy normal (NOT syspreped) image to new VM m/c

2. sysprep it

and then ur normal steps....

Share this post


Link to post
Share on other sites

In your syspreped image, have you included the vmware IDE or SCSI drivers in the mass storage section? if not, it will BSOD on you anytime you try and use that image on VMWare.

Share this post


Link to post
Share on other sites

Is there any way, after doing the wim image, to use WinFLP or LH installer to format and apply the wim image, as Dexter inside does?

thank you in advance

Share this post


Link to post
Share on other sites

Has anyone dealt with System partitions?

I have several peices of hardware that require system partitons (older hardware but we stil use it and I have to support it)

My issue is that the System partition is a hidden partition with no drive letter assigned.

ImageX can't deal with this partition like PQIDeploy or Ghost.

Has anyone been sucessful with imagaing and deploying a system partition using imageX?

I am told I have to play with it by actually making the sys partiton active and assigning a drive letter

Then Imaging it.

And when I deply it.. doing the same in reverse. Deploy as C:... then hide it and mark as non bootable.

Thats lot of work in my book....

I'm curious if anyone has tackled this yet and if they would post the code thay used.

Chris

Share this post


Link to post
Share on other sites
Has anyone dealt with System partitions?

I have several peices of hardware that require system partitons (older hardware but we stil use it and I have to support it)

My issue is that the System partition is a hidden partition with no drive letter assigned.

ImageX can't deal with this partition like PQIDeploy or Ghost.

Has anyone been sucessful with imagaing and deploying a system partition using imageX?

I am told I have to play with it by actually making the sys partiton active and assigning a drive letter

Then Imaging it.

And when I deply it.. doing the same in reverse. Deploy as C:... then hide it and mark as non bootable.

Thats lot of work in my book....

I'm curious if anyone has tackled this yet and if they would post the code thay used.

Chris

If the datafiles on the partition is readable by Windows/WinPE, it should be possible, remember ImageX is filebased and not disk/sector based like Ghost/PQIDeploy.

It will require some scripting/coding to handle but as you have access to VBScript and WMI from WinPE, it should be fairly easy to solve this.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...