Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
darkbolo69

#error:System. reflection. targetinvocationexception

Recommended Posts

Hello guys I'm having the following problem and I don't have any idea how to fix it, could anyone help me. Currently I have the latest NET framework 2.0 But when I ran Nlite this screen pop up

#error:System. reflection. target invocation exception

Exception has been thrown by the target of an invocation

at system runtime method handle invoke method fast object [] argument etc.........

Thanks darkbolo69

Share this post


Link to post
Share on other sites

Hm...

So I take XP Sp2, fresh Windows with full Framework, nLite installer?

Anything else? I mean of course it works for majority out of the box but I did have those errors during development so I won't dismiss you so easily.

Share this post


Link to post
Share on other sites

Well read the error report:

You're missing Microsoft Sans Serif Bold font.

Share this post


Link to post
Share on other sites

Thanks, problem solved after replacing the corrupt font.

I thought of another reason because the font wasn't missing but obviously corrupt.

The program loads perfectly now. Appreciate the great work on this program. Thanks

Share this post


Link to post
Share on other sites

Sorry to revive this forum, but I just got a similar error for the first time ever.

I attached a screenshot for it.

I read through the error several times, and I just can't seem to find anything that I could have cause, or know how to fix. any help would be greatly appreciated.

post-245253-1243211133_thumb.png

Share this post


Link to post
Share on other sites

MCSammer, what were you doing at the time of the error? What nLite version are you running - should be 1.4.9.1? If you have a Last Session.ini, please attach (not paste) it. Have you run nLite successfully since installing it and .NET Framework? Good luck, John.

Share this post


Link to post
Share on other sites

Dear John,

I was just trying to load nLite, to work on a project I've been working on for everyday for about the last... week. and I'm compulsive about getting the latest updates for everything, so it's not an out of date issue. and I tried installing, uninstalling, installing, it but same error. idk, let's just say that this is by far the best thing that's happened all day, so I'm kinda irritated.

Share this post


Link to post
Share on other sites

MCSammer, you did not answer my questions about nLite/.NET working before. Did you remove/reinstall nLite or .NET or both? Several posters have reported strange .NET problems and these were cured by removing/reinstalling .NET. Did you check the MD5 for the nLite you DLed? Did you DL it from the nLite web site? More information is always better than less. Are you running under Vista, as your information indicates? If you are ultimately going to create an ISO for XP, under Vista you will not be able to integrate an SP. Enjoy, John.

Share this post


Link to post
Share on other sites

A. It's XP 32-bit SP3 with a win7 skin (The image is)

B. I downloaded it from the nlite website after it was released.

C. Would I uninstall 3.5, 3, 2 sp2, and 1.1?

D. Yes it was working, hence the "project I've been working on for a week"

E. It worked yesterday, and it finished making an ISO, which unfortunately did not work (Tested it using VirtualBox)

F. I hope I don't seem to, PO'ed, it's been a poor day, as I mentioned before, but I don't mean to take it out on anyone.

G. I did delete a bunch of fonts I don't use (about +1500 of +3700) earlier today, so I want to call that the culprit.

H. Thanks for your help.

Share this post


Link to post
Share on other sites

MCSammer, if you have created an ISO before, I would not, at least at this time, be removing/reinstalling anything. Did you remove the fronts from your Windows source? Is your Windows source a legal copy with a legal key? Please go ahead and attach one of your earlier Last Session.ini files? Now here is my normal inculcation, please make sure to always start with a fresh copy of your CD files/folders, do all your work in one nLite session and integrate only one SP. Please report when you have a solution, so others can benefit. So, starting with a fresh copy of your source (unaltered), try again. What kind of problems did you have with the ISO you cut? Enjoy, John.

Share this post


Link to post
Share on other sites

I just wanted to add that if you cannot find yourself a copy of Microsoft Sans Serif Bold font that installing Microsoft PowerPoint Viewer 2007 Here will give you a copy. This is what I had to do and it solved my problem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...