Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


boooggy

[RELEASE] Boooggy's WMP 11 direct integration solution

Recommended Posts

Sorry to disturb but.

I realize that. Slipstreamer not take all string from WMP11 setup.

What ever language of setup you use. Slipstreamer allways write en-US stings to wmp.inf.

These ara my locals. But Slipstreamer not using them.

Original source

LangTypeValue = 0x41F

Language = "TRK"

LANGUAGE_WMP="TR"

LCID="1055"

FILE_AUDIO ="Ses dosyası"

FILE_MIDI ="MIDI dosyası"

FILE_MPEG ="Film dosyası (MPEG)"

FILE_MP3 ="MP3 dosyası"

FILE_M3U="M3U dosyası"

FILE_NETSHOW ="Windows Media dosyası"

FILE_VIDEO ="Video dosyası"

FILE_PLAYLIST = "Medya çalma listesi"

FILE_CDA = "CD Müzik Parçası"

FILE_PICTURE ="Resim dosyası"

DESCRIPTION_AIFF = "AIFF Biçiminde Ses"

DESCRIPTION_AU = "AU Biçimli Ses"

DESCRIPTION_VIDEO = "Video Klibi"

DESCRIPTION_AUDIO = "Ses Klibi"

DESCRIPTION_MOVIE = "Film Klibi"

DESCRIPTION_MIDI = "MIDI Sırası"

DESCRIPTION_WAVE = "Ses Dalgası"

WMP_TIP = "Başlat menüsü veya masaüstünden Windows Media Player'a erişim olanağı ekler ya da bunu kaldırır"

WMP_NAME="Windows Media Player"

STR_TRANSFER = "Dosya aktar"

TEXT_BURN= "Ses CD'si yaz"

TEXT_RIP = "CD'den müzik kopyala"

OPENTEXT="&Aç"

PLAYTEXT="Y&ürüt"

CDDELUXE_NAME = "Delüks CD Çalar"

DISKNAME="Microsoft Windows Media Player'ı Yükle"

WMP11 Slipstreamer wmp.inf file.

TYPE_CDA = "*.cda"

LANGUAGE="EN"

LCID="1033"

MP2_FOLDER = "Windows Media Player"

FILE_AUDIO ="Audio file"

FILE_MIDI ="MIDI file"

FILE_MPEG ="Movie File (MPEG)"

FILE_MP3 ="MP3 file"

FILE_M3U="M3U file"

FILE_NETSHOW ="Windows Media file"

FILE_VIDEO ="Video file"

FILE_PLAYLIST = "Media playlist"

FILE_CDA = "CD Audio Track"

DESCRIPTION_AIFF = "AIFF Format Sound"

DESCRIPTION_AU = "AU Format Sound"

DESCRIPTION_VIDEO = "Video Clip"

DESCRIPTION_AUDIO = "Sound Clip"

DESCRIPTION_MOVIE = "Movie Clip"

DESCRIPTION_MIDI = "MIDI Sequence"

DESCRIPTION_WAVE = "Wave Sound"

PROGRAMFILES = "Program Files"

DVDPLAY_DESC="DVD Player"

FOLDER_DESC="Accessories\Entertainment"

TEXT_BURN= "Burn an audio CD"

TEXT_RIP = "Rip music from CD"

OPENTEXT="&Open"

PLAYTEXT="&Play"

WMP_NAME="Windows Media Player"

CDDELUXE_NAME = "Deluxe CD Player"

DISKNAME="Microsoft Windows Media Player 11 Install"

Edited by eryen

Share this post


Link to post
Share on other sites

Is the hotfix list on this page still up-to-date or are there new hotfixes for WMP11?

the hotfixes u found there are kept up to date .

eryen

i will investigate more....thx for reporting

Edited by boooggy

Share this post


Link to post
Share on other sites
When I run WMP11 Integrator with all the hotfixes I have the following issues..

1) The Winnt.sif settings for [Display] do not work - first boot defaults to 640x800

2) Upon first login I get the following popup

Title = "Advanced INF Install"

Text = "Error creating process <C:\Program Files\Windows Media Player\WMPEnc.exe /RegServer>. Reason: The system cannot find the file specified"

If I click OK and go to "C:\program files\Windows Media Player" there are only 11 files and 2 Folders for a total of 3.5MB

Info : The SP3 install without WMP11 works fine

I'm getting the exact same results.

FIXED by puting modified wbemoc.inf AFTER WMP11 splipstreaming

Take

wbemoc.in_

unpack wbemoc.in_ (for example in WinRAR or use command line "expand wbemoc.in_" ) to:

wbemoc.inf

Modify in notepad (note that file is in UNICODE, some notepad replacements may have problems,use uni2asci or simply "save as" ASCI in notepad then edit, windows will not have any problems with asci file)

wbemoc.inf

.....

[WBEM.CopyMOFs]

....

napclientprov.mof

napclientschema.mof

....

so it will looks like this:

.....

[WBEM.CopyMOFs]

....

napclientprov.mof,napprov.mof

napclientschema.mof,napschem.mof

....

(the first shown ones only, more or less in the middle,don't modify lines at the very end)

cab it back

"makecab wbemoc.inf"

put on CD.

Don't use english version if you use non-english one as ONE string is local

PL for example

[strings]

WBEM_DESC = "WMI"

WBEM_TIP = "Instrumentacja zarządzania Windows"

English versions already modified, info and all credits goes to people here:

http://www.ryanvm.net/forum/viewtopic.php?t=6290

Fixed for me that error during install, lack of firewall and access error in net connections

taskkill error "class not registered" etc.

English file in ZIP'ed attachement:

wbemoc.zip

Edited by anonim1979

Share this post


Link to post
Share on other sites

Is WMP 11 having any issues in Windows 2000 ?

I tried to integrate WMP11( with hotfixes mentioned in his page) to XP SP3 in Win 2000 Environment,,, Windows Explorer encounters an error and it gets closed...

I installed .Net 2.0, any other ideas ?

Edited by dazzlee

Share this post


Link to post
Share on other sites

Some info about the what exactly the error was ? what message ? Details ? when did the error happen ?

That would really be nice.

Share this post


Link to post
Share on other sites

dazzlee integrated wmp11 using slipstreamer on a xp source but running the slisptreamer in a 2k enviroment.....

slisptreamer cant integrate wmp11 on 2k. his error can happen but like epsilon said we need more details.....

please read his post carefully before posting.

Share this post


Link to post
Share on other sites

Yeah booogy understood me,,,

I used WMP11 Slipstreamer in Win2k Environment to integrate into XP Source..

Here's first screen

graphic0kq1.jpg

The Error Screen

graphic1vz6.jpg

Detailed Error Report

graphic2ft7.jpg

After the error, the wmp11temp folder view...

graphic3na3.jpg

I integrated all Hotfixes list in the booogy's page...

You need any other INF files from me listed above?

Share this post


Link to post
Share on other sites

thx dazz for the report....

can u please add mspatcha.dll to wmp11 slips folder (where u have the executable)?

Edited by boooggy

Share this post


Link to post
Share on other sites

@Boooggy

I did a slip of my xp pro + sp3 + your WMP 11 + a few addon's. These 'addons' are the ones that don't change, like my Microsoft works suite program, DotNet, etc. Thus, this CD becomes the basis of making a second finished DVD with all other options/rotating 'updated' hot fixes, component removal, etc. This, therefore, speeds up the overall process when making my 'final' DVD.

? I noticed that there are two files, not to big, WMP9 & WMP10, about 2megs each, can they be deleted or are they essential.

Thanks in advance. Great program by the way.

Eddie

Share this post


Link to post
Share on other sites
thx dazz for the report....

can u please add mspatcha.dll to wmp11 slips folder (where u have the executable)?

I put the file in the folder(f:\softs\os\project\wmp11\mspatch.dll)here only i have the WMP original file..

still the same error mate.....

Is ther any chance, any of my dotnet framework files being corrupted ?

Share this post


Link to post
Share on other sites

dont think so....if net 2 is corupted u couldnt start the program....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...