Jump to content

DCOM Server Process Launcher - Error


Recommended Posts

First I want to mention that I chose to 'disable Dcom' in nlite 'security tweaks' and in network tweaks - 'disable Dcom protocol bindings'.

I also disabled the following services:

-SSDP Discovery Service

-Universal Plug and Play Device Host

-Windows Media Player Network Sharing Service (wmp11 new service).

-Machine Debug Manager

Now, all the time I get the following error in the XP system event viewer:

DCOM got error "The service cannot be started, either because it is disabled or because it has no enabled devices associated with it. " attempting to start the service MDM with arguments "" in order to run the server:


This is the only error I get but it keeps on coming.

I know it's got something to do with the MDM (Machine Debug Manager) but as I understand that service is not needed.

Can I disable The **** 'Dcom service' without damaging the system?

If not, how can I stop getting error??

I also tried the "Dcomobulator". Still get errors.

If I enable the 'Machine Debug Manager' service it is still not enough. Then I'll get errors until I turn the other services back on. But I don't need them at all.

Can someone help?

Link to comment
Share on other sites

Hi man,

You got this error not because You disabled dcom, but because all those servises (SSDP and UPNPhost) are needed for media player 11.

You can disable by default only this one (network) service. It will not invoke dcom error.

But each time You start media player it triggers upnphost and this service starts ssdp. You need to remove service dependency with regedit but even after that You will be able to disable only ssdp, but upnphost will start and stop each time You will start wmp11. So You can not disable this service but it won't take Your resourses.

Good luck,


Link to comment
Share on other sites

Thanks Alex. :)

But is there no way (like a reg tweak) that I can stop WMP11 from starting 'upnphost' and 'ssdp'. I don't need those services.

and what does MDM service got to do with it from the first place?! (I disabled him, too)

Is this error new for WMP11?

can't we all just get along?? :}

Link to comment
Share on other sites

Hi again,

This error is the cause of Your services adjustment. WMP 10 let's You turn them off, WMP11 directed to faster and better external devices connectivity. That's why it does not ask if You need those services or not, just creates dependency. You need to modify wmp files to be able to disable upnphost service. But here I can not help You, work for real profees.

Hey guys, help :realmad:

Good luck,


Link to comment
Share on other sites

  • 2 months later...

Something about DCOM... I had this enabled and the system used 35.0Mb RAM

but when I enabled DCOM it went up to 35.7Mb RAM but dropped slowly down

to 35.2Mb. Yes, I rebooted and left it ten minutes each time, I even have Task

Manager in the Startup folder, I am just trying to work it out.

DHCP is another one - it uses no resources (I mean not even 0.1Mb RAM) and

can cause a broken internet connection if it is disabled... so then it is pointless

disabling DHCP Client, but this DCOM seems to use 0.2Mb to 0.7Mb RAM if its



Enable DCOM and you save +/- 0.35Mb RAM... don't believe me? Test it for yourself and see!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...