Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
soporific

Windows 98 hangs on shutdown "DDE Server Window"

Recommended Posts

I was lucky enough to be able to test v1.5 of the autopatcher on a real working system that was struggling to work int he real world because it had virtually no updates whatsoever, but was trying to access the internet and send email, etc. --- it was all good, except a new bug was found

... before the hotfixes started to install, the system would hang on shutdown and give the message:

DDE Server Window

This program is not responding. It may be busy, waiting for a response from
you or it may have stopped running

Doing some research on this issue, I came upon the following post here

and at the bottom was this:

Hi!

go to

start

run

type in regedit

export the registry

name it before forced exit

go to

HKEY_CURRENT_USER\CONTROL PANEL\DESKTOP

IN THE RIGHT HAND PANEL ADD THE NEW STRING

AutoEndTasks if it is not there and give it the value of 1

update your ifsmgr.vxd to version 4.10.0.2223 use microsoft 256015usa8.exe to download and install it. this shuts down a lot better than the 4.10.0.2225 version downloaded with 273027usa8.exe wich is the one you are supposed to use for windows 98 se.

once you have updated you file manager go to

start

run

type in redgedit

export

save the file as before cachewritedelay

now go to

HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\WINDOWS\CURRENTVERSION

if you don't already have it create a new DWORD Value called CacheWriteDelay

double click on it

in the decimal box type 4000

the words CacheWriteDelay

for more information on this go to www.mdgx.com

Anyone know any info about this? in particular, v.2225 of ifsmgr.vxd is buggier than v.2223 ???

MDGx, i'm looking at you for this one... your site was mentioned in the evidence...

Edited by soporific

Share this post


Link to post
Share on other sites

At least some information in that post is wrong.

The package with 4.10.2225 version is 273017usa8.exe, not 273027usa8.exe

But what is much more important, the CacheWriteDelay registry entry is used by version 4.10.2225 only, not by 4.10.2223, you can just look into the file, this text is contained in 4.10.2225 version only.

It means that it has absolutely no sense to set the registry CacheWriteDelay to any value if 4.10.2225 is not installed.

Petr

Share this post


Link to post
Share on other sites

They poster you have quoted has things upside down, from mdgx site Win98 SE IFSMGR.VXD 4.10.2225 Fix [225 KB, English] <-is the update they should have quoted/used. Then

The second part applies ONLY to Windows 98 SE and ME, and consists in a workaround, by creating a Registry Value that allocates the updated IFSMGR.VXD [after installation and the mandatory reboot :)] enough time (delay) to write (flush) all data stored in the memory cache buffer back to the hard disk(s)/partition(s) while Windows shuts down.

This happens (according to the Microsoft explanation) because newer (E)IDE/ATA hard drives (HDs) have their own built-in cache buffer memory [a good thing ;)], which do NOT send proper signals [a bad thing ;(] to the drive controller [moreover if using a 3rd party proprietary add-on ATA66/ATA100/ATA133/RAID (E)IDE controller], and therefore their cache will NOT empty (flush) correctly upon OS shutdown, especially if your CPU clock speed is greater than 600 MHz, and if your HD(s) built-in cache buffer is equal to or larger than 2 MB.

To do this, run Regedit and go to:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion

Right-click in the right hand pane -> create a New DWORD Value called "CacheWriteDelay" (don't type the quotes) -> click OK -> double-click on it -> check the Decimal box -> type 2000 (2 seconds delay measured in milliseconds); if 2000 doesn't work properly on your PC type 4000 (4 seconds delay in milliseconds) -> click OK or press Enter.

Close the Registry editor and restart Windows when done.

http://www.mdgx.com/newtip21.htm

Are you sure the pc does not just suffer from a hung dde app

Edited by oscardog

Share this post


Link to post
Share on other sites

Cache Write Delay tip here:

http://www.mdgx.com/newtip21.htm#CWD

Please notice bug fix #2:

The second part applies ONLY to Windows 98 SE and ME, and consists in a workaround, by creating a Registry Value that allocates the updated

IFSMGR.VXD [after installation and the mandatory reboot :)] enough time (delay) to write (flush) all data stored in the memory cache buffer back to

the hard disk(s)/partition(s) while Windows shuts down.

HTH

Share this post


Link to post
Share on other sites

soporific, you may want to set CacheWriteDelay registry entry to 0000 (or double-click on the NODELAY.REG file) after Q273017 IFSMGR.VXD 4.10.2225 fix is installed. that may make your Win98se system shut down a little faster.

yeah I agree some of the info mentioned at the Lockernome forum thread is wrong and inaccurate

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...