Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


xehqter

OEMScan - Automated Multi Manufacture Pre-Activation Utility

Recommended Posts

I've tried it with just one manufacturer, and no oemcopy. The folder is "OEM" in the root of my CDROM.

My specific problem is that When OEMSCAN.EXE is called, Windows can't find the CDROM Drive (or the "OEM" folder), so OEMSCAN.EXE is not found, even though setup knows where the drive is.

It has to do with the "setcdrom" statement. I haven't figured it out yet. And I've tried plenty, resulting in about 20+ coasters.

I only use CDR's because my burner hates CDRW's.

Also, I decided to start over from scratch with the Gateway CDROM I just slipstreamed to SP2, but there is no "SVCPACK" folder since I have not added any hotfixes with RyanVM.

Does anyone have the correct working version of this? this is what I have right now. I need it fixed, with no hiding programs, just the drive discovery.

@ECHO OFF

for %%i in (C: D: E: F: G: H: I: J: K: L: M: N: O: P: Q: R: S: T: U: V: W: X: Y: Z:) do if exist %%i\WIN51 set CDROM=%%i

%CDROM%\OEM\OEMSCAN.EXE > "%SystemRoot%\Temp\oemscan.log"

Share this post


Link to post
Share on other sites

I don't know if this thread is still active.

Anyway, I been trying to use oemscan on Windows XP x64. Oemscan runs, detect the right set of oembios files to copy but fail to copy. I use the cmd line to invoke a cmd file called oemcopy.cmd that basically re-try to copy the oembios files to the system32 directory, but that also fails. I did manage to copy the oembios files to both syswow64 and dllcache directories, but that does not activate windows.

Oemscan however, have no problems importing the oembios.cat file.

If I copy the oembios files manually using windows explorer to the system32 folder, windows will activate.

I am already logged on as administrator, and tried to run oemscan as a detachedprogram and from runonceex. It runs and imports the.cat file everytime but not the others.

I even removed the oembios files (sig, dat and bin) from the installation Cd and removed all mentions from the txtsetup.sif and dosnet.inf files.

Am I missing something obvious here? Any help will be much appreciated.

UPDATE

I think I found the reason why oemscan is not copying the files to system32 folder. Basically, the x64 windows is redirecting all files to the system32 folder to the syswow64 -x64 equivalent folder instead. That will not activate windows.

Strangely enough, all attempts to copy to the %systemroot%/system32 using cmd will also end up in the syswow64 folder.

I think I solve the problem by adding an AutoIT executable that will run from the cmd line in the oemscan.ini file to copy the files to the right folder instead.

I think there should be a version 1.4.2 to solve this error for us hapless x64 users, me in particular. :whistle:

Edited by kenlau

Share this post


Link to post
Share on other sites

Hi kenlau,

I don't think this topic is dead, but theres not really anywhere else to go with it.

64bit XP isn't really an option as so few people use it, and those with the skills to get the most out of a 64bit OS will probably be using Linux or Vista. :blink:

But, there is a 'sister' project on the forums over at Signet Software.

I was over there last week and think i saw something about 64bit OEMBIOS files. ;)

Share this post


Link to post
Share on other sites

Hi ZaForD,

In my opinion, x64 offers much better speed and stability than x86, plus the simple fact that I plan to skip Vista entirely. I just cannot see myself using Vista. As far as OS for new machines are concerned, XP x64 is one of the better kept secrets.

I already looked through Signet Software, Basically I scoured both MSFN and Signet for clues to why my oemscan do not work. I know someone in Signet reported that they got x64 to activate, but leave no details on how it was done.

In any case, I got it working by calling an AutoIt exe file from oemscan.ini that copy the proper oembios files across, bypassing the x64 redirection. It is just an extra step, and not a big deal really. If the author is going to come up with a new revision, I just hope he keep in mind this bug.

Thanks

Share this post


Link to post
Share on other sites

Hi kenlau,

I won't go into the x86 vs. x64 thing, as it would take the thread way of track. :yes:

I'm sorry the link wasn't much help, I was looking for something else at the time and just noticed it.

Seems you've found a work round, could you post the details ?

I sure it would help some others that are using x64.

Share this post


Link to post
Share on other sites

Here goes nothing.

Basically, when OEMScan runs, it will copy the matching oembios files to the system32 folder according to the matching slp in the bios. However, when this is done of XP x64, Windows quietly redirects the oembios files to x64-equivalent folder which is syswow64. When this happens, the pre-activation does not occur.

The next alternative is for the oemscan.ini file to call a cmd file to copy the files again to the system32 folder, i.e.,

copy oembios.bin %systemroot\system32 /y

Bugger it all, would you know it, Windows still redirects the files to the syswow64 folder. However, if you copy the files using Windows Explorer, it will work. So will copying the files from an user opened command windows, which was a red herring, as it lead me to believe it was an user permission problem. That was a wasted 2 days I am never going to get back.

The neurons in my brain finally fired, and I remember AutoIT have a function that disable the redirection to the syswow64 folder. Below is the AutoIT script that is called from oemscan.ini.

DllCall("kernel32.dll", "int", "Wow64DisableWow64FsRedirection", "int", 1)
If FileExists ( @ScriptDir & "\oembios.bin" ) Then
FileCopy ( @ScriptDir & "\oembios.bin" , @WindowsDir & "\system32\Oembios.bin" , 1 )
FileCopy ( @ScriptDir & "\oembios.dat" , @WindowsDir & "\system32\Oembios.dat" , 1 )
FileCopy ( @ScriptDir & "\oembios.sig" , @WindowsDir & "\system32\Oembios.sig" , 1 )
FileCopy ( @ScriptDir & "\oembios.bin" , @WindowsDir & "\system32\dllcache\Oembios.bin" , 1 )
FileCopy ( @ScriptDir & "\oembios.dat" , @WindowsDir & "\system32\dllcache\Oembios.dat" , 1 )
FileCopy ( @ScriptDir & "\oembios.sig" , @WindowsDir & "\system32\dllcache\Oembios.sig" , 1 )
FileCopy ( @ScriptDir & "\OEMINFO.INI" , @WindowsDir & "\system32\OEMINFO.INI" , 1 )
FileCopy ( @ScriptDir & "\OEMLOGO.BMP" , @WindowsDir & "\system32\OEMLOGO.BMP" , 1 )
FileDelete ( @WindowsDir & "\syswow64\oembios.bin" )
FileDelete ( @WindowsDir & "\syswow64\oembios.dat" )
FileDelete ( @WindowsDir & "\syswow64\oembios.sig" )
FileSetAttrib ( @WindowsDir & "\system32\Oembios.bin", "+S+R", 1)
FileSetAttrib ( @WindowsDir & "\system32\Oembios.dat", "+S+R", 1)
FileSetAttrib ( @WindowsDir & "\system32\Oembios.sig", "+S+R", 1)
EndIf

End of story. Now everything works.

Share this post


Link to post
Share on other sites

gone on siginet.com... trying to download addons but the page cannot be found. someone can point me to the right way to obtain those files?

Share this post


Link to post
Share on other sites
Guest elarifr

oembios targa crc d0f94e0d

This is preactivated with a royalty key beginning by CY77C-RP923-****-****-*****

1008 TARGA, 1008 TARGA is not ok for DMI on an other pc and i can not reinstall the pc i have in hand

Bios also include TARGASYS string in F000

MGADiag report <name>TARGA GmbH</name>

removed MGADIAG / DMI REPORT / slp key

TARGASYS is working SLP String

targa_dmi_by_crystaldmi_OEM_String_type11.txt

Edited by elarifr

Share this post


Link to post
Share on other sites

elarifr, it would be great if we could add your oembios file set to our collection

update

Set verified and working fine, tested on VPC

Targa (OEMBIOS CRC=D0F94E0D)

'F000','0000','FFFF','TARGASYS'

elarifr, thx :)

Edited by FreeStyler

Share this post


Link to post
Share on other sites

Ok Now that i looked at this for a little longer and read the oemscan instructions txt I have a few questions as well as offerings.

First the offerings:

I would like to mirror the oembios repository. I currently have 2000 gb to use on my web hosting server and a matched 2000 gb monthly transfer limit.

I think if the files were offered differently it would be much easier to understand start and finish this product. I would like to 7z the oembios files in the correct directory structure with the oemscan.ini that matches for all the oembios file sets that we have. This way you could download one 7z file extract to the oemscan folder and then just remove the things you don't want instead of having to manually add all the ones you do. Maybe also i could host some tutorials on how to implement oemscan in unattended AIO DVDs for Techs and such...

Second Questions:

Why are there oembios crossed off the repository? Also the torrent files are down i know that you cant distribute them through the forum but is there any other way to get them. Also Each set of oembios files has to go in a seperate folder right? So if there are two dell sets then the Folder structure would be Dell\set1\ and Dell\set2\

PM me with any suggestions or help...

Edited by mrd05d

Share this post


Link to post
Share on other sites

Yes, I'm still alive, sorry for being AFK for so long. It looks like there is still activity for this project so I thought I'd ask, any new Feature Requests or Bug Fixes needed?

Edited by xehqter

Share this post


Link to post
Share on other sites

I have my server on a 50MB connection seeding all the availble torrents over at oembios.net. I would however suggest that we make a RyanVM intergration of all packages to make life easier for the end user.

Anyone wanna take up the challenge with me? I know siginet started it but stopped after 3-4 of them.

*edit* the reason some are crossed off is due to a more compatible revision found for the oembios files. I would also like to see a .7z utility with intergrator as well. As far as mirroring them I'm also seeding them, but having this project be on sourceforge might make it a bit easier overall.

Edited by SSX4life

Share this post


Link to post
Share on other sites

If someone could help me out with locating the oemscan addons for the integrator I would really appreciate it. The link for the older 1.4.1 are down and I could really use them for my work at a computer store. I think it would definately be helpful to others to have an addon, even if it didn't have the bios files in there and just a place to put them with the bios file name for simplicity sake. Any help would be greatly appreciated.

Share this post


Link to post
Share on other sites
Yes, I'm still alive, sorry for being AFK for so long. It looks like there is still activity for this project so I thought I'd ask, any new Feature Requests or Bug Fixes needed?

Some form of GUI that will allow you to select which packages you want to install and have them auto modify the I386\svcpack\XXX folder along with the D:\oem\oemscan.ini file accordingly. I know that autopatcher has something similar to this.

For example.

Run a standalone executable / .msi / etc.

Select which hardware you want supported in your windows install disk

Software then downloads off of one of our repositories hosted by the community (I'd volunteer)

Software then edits the oemscan.ini table + adds the corresponding folder to D:\I386\svcpack

This could be easily done outside of RyanVM intergrator but if we wanted to go the manual approach and add in these links for .7z's we could do that as well (anyone care to point me in the right direction on how to script those addons for intergrator?). I think that it would be much quicker to do it as I listed previously (same model setup as you would see from bashrat's driver pack creation tool perhaps?)

Just a few suggestions. As always I'm willing to host / seed files.

--ssx--

Edited by SSX4life

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...