Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
alfaunits

Network Functionality important components

Recommended Posts

For me, after XP SP2 and/or subsequent updates there is changed functionality/dependencies. In order to display network icon, now two more services are needed (while before I always left them disabled/taken out):

- network location awareness

- remote access connection manager.

Having the same problem

Going by GrofLuigi's post, I am missing "network location awareness" from services altogether. No services were removed on this setup, nor was the service enable/disable tab used.

All the other services listed by GrofLuigi are running and still nothing

Share this post


Link to post
Share on other sites

Yea something is messed up. The same thing happens with a USB-connected external hard drive. The drive is properly formatted and I can use it on other computers. But when I hook it up to the nlite 1.0.1 computer it installs the drivers and says that went ok but then you cannot see it in my computer at all, and there is no way to access it.

And I was very leanient with what I selected to remove. I did no network tweaks and I only selected to remove one or two services that are extremely safe to remove.

I have no clue what's going on but I cannot get this computer to work at all in any sort of operable condition using nlite.

Share this post


Link to post
Share on other sites

dale5605, well I must say you did something wrong, it's up to you to figure out what...probably some addon or update pack...or even wrong hotfix.

Anyway try new version if it helps for you when it's out.

Share this post


Link to post
Share on other sites

It says some where in nLite that don't remove it if you don't know if you need it(or something like that).

So are you unsure don't remove it. If you are unsure and still remove it and something goes wrong you'll only have you're self to blame.

Share this post


Link to post
Share on other sites
In 1.0 and 1.0.1 windows networking will only work over netbios, which means you have to have netbios installed on all your windows computers in your workgroup. which is a bit pants since netbios sucks and is considered unsafe, plus is slows down tcp/ip and isnt as fast in network transfers

In know you're talking about Server 2003 - so I'm not sure my comments apply, but . . .

NetBEUI as a transport protocol on a wired, local network, works very well -- faster than TCP/IP because of less overhead. If configured correctly is extremely safe because it is non-routable.

While Steve Gibson's "Network Bondage" page has never been updated to show the configurations for XP - it does a good job explaining the concept. http://www.grc.com/su-bondage.htm

The secrets are:

1. Install the NetBEUI protocol

(From the XP CD copy \VALUEADD\MSFT\NET\NETBEUI\NBF.SYS to the Windows\System32\Drivers directory | From the XP CD copy \VALUEADD\MSFT\NET\NETBEUI\NETBF.INF to the Windows\Inf directory | Local Area Connection Properties | Install | Protocol | NetBEUI Protocol)

[i do these steps by placing the two files in the $OEM$\$$\System32\Drivers and $OEM$\$$\Inf directories on the install disk and adding "MS_NetBEUI=params.MS_NetBEUI" to the [NetProtocols] section of the WINNT.SIF file]

2. Disable "NetBios over TCP/IP"

(In XP that's Local Area Connection Properties | Internet Protocol (TCP/IP) | Properties | Advanced | WINS | Disable NetBIOS over TCP/IP)

[i'd bet that this can be done in WINNT.SIF too, if I knew what I was doing]

3. Ensure that both Client for Microsoft Networks and File and Printer Sharing are bound to the NetBEUI protocol and NOT to TCP/IP

(in XP Network Connections | Advanced Menu | Advanced Settings | Bindings for Local Area Connection [or whatever you called it] | Uncheck "File and Printer Sharing for Microsoft Networks / Internet Protocol TCP/IP" and Uncheck "Client for Microsoft Networks / Internet Protocol TCP/IP)

[Anybody got a hint on how to do this automatically?]

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...