Jump to content

mraid35x Failing on first Reboot


JohnGruhn
 Share

Recommended Posts

I installed Dell's mraid35x mass storage drivers for Win2k3 by editing txtmode.sif and moving a makecab compressed copy of mraid35x.sys into my i386, replacing the previous versionn. I am using RIS on Win2k3 and setup runs fine, identifying my Dell 1750's raid, formatting, installing updates etc. Upon the first boot after setup however, the driver seems to be lost and I get a 0x7B BSOD. If it worked during setup, what would casuse it to not use it post setup? The relevant settings for mraid35x from my txtsetup.sif are listed below.

[SourceDisksFiles]
mraid35x.sys = 1,,,,,,4_,4,0,,,1,4

[HardwareIdsDatabase]

PCI\VEN_101E&DEV_9010 = "mraid35x"
PCI\VEN_101E&DEV_9060 = "mraid35x"
PCI\VEN_8086&DEV_1960&SUBSYS_11121111 = "mraid35x"
PCI\VEN_8086&DEV_1960&SUBSYS_11111111 = "mraid35x"
PCI\VEN_8086&DEV_1960&SUBSYS_09A0101E = "mraid35x"
PCI\VEN_8086&DEV_1960&SUBSYS_11111028 = "mraid35x"
PCI\VEN_8086&DEV_1960&SUBSYS_04671028 = "mraid35x"
PCI\VEN_101E&DEV_1960&SUBSYS_04711028 = "mraid35x"
PCI\VEN_101E&DEV_1960&SUBSYS_04931028 = "mraid35x"
PCI\VEN_101E&DEV_1960&SUBSYS_04751028 = "mraid35x"
PCI\VEN_1028&DEV_000E&SUBSYS_01231028 = "mraid35x"
PCI\VEN_1028&DEV_000F&SUBSYS_013B1028 = "mraid35x"
PCI\VEN_1028&DEV_000F&SUBSYS_014A1028 = "mraid35x"
PCI\VEN_1028&DEV_000F&SUBSYS_014C1028 = "mraid35x"
PCI\VEN_1028&DEV_000F&SUBSYS_014D1028 = "mraid35x"
PCI\VEN_101E&DEV_1960&SUBSYS_05111028 = "mraid35x"
PCI\VEN_1000&DEV_1960&SUBSYS_05181028 = "mraid35x"
PCI\VEN_1000&DEV_1960&SUBSYS_05201028 = "mraid35x"
PCI\VEN_1028&DEV_0013&SUBSYS_016C1028 = "mraid35x"
PCI\VEN_1028&DEV_0013&SUBSYS_016D1028 = "mraid35x"
PCI\VEN_1028&DEV_0013&SUBSYS_016E1028 = "mraid35x"
PCI\VEN_1028&DEV_0013&SUBSYS_016F1028 = "mraid35x"
PCI\VEN_1028&DEV_0013&SUBSYS_01701028 = "mraid35x"
PCI\VEN_1000&DEV_0408&SUBSYS_00011028 = "mraid35x"
PCI\VEN_1000&DEV_0408&SUBSYS_00021028 = "mraid35x"

[SCSI.Load]
mraid35x = mraid35x.sys,4

[SCSI]
mraid35x = "AMI MegaRaid RAID Controller"

-- Gruhnj

Link to comment
Share on other sites

  • 2 weeks later...

Try to remove previons mraid35x lines on txtsetup.sif in SCSI, SCSI.Load, HardwareIdsDatabase, SourceDisksFiles.

Two different device, two different file, two different HVId sets - one sys file name.

Link to comment
Share on other sites

  • 2 weeks later...

Hi!

I am also using the mraid35x.sys file for Windows 2003 SP1 (version 6.41.2.32) which I have copied to my i386 (not compressed) and this is what I have in my txtsetup.sif. It's all working smoothly:

[SourceDisksFiles]
mraid35x.sys = 1,,,,,,_x,2,0,0

[HardwareIdsDatabase]
PCI\VEN_1028&DEV_000F&SUBSYS_014D1028 = "mraid35x"
PCI\VEN_1028&DEV_000F&SUBSYS_014C1028 = "mraid35x"
PCI\VEN_1028&DEV_000F&SUBSYS_014A1028 = "mraid35x"
PCI\VEN_1028&DEV_000F&SUBSYS_013B1028 = "mraid35x"
PCI\VEN_101E&DEV_9010 = "mraid35x"
PCI\VEN_101E&DEV_9060 = "mraid35x"
PCI\VEN_8086&DEV_1960&SUBSYS_0438101E = "mraid35x"
PCI\VEN_8086&DEV_1960&SUBSYS_0466101E = "mraid35x"
PCI\VEN_8086&DEV_1960&SUBSYS_0467101E = "mraid35x"
PCI\VEN_8086&DEV_1960&SUBSYS_0490101E = "mraid35x"
PCI\VEN_8086&DEV_1960&SUBSYS_04671028 = "mraid35x"
PCI\VEN_8086&DEV_1960&SUBSYS_11111028 = "mraid35x"
PCI\VEN_8086&DEV_1960&SUBSYS_10C6103C = "mraid35x"
PCI\VEN_8086&DEV_1960&SUBSYS_10C7103C = "mraid35x"
PCI\VEN_8086&DEV_1960&SUBSYS_10CC103C = "mraid35x"
PCI\VEN_8086&DEV_1960&SUBSYS_10CD103C = "mraid35x"
PCI\VEN_8086&DEV_1960&SUBSYS_11111111 = "mraid35x"
PCI\VEN_8086&DEV_1960&SUBSYS_11121111 = "mraid35x"
PCI\VEN_8086&DEV_1960&SUBSYS_03A2113C = "mraid35x"
PCI\VEN_8086&DEV_1960&SUBSYS_0471101E = "mraid35x"
PCI\VEN_101E&DEV_1960&SUBSYS_0471101E = "mraid35x"
PCI\VEN_8086&DEV_1960&SUBSYS_0493101E = "mraid35x"
PCI\VEN_101E&DEV_1960&SUBSYS_0493101E = "mraid35x"
PCI\VEN_8086&DEV_1960&SUBSYS_0475101E = "mraid35x"
PCI\VEN_101E&DEV_1960&SUBSYS_0475101E = "mraid35x"
PCI\VEN_101E&DEV_1960&SUBSYS_04751028 = "mraid35x"
PCI\VEN_8086&DEV_1960&SUBSYS_04711028 = "mraid35x"
PCI\VEN_101E&DEV_1960&SUBSYS_04711028 = "mraid35x"
PCI\VEN_8086&DEV_1960&SUBSYS_04931028 = "mraid35x"
PCI\VEN_101E&DEV_1960&SUBSYS_04931028 = "mraid35x"
PCI\VEN_101E&DEV_1960&SUBSYS_60E7103C = "mraid35x"
PCI\VEN_101E&DEV_1960&SUBSYS_60E8103C = "mraid35x"
PCI\VEN_101E&DEV_1960&SUBSYS_60E3103C = "mraid35x"
PCI\VEN_1028&DEV_000E&SUBSYS_01231028 = "mraid35x"
PCI\VEN_1000&DEV_1960&SUBSYS_05201028 = "mraid35x"
PCI\VEN_1000&DEV_1960&SUBSYS_05181028 = "mraid35x"
PCI\VEN_1000&DEV_1960&SUBSYS_05181000 = "mraid35x"
PCI\VEN_1000&DEV_1960&SUBSYS_05201000 = "mraid35x"
PCI\VEN_1000&DEV_1960&SUBSYS_A5201000 = "mraid35x"
PCI\VEN_1000&DEV_0407&SUBSYS_05301000 = "mraid35x"
PCI\VEN_1000&DEV_0407&SUBSYS_05311000 = "mraid35x"
PCI\VEN_1000&DEV_0407&SUBSYS_05321000 = "mraid35x"
PCI\VEN_1000&DEV_1960&SUBSYS_45231000 = "mraid35x"
PCI\VEN_1000&DEV_1960&SUBSYS_05231000 = "mraid35x"
PCI\VEN_1028&DEV_0013&SUBSYS_016C1028 = "mraid35x"
PCI\VEN_1028&DEV_0013&SUBSYS_016D1028 = "mraid35x"
PCI\VEN_1028&DEV_0013&SUBSYS_016E1028 = "mraid35x"
PCI\VEN_1028&DEV_0013&SUBSYS_016F1028 = "mraid35x"
PCI\VEN_1028&DEV_0013&SUBSYS_01701028 = "mraid35x"
PCI\VEN_1000&DEV_0408&SUBSYS_00021028 = "mraid35x"

[SCSI.Load]
mraid35x = mraid35x.sys,4

[SCSI]
mraid35x = "AMI MegaRaid RAID Controller"
mraid35x = "DELL PERC 4/Di RAID On Motherboard Driver"
mraid35x = "DELL PERC 4e/Di RAID Controller Driver"
mraid35x = "DELL PERC 4e/Si RAID Controller Driver"
mraid35x = "DELL PERC 4/DC RAID Controller Driver"

And yeah, I know, my driver is located in the Windows\System32 dir... :angel

Hope it helps!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...