Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
clivebuckwheat

Ok what am I doing wrong...

Recommended Posts

specifically French (Canada) Canadian French Keyboard.

Can someone point me into the right direction.

:whistle:

Edited by clivebuckwheat

Share this post


Link to post
Share on other sites

Hi clivebuckwheat,

For more info check this...

and here you'll find a list of all the locale IDs for winXP/2003...

Or just add or edit in your /i386/winnt.sif file the line below

[RegionalSettings]
Language = "0409:00000409"
SystemLocale = "0409:00000409"
UserLocale = "0409:00000409"
InputLocale = "1009:00000409", "0409:00000409"

The last line sets default keyboard the Canadian_English and you can switch (Alt+Shift) to Canadian_French... ;)

Edited by Jaco...

Share this post


Link to post
Share on other sites

I Have no Idea of what I am doing wrong

I need the following

Input Language:

English (Canada) U.S. Keyboard layout (default)

French (Canada) Canadian French Keyboard

untitled7fx.jpg

here is my winnt.sif

[RegionalSettings]

SystemLocale = "0409"

UserLocale = "0409"

UserLocale_DefaultUser = "0409"

InputLocale = "0409:00000409", "1009:00011009"

InputLocale_DefaultUser = "0409:00000409"

I don't see my error. why am i getting canandian english?

Edited by clivebuckwheat

Share this post


Link to post
Share on other sites

You can use the sysprep from the windows deployment tools.

Share this post


Link to post
Share on other sites
I need the following

Input Language:

English (Canada) U.S. Keyboard layout (default)

French (Canada) Canadian French Keyboard

here is my winnt.sif

[RegionalSettings]

SystemLocale = "0409"

UserLocale = "0409"

UserLocale_DefaultUser = "0409"

InputLocale = "0409:00000409", "1009:00011009"

InputLocale_DefaultUser = "0409:00000409"

I don't see my error. why am i getting canandian english?

because 1009 is canadian english

if you want French Canadian use 0c0c instead of 1009

why do you not want to read Windows XP/Server 2003 - List of Locale IDs, Input Locale, and Language Collection ? :)

Edited by laura

Share this post


Link to post
Share on other sites

Ok I am almost there

I got my

English (Canada) - US Keyboard

French (Canada) - Canadian French Keyboard.

My question is why am I getting.

English (United States) - US Keyboard. I don't want this.

Below is a copy of my winnt.sif

[RegionalSettings]
SystemLocale = "1009"
UserLocale = "1009"
UserLocale_DefaultUser = "1009"
InputLocale = "1009:00000409" ,"0c0c:00001009"
InputLocale_DefaultUser = "1009:00000409"

Share this post


Link to post
Share on other sites

English_Canadian= 1009 I want this

I want to get rid of English (United States) - US Keyboard

I don't see where it is coming from?

Share this post


Link to post
Share on other sites

Uh I'm sorry for my silly post, I ment setupmgr.exe

It can generate exact sif code for you.

Once again sorry for posting in a hurry.

Share this post


Link to post
Share on other sites

I have all the keyboards I need.

It is just that I don't want the

English (United States) - US Keyboard

if someone could look at my winnt.sif and tell me it would be greatly appreciated. I been 4 days on this problem.

Share this post


Link to post
Share on other sites

To delete the English (United States) US Keyboard.

I did

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Keyboard Layout\Preload]

"1"="00001009"

"2"="00000c0c"

[HKEY_CURRENT_USER\Keyboard Layout\Preload]

"3"=-

1. is english canada

2. is French Canadian

3. Is blank but it was English (United States) US Keyboard.

special thanks to Dje for this trick

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...