Jump to content

how to disable the annoying "http://runonce.msn.com/runonce2.aspx


chee
 Share

Recommended Posts

I found a really easy quick fix. Just right click on http://runonce.msn.com/runonce2.aspx since this is the target. The page should open correctly. When there, make all corrections then click save changes. Close your internet explorer windows and click your IE icon to reopen. It should work just fine. At least on my two computers it did. Do tinkering with the registry!

Mike

I found a really easy quick fix. Just right click on http://runonce.msn.com/runonce2.aspx since this is the target. The page should open correctly. When there, make all corrections then click save changes. Close your internet explorer windows and click your IE icon to reopen. It should work just fine. At least on my two computers it did. Do tinkering with the registry!

Mike

Opps! I mean NO tinkering with the registry!

Link to comment
Share on other sites


Open IE7, then Click the tool button on the upper right side of browser. From the Manage Add-ons menu select “Enable or Disable Add-ons”. You should be looking at the add-ons currently loaded window. Now look for any add-ons with names that might appear to support your ant-virus, spy ware, or popup blocker software.

Example: I use Freedom all in one anti-virus software, which is produced by zero-knowledge and had to add-ons containing the name zero-knowledge.

I disabled them, restarted browser, completed the runonce screen and then enabled them again and everything works perfect.

This trick may also help those who are having trouble with Musicmatch and Roxio – Cd Creator (by disabling any add-ons associated with the software).

Link to comment
Share on other sites

The only way I found to get rid of http://runonce.msn.com/runonce2.aspx is to start Internet explorer from Start/All Programs/Accessories/System Tools/Internet Explorer (no add ons). Once you launch IE you put the following address in the address window. http://runonce.msn.com/runonce2.aspx. Select your choices and go to the bottom of the page to submit. Once finished you will be back to your normal start page.

Edited by allen1y
Link to comment
Share on other sites

Hello

I've joined the forum for the express purpose of thanking you all for giving us the fix to this situation. This problem has been p***ing us off ever since a 'not specifically denied' automatic update to IE (7.0.5346.5 Beta 2) presented itself for approval. (Denied). But 1 restore point and 2 new DWORDS later and we're BAU. Thanks to all.

rapato wollongong Australia

Link to comment
Share on other sites

I was having this same problem on IE6, it was going to "about:blank".

I deleted the entry that causes this and it still did it. It was because

I was only editing the HKEY_LOCAL_MACHINE part of the registry and

it is in HKEY_CURRENT_USER!

All I had to do was change the "Start Page" entry to Google's address.

Make sure you change it in the HKCU though not just HKLM. :blushing:

Link to comment
Share on other sites

After having this problem with our second computer and reading all the suggested solutions, I found a very simple solution. When first opening explorer, it will go to a site something like http://go.microsoft.com/fwlink/?LinkID=XXXXX, where X is a string of numbers. Close explorer. Then go to start-all programs-accessories-system tools-internet explorer(no add-ons). This opens explorer in a new window. Enter the address that explorer first tries to access, and enter. Voile! The set up site should appear where you can set the defaults, and problem solved! No need to add, delete, adjust any registry values or change any program settings. The problem apparently is caused by an add-on, such as an active-X control or something, which I haven't found, but IE now goes right to the home page.

Link to comment
Share on other sites

Being semi-computer literate I tried this after my runonce.msn.com/runonce2.aspx simply remained that certain shade of blue... It took a second or two of "connecting" and although it appeared to load nothing appeared on the screen. If you have this problem, try clicking anywhere on the blue screen and then click CTRL+A (ie or edit / select all) and then open Word or similar word processor. Paste into it and you'll see the page come up... no idea why this is so, but now you can see what should have loaded, albeit not layed out the same way. The first link is for editing the settings. If you cannot double click it to go to a browser window, right click instead and select edit hyper link or edit url link depending on your software. The link (java..etc) appears and cut & paste this into the browser window. In my case this brought the correct page up. I selected my options and saved them. After the closing & opening of IE7 I was back to my good ol' goggle.co.uk home page ;-).

Hope it works for some.

Link to comment
Share on other sites

  • 3 weeks later...

To prevent RunOnce from loading.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]

"RunOnceComplete"=dword:00000001

"RunOnceHasShown"=dword:00000001

Also posted in my Tips and Tricks

I just become a member here....I just wanted to say thank you thank you!

the above instructions "fixed" my problem

~yorky~

I would like to confirm this, RunOnce* is NOT a value under HKLM - it only exisits under HKCU. My system doesn't have a problem, but for those who do:

Windows Registry Editor Version 5.00

[HKCU\Software\Microsoft\Internet Explorer\Main]
"RunOnceComplete"=dword:00000001
"RunOnceHasShown"=dword:0000000

Save as IE7FIX.REG and run it.

For those who manually open Regedit and are not familiar with it - KEYS are FOLDERS, and the things inside the Keys are the VALUES (whereas normally files are inside values). Each value contains DATA. For instance:

"HKCU\Software\Microsoft\Internet Explorer\Main" is a KEY.

"RunOnceComplete" is a VALUE.

"dword:00000001" is DATA.

You could also do this with a batch (.CMD or .BAT) file:

REG ADD "HKCU\Software\Microsoft\Internet Explorer\Main" /V "RunOnceComplete" /T REG_DWORD /D 1 /F

REG ADD "HKCU\Software\Microsoft\Internet Explorer\Main" /V "RunOnceHasShown" /T REG_DWORD /D 1 /F

Thank YOu Very much This was the easiest solution for us that do not know a lot about registry thank you!!!!!!!

Edited by rabanito172
Link to comment
Share on other sites

  • 2 weeks later...
  • 4 months later...
Using the IE7 final, the last message posted does not fix the problem listed.

After a little playing, I did find the solution to the problem. It does require that you make the change recommended in the last post (Or in my case, it did not exist, so I had to create the DWORD).

IN ADDITION to what the last post recommends, you should also create the following DWORD in HKCU>Software>Microsoft>Internet Explorer>Main:

RunOnceComplete

Set it to 1

This FIXED it for me! Hopefully this will fix it for everyone else having the same problem.

Good luck!

Hey Friends!! I Just navigated to this forum in search for the answer to this problem, and FOUND IT!! Thanks for your knowledge..

Artaban... form Venezuela.. :thumbup

Link to comment
Share on other sites

Hello All,

I registered to this site in hopes of fixing the IE problem with runonce. I tried to edit the Registry but I dont have the RUNONCE VALUE when I go to HKEY_CURRENT_USER - SOFTWARE - MICROSOFT - IE - MAIN

Is there a reason why RUNONCECOMPLETE isnt listed?

Link to comment
Share on other sites

  • 1 month later...

downloded the ie7 beta from microsoft and got runounce.msn for the home page went to change it to my homepage and got 4 trojun dialers was able to delete 3 and finally had to format and reinstall windows how do i get rid of this anoing thing?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...