Jump to content

WPI 5.0rc2 Bug Reports

Recommended Posts

Tooltip bug: every tooltip should have a z-index declared.

Or it may happen something like this:


Edit: Hm .. I see a z-index declared. I don't know why that happens and I don't have time to search any further.

Edited by sadicq
Link to comment
Share on other sites

no bug , just an old problem who still exist

with no_column_break_in_categories checked :

if i have 20 categories , each with 14 programs

but 13 of them in every category hided (cond[]=false) ,

wpi will show 20 programs in 20 columns (1program x 20categories)

(7 pages with 3 columns) each column with only one program listed

wpi still preserve space in columns for ALL programs in a category

i dont know if is easy to count the programs in a category

AFTER the cond[] is evaluated ...

I can't reproduce the problem. Can you send me your config?

Edited by sadicq
Link to comment
Share on other sites

2 small issues:

1- If the 1st category is called 'Applications', it isn't displayed, neither its content!

2- not exactly a bug as it is mentioned as 'option removed' in the changelog, but I'm a bit annoyed by the mandatory sorting of the elements of a category:

- I have 2 items: Firefox Profile & Firefox Extensions.

- Extensions are installed to the Profile. So the above order is the right one!

- Still it is displayed in the reverse order (alphabetic).

I know that it's not an issue for installation since I can falsify the sorting option for installing, but I'd like to have the display matching what will be done later (WYSIWYG).

Link to comment
Share on other sites

Sorry, I did not explain it well:

my Sort Order is empty as I already feed WPI the progs in the order I want. So I don't bother using this option.

When I was writing 'first', it meant that the first prog's category was 'Applications'. See attached config.js (taking the same stuff as example...).

Now the thing is: with any other string -including "applications" (please note that this one is not capitalized)- it works flawlessly. No problem also if there is another prog before in another category.

BTW, there's another strange error message if I ever try to edit this config inside WPI (try it yourself to see it). Not that I need it (choosing and installing progs work fine and I use another tool to edit config.js), but that may be the sign that I could improve my application for writing config.js. If ever you have any hint...


Link to comment
Share on other sites

It took me awhile but I figured out what was wrong with Dje's config file. I am posting it here also so everyone knows:

prog[pn]=[]; MUST be the first line of each entry in your config.js.

Dje had it as the second. It threw off the way WPI counts the entries, therefore messed up the configList[] array.

Edited by mritter
Link to comment
Share on other sites

Oups, sorry!

I've just changed that and passed uid[pn]=[]; first because of my new injection thing.

It works fine (with or without injection) for display and install. Only the configwizard broke.

But I can have uid[pn]=[]; in between prog[pn]=[]; and the injection stuff (prog[pn][0]+='...';)

So it's ok. Thanks again and sorry to have make you spend your time on this.

And the injection also breaks the configwizard, not so surprisingly!

But that is not a WPI bug!

Link to comment
Share on other sites

Mritter, I confirm the bug for the 'Applications category' thing:

- I downloaded the vanilla WPI and ran it. Of course no prog is showing up since the config is empty (no config.js -nor useroptions.js for that matter).

- Then I went to WPI's config editor. Typed a prog entry. -> category is set BY DEFAULT to Applications.

- Typed a command for that entry, saved and exit the editor. -> The prog is not showing up in WPI's main window!

Link to comment
Share on other sites

bugs still reports here ?

...I can't reproduce the problem. Can you send me your config?
i will made a file for you , to study, after my uA_DVD this month

all my entries in config.js have fileexist as cond[] , so you cannot view something..

without programs in their locations

old minor bug, no rush...

Link to comment
Share on other sites

no sound here ! RC2 had.

sorry ! in this moment RC2 il also without sound.

my last night install is :realmad:

MP10 do not recognize .mid, .wav !??? :blushing:

i change only alanoll winamp kit ?

i wil have a long night... :angry:

Edited by oneless
Link to comment
Share on other sites

Your fix might work, but it is not the source of the problem. Your solution will always put the new entry at the top of the list. Fine. But the real problem is when WPI reads the config file, if the array is blank, InstallAudio=[''], that is where the blank line is getting thrown in. It has a length if 1, but it really is empty. WPI has done this method of saving/reading for as long as I have been around; it just needed some tweaking.

If you want to test your mod installer, here is the updated code for optionswizard.js:

if (opt=="WPIAudio") 
if (WPIAudio.length==1 && WPIAudio[0]=="") <---- These 2 lines


if (opt=="InstallAudio") 
if (InstallAudio.length==1 && InstallAudio[0]=="") <----- These 2 lines

Link to comment
Share on other sites

I've been trying RC2 as part of my UA CD to install apps for Windows XP SP2.

The same config.js that works for v4.3.8 does not work for v5.2rc2.

There are several problems:

1. Most of the commands involving nircmd.exe or taskill fail.

The only difference I can see is that working commands (apart from mostly being cmd[1]) look like this:

Cmd1 Success: 'D:\DVD-Apps\IZArc35.exe' '/S /verysilent /silent'

whereas failing ones look like this:

'D:\DVD-Tools\nircmd.exe execmd move "~$folder.common_programs$\IZArc" "~$folder.common_programs$\Archivers\IZArc"' ''

The config.js responsible for this example is:

prog[pn]=['IZArc 3.5']
desc[pn]=['IZArc is a free archiving tool that suports many archive formats. It allows you to drag and drop files from and to Windows Explorer, create multiple archives spanning disks, view and write comments.']
cmd1[pn]=['%CDROM%\\DVD-Apps\\IZArc35.exe /S /verysilent /silent']
cmd2[pn]=['%CDROM%\\DVD-Tools\\nircmd.exe execmd move "~$folder.common_programs$\\IZArc" "~$folder.common_programs$\\Archivers\\IZArc"']

A minor problem is that if I set the timer to 600 seconds it counts down from 0:599 ... to 0:00, but I think someone has already reported that.

Another more serious problem is that the installation always reboots at about the same place, for no obvious reason. In the example log I append below, the reboot happens after MS AntiSpyware installs but before Foxit does. I've tried a few times and removing the "suspect" program does nothing - it still reboots at roughly the same place.

Is there any way of tracking down why it reboots?

I don't think it is time based as I set an install off this morning and it was waiting for me to sort out yEnc (the AutoIt I wrote isn't so good!), and it rebooted shortly after I sorted yEnc tonight, 8 hours later.

Here's the log in case it helps with some of these issues


Edit: Log removed - 5.0 Final seems to have fixed all these issues.

Edited by deadbug
Link to comment
Share on other sites

Man, can't you just attach the file to keep this thread readable...

Please edit your post.

Most of your probs, if not all, have been solved in 5.0 final. Check it out and report any remaining flaw.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...