Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


cancerface

[beta] User Creation Tool

Recommended Posts


I used this tool in the past and it works great! But I was wondering if a tool exists to just give a computername, computer owner and domain to join. The creation of a user is not needed where it's a domain user that logs in.

We have different domains.

Thanks for your support!

Edited by Kingskawn

Share this post


Link to post
Share on other sites

@Kingskawn

I am not aware of any tools that will give a GUI for what you are after, however, you could use something like netdom.exe from the 2000 support tools to join the domain.

What you may want to try is running the user creation tool of this thread (from cmdlines) with only ParseComputerSection set to 1 (so that no UserInfo and Security info will be active/parsed), get a GUI for generating the computer account (in a workgroup) then after rebooting you can call netdom.exe in order to join the domain:

netdom join COMPUTERNAME /domain:DOMAIN /userd:DOMAIN\USERID /passwordd:PASSWORD

with USERID and PASSWORD the username and password of a domain account with privileges to add computers to the domain. The downside of this is that you need to supply the username and password in a cmd script in order to join the domain.

I played around a bit with advapi32 and there are functions that will join a computer to the domain, however, modifying the user creation GUI to accommodate that functionality would be rather involved ...

[placed on my list of things to do]

:rolleyes:

CF

Share this post


Link to post
Share on other sites

@cancerface: I've looked for that netdom.exe but it seems that the name have to be hard coded.

What I want is when I install a new computer a screen must popup asking me a camputername, computer owner and the domain to join. So I have to do that on several machines.

Share this post


Link to post
Share on other sites
I've looked for that netdom.exe but it seems that the name have to be hard coded.
?

I am not in a AD environment so I cannot really test this ... But my understanding after reading the netdom.exe discription is that it is able to join your machine to a domain if you supply it with the machine's name and have enough privileges to do so. As for the name, this is something that you can do using the tool of this thread. You can even add a list of different names based on the MAC address of each PC you would like to name and the tool will pick the appropriate name each time. This is supported right now. There is no support for joining an AD tree as this requires a lot more checking and I have not written the code yet + it is difficult to do so when you cannot test it ...

My idea was that you can get a GUI for the name and a temporary workgroup, then after rebooting run netdom.exe to join the domain.

So for example in the GUI part you get to specify the name, then after rebooting get the name (by using wmic or any other way you know off), place it in an environmental variable then pass it to netdom.exe with your domain name.

I am sorry, but I do not know of any tool that will do what you are after with a GUI ...

CF

Share this post


Link to post
Share on other sites

Hello guys,

in XP SP3 I get an error using this tool: The just created users Password will not be adopted. Loggin in works only with a blank passowrd although a password was given in with the tool.

Any solutions?

Grz

Supergudrun

Edited by supergudrun

Share this post


Link to post
Share on other sites

@supergudrun

Not sure where you fail to login with the generated user.

Just deployed a freshly integrated SP3 disc and called the create user tool from T12 as always. The user was successfully created and autologin worked as expected. I did not use a blank password. Same result if I use the PasswordCheck flag in order to generate a user with a blank password...

Have you ever used this tool with an SP2 install without any problems? If not, I suggest having a look at the INI file, maybe you missed something there?

CF

Share this post


Link to post
Share on other sites

I do the translation to spanish because i think this is a nice script.

In my native language (Spanish) its fail when try to change the default account Administrator (maybe because in Spanish is "Administrador"?)

I edit this post with the translation file, thanks for this little tool cancerface.

Edit:

I have a question:

I translated 90% of the strings but there are variables with $xxxxx$ and 'xxxxxx', that strings has to be translated or not?

Edited by iperoni

Share this post


Link to post
Share on other sites

@iperoni

Glad you like it :hello:

Check this part of the thread and download the file with the English strings. If you post here a file with the spanish translation (in ANSI) I can implement it into the main executable and change the dimensions of the interface to accommodate the Spanish button labels.

You need to edit both the InterfaceEN.ini and LangStringsEN.txt files. The $xxxxx$ entries are variables so you do not need to edit them.

The program should not fail to change the default Administrator account in any language as it looks for accounts by their SID which is language independent. However if you are logged using the Administrator account and then you try to change the name of that account, the process will fail ...

CF

Share this post


Link to post
Share on other sites

Thanks for the translation iperoni :thumbup

Updated first post to v.1.7.1 adding Spanish language support to the GUI

Enjoy :hello:

CF

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...