Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


cancerface

[beta] User Creation Tool

Recommended Posts

Well, unless you specified username=Administrator in the INI file or set the name to administrator in the GUI I do not see how the program can write the wrong value in the registry...

Are you sure that commenting the winnt.sif values out is the same as deleting them? I do not know if this is the case to be honest. Another way to test this is to use EncryptedAdminPassword = Yes

which disables autologon, if I am not mistaken ...

All I can tell you is that the program gets a value from the INI file, places it in the GUI, then takes the same value (username) from the GUI and places it in the registry. I cannot see how the wrong value can make it to the registry :no:

CF

Share this post


Link to post
Share on other sites

@ vertigo

I set DisableAdmin to 1, in my INI. This is a snippet of my (working) NewUser.ini:

[userInfo]FirstName=SomeName

LastName=

Description=System Administrator

UserName=SomeName (same name as the FirstName)

Password=123 (same PW in WINNT.SIF)

UnlimitedPass=1

AutoLogon=1

Admin=1

[securityInfo]

FakeAdmin=0

FakeGuest=0

RenameAdmin=1

RenameGuest=1

DisableAdmin=1

ForcedLogon=1

NewAdminName=ADMIN

NewGuestName=GUESS

HideNewAdmin=0

Also, search your reg files (tweaks) and your CMD files for "Administrator".

You might insert it somewhere! Sometimes, I forget to update my tweaks and CMDs to suit a new routine.

Or, you might use another software that logs "Administrator" on automatically.

Are you sure that commenting the winnt.sif values out is the same as deleting them?

Yes!

Edited by mazin

Share this post


Link to post
Share on other sites

OK, finally I managed to do it right. I did 2 tests. Firstly I changed winnt.sif entries to

[GuiUnattended]
AdminPassword=d90asd8098vxcvx9084234...
EncryptedAdminPassword=Yes

but that didn't help.

Then I removed all commented lines from winnt.sif and moved CreateUser.exe from T13 svcpack (7z-sfx) to T12 cmdlines ($OEM$) and everything went fine. I don't know exactly what was the problem, maybe the autologon entry was overwrriten somehow by the windows setup when I used to run the tool from svcpack. Soon I will try to do more tests.

EDIT1:

I did another test and it seems that CreateUser.exe should be run only from T12 cmdlines.txt.

Cheers

Edited by vertigo

Share this post


Link to post
Share on other sites
1) when I have an occurance of CreateUser with only the computer info enabled the parameters are greyed out till I toggle the "Computer Details" box.
Oups! Yes, that behaviour should not be there... In fact the same happened if only the Security Section is enabled. Tracked the error down and fixed it!

Updated to v1.6:

v.1.6 Changelog

  • Rewrote the function that checks for admin privileges
  • Fixed an error that would hide fields although the Parse[]Section flag was on
  • Added support for Turkish (thanks KenanBalamir!) & Greek languages (Interface + message boxes)

Updated first post and uploaded the new version

Thanks man! But, Cancel button caption is wrong.

post-52297-1161547706_thumb.jpg

Vazgeç is not correct.

Vazgeç is correct.

Thanks again.

~Kenan

Edited by KenanBalamir

Share this post


Link to post
Share on other sites

Sorry guys I have all time some error or SDI.

Thisone new version do not wor for me 1.4-1.6 otherone work good.

Share this post


Link to post
Share on other sites

Hi,

Excellent tool - although I found something strange happening when installing completly unattended.

I setup basic username / compname / etc but changed Timeout=30000 and nothing happened after

30 secs - press GO worked OK.

Next install changed Timeout=20000 worked perfect

Strange eh!

PS:Run from normal desktop with only change comp info on 2 machines - same thing

Share this post


Link to post
Share on other sites

:blushing:

Not discontinued, nor abandoned, I am just up to my neck with things to do.

I think I will have some time during the weekend to update this, adding the French lang support etc.

@KenanBalamir

I think that the cancel button label is embedded in my nsis compiler like that, I will look into it and post a request for a fix in the NSIS forums.

@colc

I will play around with this and see if it is a bug indeed

@Yurek3

Can you provide any info on the reason why these versions do not work for you? Maybe I could upload a debug version for you and we could track the problem down ...

@vertigo

Hmmm... I have been running from cmdlines without any problems and I have tested from svcpack without problems as well. Maybe it is indeed something else in your setup that overwrites the autologon entry?

CF

Share this post


Link to post
Share on other sites
:blushing:

I am just up to my neck with things to do.

Are you sick ? I hope you'll get better soon.

:blushing:

Not discontinued, nor abandoned

@KenanBalamir

I think that the cancel button label is embedded in my nsis compiler like that, I will look into it and post a request for a fix in the NSIS forums.

That's great! Thanks for care..

Kenan

Share this post


Link to post
Share on other sites

Hi, I just discovered this wonderfull tool for usercreation.

I've searched the 10 pages of this topic but didn't find out how to use

'InterfaceFR.ini' to see the program in French.

Also I don't want to fill in a password, so I set CheckValues=0

and there's always a popup that says 'fill in all the fields'.

Why is this ?

Someone could help me please ? THX

Edited by DJPro

Share this post


Link to post
Share on other sites

@DJPro

The French strings are not yet implemented. Once I include the strings in the main EXE, it will automatically detect your language and will swap to French if necessary

The password by design is checked regardless of the CheckValues variable. It cannot be empty.

If however you feel that this may be needed, I can add another switch so that password checking can be omitted (which is a BAD idea, especially if the two passwords do not match) ...

CF

Share this post


Link to post
Share on other sites

I would like the switch for the password, because I never use passwords on unattended installs.

Maybe you can set the passwordfield so that the '*' are readable and you can check if it's correct. (if you think this is a good idea?)

Anyway I'll wait for a future release with the language files.

Thanks for the fast reply, CF !

Share this post


Link to post
Share on other sites

After a loooong delay I managed to get some time and updated this little tool with the latest lang strings ...

Updated to v1.7:

v.1.7 Changelog

  • Added French GUI support (thanks kSaMi!)
  • Added PasswordCheck switch to disable password checking and force a blank password

As always comments/suggestions are welcome

Updated first post and uploaded the new version

Enjoy :)

CF

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...