Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
wreakhavoc

"Security Alert" pop up

Recommended Posts

Since installing the unofficial service pack I am getting a "Security Alert" window explaining something about certification and asking if I'm sure I want to proceed etc. whenever I go to a site where I have to enter my user-name and password. How can I disable this major annoyance? I asked elsewhere and was told to check the tools>internet options settings on IE but that didn't help either.

Share this post


Link to post
Share on other sites

Tools -> Internet Options -> Advanced

One of the settings under the Security section.

Share this post


Link to post
Share on other sites
Tools -> Internet Options -> Advanced

One of the settings under the Security section.

Thanks but as I said I already did that and am still getting the pop-up. Here is a screen capture of what I have unchecked:

security0pi.jpg

Share this post


Link to post
Share on other sites

One more location to check - this is under the Security tab, select Internet zone and then click Custom Level:

n15zm.png

Share this post


Link to post
Share on other sites
One more location to check - this is under the Security tab, select Internet zone and then click Custom Level:

OK, I tried that too but still getting the alert every time. What else could it possibly be? Something in the registry?

Share this post


Link to post
Share on other sites
Since installing the unofficial service pack I am getting a "Security Alert" window explaining something about certification and asking if I'm sure I want to proceed etc. whenever I go to a site where I have to enter my user-name and password. How can I disable this major annoyance? I asked elsewhere and was told to check the tools>internet options settings on IE but that didn't help either.

Is it possible to make a screenshot or write EXACTLY what is written in this window? "something about certificates" is not very good description.

"whenever I go to a site where I have to enter my user-name and password." - does it mean that it is just when you go to specific login page? What is the URL? Does it start with "https://"? What Internet browser do you use? Internet Explorer, FireFox, Opera? And what version? Original Internet Explorer 5.0 contains expired certificates but the unofficial servicepack contains new ones.

Petr

Edited by Petr

Share this post


Link to post
Share on other sites

Try downloading the newly revised Root Certificates Update here:

http://download.windowsupdate.com/msdownlo...en/rootsupd.exe

and run it to see if it goes away. If not, you may need to contact the webmaster of the web site that displayed the Security Alert message about certificates. as Petr said, show us precisely what kind of Security Alert you received.

Share this post


Link to post
Share on other sites
Is it possible to make a screenshot or write EXACTLY what is written in this window? "something about certificates" is not very good description.

"whenever I go to a site where I have to enter my user-name and password." - does it mean that it is just when you go to specific login page? What is the URL? Does it start with "https://"?'>https://"? What Internet browser do you use? Internet Explorer, FireFox, Opera? And what version? Original Internet Explorer 5.0 contains expired certificates but the unofficial servicepack contains new ones.

Petr

It only happens with IE. (I'm using IE 6 and never got this pop-up until I installed the package) There are too numerous URL's to list- yes, some start wth "https://"

Here it is:

sa4tp.jpg

Edited by wreakhavoc

Share this post


Link to post
Share on other sites
It only happens with IE. (I'm using IE 6 and never got this pop-up until I installed the package) There are too numerous URL's to list- yes, some start wth "https://"

This dialog appears ONLY for "https://" URLs.

Have you try to refresh the list of root certificates by rootsupd package as suggested by erpdude8?

If you click "View Cerificate" - who is the issuer?

Petr

Share this post


Link to post
Share on other sites
This dialog appears ONLY for "https://" URLs.

Have you try to refresh the list of root certificates by rootsupd package as suggested by erpdude8?

If you click "View Cerificate" - who is the issuer?

Petr

Yes I did that but am still getting the alert. Clicking "View certificate" shows the issuer etc. (i.e. when I'm going to check my bank account online the issuer is my bank)

but when I go through the wizard/procedure to import the certificate even after it says "import successful" I still get the pop-up.

Share this post


Link to post
Share on other sites

This dialog appears ONLY for "https://" URLs.

Have you try to refresh the list of root certificates by rootsupd package as suggested by erpdude8?

If you click "View Cerificate" - who is the issuer?

Petr

Yes I did that but am still getting the alert. Clicking "View certificate" shows the issuer etc. (i.e. when I'm going to check my bank account online the issuer is my bank)

but when I go through the wizard/procedure to import the certificate even after it says "import successful" I still get the pop-up.

The issuer is your bank? Strange. Most banks I know have cerificates issued by Verisign or similar cerification authority. I think the behavior you describe is expected and correct. You should install the root cerificate of the issuer is you want to get rid of the security alert.

Petr

Share this post


Link to post
Share on other sites

Also, online banking web sites require 128-bit SSL encryption which should be provided in IE 6. try installing MDGx's CRYPT9X package to re-register some of the crypt32 files here:

http://www.mdgx.com/files/CRYPT9X.EXE

I may suspect bad or corrupted cryp32.dll and softpub.dll files. Install CRYPT9X package, then try the site again. if it works, great. if not, try repairing IE from Add/Remove programs select Internet Explorer and Internet Tools, then select the option Repair Internet Explorer and reboot.

Share this post


Link to post
Share on other sites
Also, online banking web sites require 128-bit SSL encryption which should be provided in IE 6. try installing MDGx's CRYPT9X package to re-register some of the crypt32 files here:

http://www.mdgx.com/files/CRYPT9X.EXE

I may suspect bad or corrupted cryp32.dll and softpub.dll files. Install CRYPT9X package, then try the site again. if it works, great. if not, try repairing IE from Add/Remove programs select Internet Explorer and Internet Tools, then select the option Repair Internet Explorer and reboot.

OK, that seems to have cured the problem. If it was a problem with IE then it was caused by the unofficial service pack. I never once saw the security alert until after that installation.

Thanks to all who replied!

Share this post


Link to post
Share on other sites

no probs, wreakhavoc.

I now suggest to Gape to include all the files from MDGx's CRYPT9X package & the info from the CRYPT9X.INF

file and incorporate it into the next release of the Win98 SE Service Pack. for some reason, the 128-bit IE encryption files from the 98se SP were not properly registered on wreakhavoc's system. that should be fixed in the next release.

Share this post


Link to post
Share on other sites

if Windows users encounter the "Security Alert" message described in this thread in other versions of Windows such as NT4, WinME, Win2000, XP or Win2003, open the MS-DOS Command Window, go to the

Windows System folder (\Windows\System\ in Win95, 98 & ME; \WinNT\system32\ in WinNT4 & 2000; \Windows\system32\ in WinXP & 2003) and type in the following commands to re-register the Crypto files:

"REGSVR32.EXE CRYPTUI.DLL"

"REGSVR32.EXE CRYPTDLG.DLL"

"REGSVR32.EXE MSCAT32.DLL"

"REGSVR32.EXE MSSIP32.DLL"

"REGSVR32.EXE RSAENH.DLL"

"REGSVR32.EXE SCHANNEL.DLL"

"REGSVR32.EXE SOFTPUB.DLL"

"REGSVR32.EXE WINTRUST.DLL"

"REGSVR32.EXE XENROLL.DLL"

one of my aunts told me she encountered the "Security Alert" pop-up message on her WinME computer when visiting a certain web site just like the one wreakhavoc mentioned. I just had to replace those files with clean versions and then re-register them with the REGSVR32 command.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×