Jump to content

Missing Language solution


jkey
 Share

Recommended Posts

I missed topic “Missing Language solution” and I need to confess that even I have same troubles since RC5 . I am usin Swedish version of xp pro but Swedish language is missing because of something. Last CD I made gone really weird and sometimes when I get to the msn homepage I end up on the Finnish version of it [probably because nlite read my CD as Swedish/Finnish version – only God knows why]. This worked well with earlier versions…

Hope this will disappear with RC7

Link to comment
Share on other sites


I missed topic “Missing Language solution” and I need to confess that even I have same troubles since RC5 . I am usin Swedish version of xp pro but Swedish language is missing because of something. Last CD I made gone really weird and sometimes when I get to the msn homepage I end up on the Finnish version of it [probably because nlite read my CD as Swedish/Finnish version – only God knows why]. This worked well with earlier versions…

Hope this will disappear with RC7

I'll try to resolve Your problem!

Stay in touch :yes:

Link to comment
Share on other sites

After 2 days of debugging only this I managed to fix it.

And to regain credibility you must know that this wasn't my mistake, it is due to new intl.inf and signature issue (when you edit the file).

To test, if you don't believe me, try to just open intl.inf, edit one line, add space or something, save it and you will have this issue without any nlitement.

Fixed in next version, thank you all and sorry for problems caused by this issue.

Link to comment
Share on other sites

Lithuanian language fix, after windows installation (very similiar to Latvian). Reg file:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\Language Groups]

"3"="1"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage]

"10000"="c_10000.nls"

"1257"="c_1257.nls"

"28594"="c_28594.nls"

"28603"="c_28603.nls"

"775"="c_775.nls"

"850"="c_850.nls"

"855"="c_855.nls"

"865"="c_865.nls"

"866"="c_866.nls"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\Locale]

"00000425"="3"

"00000426"="3"

"00000427"="3"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layouts\]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layouts\\00010427]

"Layout File"="KBDLT1.DLL"

"Layout Id"="0027"

"Layout Text"="Lithuanian (QWERTY)"

"Layout Display Name"="@%SystemRoot%\system32\input.dll,-5088"

Link to comment
Share on other sites

After 2 days of debugging only this I managed to fix it.

And to regain credibility you must know that this wasn't my mistake, it is due to new intl.inf and signature issue (when you edit the file).

To test, if you don't believe me, try to just open intl.inf, edit one line, add space or something, save it and you will have this issue without any nlitement.

Fixed in next version, thank you all and sorry for problems caused by this issue.

Don't you love it when crap like that happens? :realmad:

Oh well, nice job in finding the problem :)

Link to comment
Share on other sites

Hey guys after i nLited my windows and installed it i can't find Greek language anywhere. Can someone please help me.. I don't think i can do that registry stuff without blowing my lap, and i was stupid enough to install all the programs i want ant se my computer the way i want it before checking the languages.. I don't think i can go through the same process again :-/ Thx...

I found this in my intl.inf

[LANGUAGE_COLLECTION.BASIC.INSTALL]

.........

CopyFiles = NLS.LGFiles.Install.Greek,KBD.LGFiles.Greek,Greek_Fonts,AGT.DLL.LGFiles.Greek,AGT.HLP.LGFiles.Greek

AddReg = NLS.LGReg.Install.Greek,KBD.LGReg.Install.Greek,Font.NonCP1252.Substitutes

.......

it means i should have greek on? anyone help...

Edited by p3tris
Link to comment
Share on other sites

Hi!

I've just noticed that I have the same problem with Polish language.

Everything stays EXCEPT Polish language and Polish Programmers keyboard layout, which I did NOT selected for removal. Weird...

Hope nuhi has found a solution few posts above :D

P.S. This is what I discovered.

I didn't touch the languages and keyboard leyout setions at all. All I've done was selecting Polish Programmers keyboard layout and Locale to Poland (didn't check the languages group).

After installing WinLite I discovered that:

1. Locale is not set to Poland (but there's a possiblity)

2. Standards and formats is not set to Polish (and there's no possibility to do so - missing preset)

3. Keyboard layout is not set to Polish Programmers (and there's no possiblity - missing)

Now I'll try not to set those option (leave english as it is default) and see what happens...

--

fahur

Edited by fahur
Link to comment
Share on other sites

just open intl.inf, edit one line, add space or something, save it and you will have this issue without any nlitement.

true that ! works fine for me.

made the default setup for me (with language and keyboard layout removals, unattended setup, options etc etc.) then edited the intl.inf file, made an ISO and it all works great :)

Link to comment
Share on other sites

hey guyz, yeah I'bin the last week making a new ISOs til I figure it out

so any one help me apply this RegionalSettings in winnt.sif by a reg file

[RegionalSettings]
LanguageGroup=1,13
SystemLocale=00000401
InputLocale=0409:00000409,0401:00000401
InputLocale_DefaultUser=0409:00000409

it's for Right-to-left complext scrpits (including Arabic)

Link to comment
Share on other sites

just open intl.inf, edit one line, add space or something, save it and you will have this issue without any nlitement.

true that ! works fine for me.

made the default setup for me (with language and keyboard layout removals, unattended setup, options etc etc.) then edited the intl.inf file, made an ISO and it all works great :)

How exactly did you fix this problem my friend? Can you explain what were the changes in intl.inf file?

I have a good unattended WinXP version but there's the well know problem with the languages..

Link to comment
Share on other sites

Can someone really please help me add Greek to my windows? It's my exams period and i need them for an essay... I don't have the time to make another cd and reinstall everything (windows, programs, office etc..) Please i would realy appreciate it... If I find the greek.inf file from earlier windows and install it? Thanks again and i hope someone helps out... :blushing:

Edited by p3tris
Link to comment
Share on other sites

How exactly did you fix this problem my friend? Can you explain what were the changes in intl.inf file?

I have a good unattended WinXP version but there's the well know problem with the languages..

after u make all the changes u need in nLite (be it removing stuff or doing unattended setup, whatever) and before u make an ISO - open up the intl.inf file with any txt editor (notepad, wordpad) then edit any line by simply puting in a blank space or type something and then delete it (the point is to have the file opened and resaved with no changes to actual txt lines) and then save the file. thas it. now go and make the ISO :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...