Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


nitro322

Universal Extractor

Recommended Posts


Guest Semiono

Hey! What is a problem with uniextract15.exe ? Is it version should old! :)

Why some installers InnoSetup is don't accessible from it?

Or it's have anybodys security signatures?

Ok! I try innounpack now...

Edited by Semiono

Share this post


Link to post
Share on other sites

I've just installed version 1.5 of Universal Extractor on my dual boot Windows 2000 SP4 / Windows 98SE machine.

Works OK on Windows 2000, but on Windows 98SE I'm getting an error and the program won't work.

Searching this thread it looks as if some others have seen this too, on earlier versions going back a year!

Is the there any fix as yet? The program is supposed to work under Windows 98...........

:(

Share this post


Link to post
Share on other sites
...but on Windows 98SE I'm getting an error and the program won't work.

Searching this thread it looks as if some others have seen this too, on earlier versions going back a year!

Is the there any fix as yet? The program is supposed to work under Windows 98...........

Actually, it's always had issues under Windows 98 (as you've seen in this thread history). I've made a some attempts at fixing this in the past few releases, but I still haven't been able to make it work reliably. As it stands, support under Windows 98 remains broken.

Going forward, this unofficial "Win 9x is not officially supported but I'll try to make it work" policy will change. Beginning with version 1.6, UniExtract will not work under Win 9x. Period. This is due to changes in recent versions of AutoIt. The AutoIt developers have added proper Unicode support, which (among other things) will make translations more reliable. The downside is that Unicode is not supported under Win 9x. The new version of UniExtract will simply not run. I tested and verified this earlier tonight, just to be certain.

If you're still running Win 9x, probably your best option going forward would be to treat UniExtract as a collection of tools and utilities and use those utilities directly to extract the files. Eg., UniExtract as a frontend will no longer work, but most of the supporting binaries included with it should function properly when called directly from the command line. It's obviously less convenient, but it'll work.

Share this post


Link to post
Share on other sites

Thanks for the reply nitro322.

I thought that it looked like something pretty fundamental that was causing the error message!

I understand the Windows 98 compatibility problem.

The only thing I would ask is whether there is an earlier version of Universal Extractor that does work under Windows 98 still available anywhere?

I could then install both versions on my dual boot machine.

Cheers, Dave.

:)

Share this post


Link to post
Share on other sites
The only thing I would ask is whether there is an earlier version of Universal Extractor that does work under Windows 98 still available anywhere?

None of them worked perfectly. 1.3.1, 1.4.2, and 1.5 all worked to varying degrees of success. Also, in some cases the standalone version worked better than the installed version, and vice-versa. I ran into some really, really weird problems that I just never could get worked out no matter how many hacks I threw at it. I'd suggest trying out the other version of 1.5 than what you're using now, and if that still fails then try 1.4.2, then 1.3.1. One of those should at least cover the basics.

Dunno if this has been mentioned yet, but as I'm using the updated unofficial 1.5.0.1, here's an archive where the data1.cab can't be extracted. Thanks for your hard work :)

I'll look into it, but I can only test against the current dev version. I have not used the unofficial release.

Share this post


Link to post
Share on other sites
.......I'd suggest trying out the other version of 1.5 than what you're using now, and if that still fails then try 1.4.2, then 1.3.1. One of those should at least cover the basics...........

Thanks again.

I managed to find and download a copy of version 1.4.2, which produced exactly the same error message as 1.5!

I tried the exe installer version and the rar archive version, with the same result.

:(

I can't find a copy of 1.3.1 anywhere to download.

Could you point me to somewhere I can get it?

What is the "other" version of 1.5?

Do you mean the non exe installer version?

Cheers, Dave.

:)

Share this post


Link to post
Share on other sites
I can't find a copy of 1.3.1 anywhere to download. Could you point me to somewhere I can get it?

It's not currently downloadable. I've been meaning to setup a download pages for archived versions for quite some time, but it's one of those things that I just haven't gotten around to. I just started working on this, though, so it should be ready in a little while. I'll post a link once everything's up.

What is the "other" version of 1.5? Do you mean the non exe installer version?

Yes, that's what I meant. The %PATH% variable behaves differently when using the installed version vs. the standalone version. I could not for the life of me figure out why, but in some cases one works better than the other. I recommend trying both (you can use both of them concurrently to ease testing).

7-zip 4.52 beta has been released, now featuring support for extracting MSI and doc files :) Seems like 7-zip is taking a hint from UE!

Very cool. I'll check it out, see how it compares with the existing MSI extraction options.

Share this post


Link to post
Share on other sites

Random request: does anyone happen to have a copy of the Universal Extract 1.4 installer? I'm uploading all of the older versions to an archive page, but I seem to be missing that file. It was released on 11/18/2006. If anyone still has a copy of this, I'd greatly appreciate it if you could send it to me or post a download link.

Thanks.

Share this post


Link to post
Share on other sites

Thanks! That's exactly what I was looking for.

For anyone interested, I just finished the download page (complete with the 1.4 installer, thanks to jaclaz). You can find it here:

http://uniextract.c1pher.com/archive/

I highly encourage you to use the latest available version, but in the event that you need an older version for some reason you should be able to always download a copy from the above link. It includes all official binary and source code releases.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×