Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
Gape

98 SE SP 2.1

Recommended Posts

Hello,

I still trying to improve the french version of the service pack, but there are some translated files that i can't find, here is the list:

Q239696 IOS.VXD

Q242193 NWREDIR.VXD

Q246817 VPOWERD.VXD

Q257360 VPICD.VXD

Q277628 VFAT.VXD

Q309081 IRENUM.VXD

Q319571 KEYB.COM

Q323455 VREDIR.VXD

If someone has these files, can you please send it to me, so i can include them in the next release of the French Version of the service pack.

Thanks

Share this post


Link to post
Share on other sites

I've created simple package for checking file versions by QFECheck tool:

http://www.winpack.org/nsp_petr/sesp21en-qfe.exe

It installs QFECheck.exe, QFECheck.hlp and it copies QFE.INF into %windir%\INF folder.

Missing files are OK (some are installed only if the file already exists), wrong version is OK just in case of WBEM files if WBEM 1.5 is not installed.

It can be uninstalled by Add/Remove programs, QFECheck.exe, QFECheck.hlp are kept in the system, just the registry information and QFE.INF file are deleted.

It is intended as tool for those who want to verify that everything was installed as expected.

Petr

Share this post


Link to post
Share on other sites
I've created simple package for checking file versions by QFECheck tool:

http://www.winpack.org/nsp_petr/sesp21en-qfe.exe

It installs QFECheck.exe, QFECheck.hlp and it copies QFE.INF into %windir%\INF folder.

It is intended as tool for those who want to verify that everything was installed as expected.

Great work, again, Petr. I will include this into the next version. Thanks! :thumbup

Share this post


Link to post
Share on other sites

About timestamps - Yes, I am sure they are lost. :(

SP 2.1 provides

11/14/05 04:54pm 4.00 721,680 Opengl32.dll

Quoting from q240896:

The English version of this fix should have the following file attributes or later:

Date Time Version Size File name Platform

-------------------------------------------------------------------

01/07/00 03:13pm 4.00 721,680 Opengl32.dll Windows 95 OSR2,

Windows 98,

Windows 98 SE

Share this post


Link to post
Share on other sites

on the install I was ask if I wanted to keep the newer file or older because the file I had was newer? Should I keep the newer file or let the install the older one

Share this post


Link to post
Share on other sites
on the install I was ask if I wanted to keep the newer file or older because the file I had was newer? Should I keep the newer file or let the install the older one

Generally, you should keep the newer. But could you write the file name(s)?

Share this post


Link to post
Share on other sites

Html help subsystem in SP 2.1 (as well as 2.0.2) predates the official KB896358 released on June 14, 2005.

One can argue about version string. I'd suggest going with KB896358 because to me it looks more recent.

5.2.3790.309 (srv03_gdr.050413-1540) in KB896358

5.2.3790.1830 (srv03_sp1_rtm.050324-1447) in SP

1550 > 1447 yet 309 < 1830

This, by the way, causes the "keep the newer" warnings too for people who picked the official update.

I'll forward KB896358 to Gape in a sec

Share this post


Link to post
Share on other sites
Html help subsystem in SP 2.1 (as well as 2.0.2) predates the official KB896358 released on June 14, 2005.

One can argue about version string. I'd suggest going with KB896358 because to me it looks more recent.

5.2.3790.309 (srv03_gdr.050413-1540) in KB896358

5.2.3790.1830 (srv03_sp1_rtm.050324-1447) in SP

1550 > 1447 yet 309 < 1830

This, by the way, causes the "keep the newer" warnings too for people who picked the official update.

I'll forward KB896358 to Gape in a sec

sesp21en contains:

HHCTRLUI.DLL 5.2.3635.0

HHCTRL.OCX 5.2.3790.309 (srv03_gdr.050413-1540)

HHSETUP.DLL 5.2.3790.309 (srv03_gdr.050413-1540)

HH.EXE 5.2.3790.309 (srv03_gdr.050413-1540)

ITIRCL.DLL 5.2.3790.309 (srv03_gdr.050413-1540)

ITSS.DLL 5.2.3790.309 (srv03_gdr.050413-1540)

sesp21fr contains:

HHCTRLUI.DLL 4.74.9273

HHCTRL.OCX 5.2.3790.309 (srv03_gdr.050413-1540)

HHSETUP.DLL 5.2.3790.309 (srv03_gdr.050413-1540)

HH.EXE 5.2.3790.309 (srv03_gdr.050413-1540)

ITIRCL.DLL 5.2.3790.309 (srv03_gdr.050413-1540)

ITSS.DLL 5.2.3790.309 (srv03_gdr.050413-1540)

sesp21de contains:

hhctrlui.dll 5.2.3664.0

hhctrl.ocx 5.2.3790.2453 (srv03_sp1_qfe.050525-1536)

hhsetup.dll 5.2.3790.2453 (srv03_sp1_qfe.050525-1536)

hh.exe 5.2.3790.2453 (srv03_sp1_qfe.050525-1536)

ITIRCL.DLL 5.2.3790.2453 (srv03_sp1_qfe.050525-1536)

ITSS.DLL 5.2.3790.2453 (srv03_sp1_qfe.050525-1536)

None SE SP 2.1 contains 5.2.3790.1830 (srv03_sp1_rtm.050324-1447).

Petr

Share this post


Link to post
Share on other sites

I see how I got confused about the version of HH.

Gape played with timestamps here as well. Could Gape please fix dates here and on recent files (e.g. opengl32.dll? It does confuse installer after all.

Share this post


Link to post
Share on other sites
I see how I got confused about the version of HH.

Gape played with timestamps here as well. Could Gape please fix dates here and on recent files (e.g. opengl32.dll? It does confuse installer after all.

My new unzipping tool changes timestamps! :angry:

OK, I'll fix them soon.

swgreed, Petr, any news about DSOUND.DLL problem?

Edited by Gape

Share this post


Link to post
Share on other sites
swgreed, Petr, any news about DSOUND.DLL problem?

Unfortunately not... therefore I released the German Version without dsound.dll for the time being.

Share this post


Link to post
Share on other sites

I see how I got confused about the version of HH.

Gape played with timestamps here as well. Could Gape please fix dates here and on recent files (e.g. opengl32.dll? It does confuse installer after all.

My new unzipping tool changes timestamps! :angry:

OK, I'll fix them soon.

swgreed, Petr, any news about DSOUND.DLL problem?

the updated dsound.dll file requires DirectX 7. since win98se originally included DirectX 6.1a, the 98se pack should NOT install that file unless DX7 [not DX 6.1 & earlier and not even DX 8 & higher] is installed. they're might be a problem when using certain computer games that depend on the dsound.dll file. havent seen any reports of any problems, yet.

Share this post


Link to post
Share on other sites
the updated dsound.dll file requires DirectX 7. since win98se originally included DirectX 6.1a, the 98se pack should NOT install that file unless DX7 [not DX 6.1 & earlier and not even DX 8 & higher] is installed. they're might be a problem when using certain computer games that depend on the dsound.dll file. havent seen any reports of any problems, yet.

Why do you think that this file requires DirectX 7? According to the Knowledge base article Q269604 this hotfix is intended for both Microsoft Windows 98 Standard Edition and Microsoft Windows 98 Second Edition with no additional conditions.

Petr

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×