Jump to content

XPCREATE 18 AUG 2005


Recommended Posts

@Greenmachine,

I am working on a Dutch version and I have almost every update included, but when I go to the Windows Update site it shows a dutch languagepack for the .NET framework. I have downloaded this file but I do not know where to put it, so it gets integrated.

When I run the file with /? it shows that it supports the /Q option to do a silent install. Have you any idea where I can put this file so it gets integrated. I tried in SVC-CF1, but received an error during install.

Everything else is working fine. Keep up the good work. I will also test with Windows Server 2003 and let you know the results. With the previous version I had some problems getting all the updates included.

The Bitfrotter

edit.... I have tried putting it in SVC-HF2 and it did not give an error, however now I have to click to install it. So it is not unattended. I believe this is because only the /Q option is available.

Edited by Bitfrotter
Link to post
Share on other sites

@Greenmachine,

Thanks for your information. I just moved the file to SVC-X2M and created a new iso. And indeed after installation everything is unattended and the windows update site shows no updates to install.

I will create a W2K3 setup later this weekend and let you know the results.

The Bitfrotter

Link to post
Share on other sites

I made a cd whit the new XPCREATE version and al works fine for me.

But i missed one thing.

Why is not added the update from windows update to microsoft update?

does any one a suggestion for this

Thx

Link to post
Share on other sites

@Greenmachine,

By now I have a complete installation for XP-SP2 UK and Dutch version and I have also created a W2K3 server cdrom. All three have every update slipstreamed. Also the Windows Update files and the genuine check are slipstreamed. I will see if I can do a W2K cd to. I saw a error with renaming a directory during the creation of the W2K3 iso and I will try to give more info on what happens. Maybe you can see about it. Will do this later.

Greetings,

Bitfrotter

Link to post
Share on other sites

Thanks, Bitfrotter, for doing the testing that I am too pressed for time and resources to do (takes forever on a laptop ... )

As for using Microsoft Update as opposed to Windows Update, that will have to wait until Microsoft creates a hotfix / patch similar to the Windows Update Version 6 thingy.

Link to post
Share on other sites
  • 2 weeks later...
Every option has it's advantages and disadvantages. Most of the other choices are either faster, more compact, or allow easy modification of Microsoft code. Me, I've got a DVD burner, I like to have time for a beer or two during the install, and shoot for that 100% Microsoft acceptable installation. That is not to try and belittle any of the other efforts, they are all good in their own right.

One option i would like to have in xpcreate.ini is ability not to call :EXPANDCABS

in the script at all.

DOCABS variable from xpcreate.ini is checked in xpcreate.cmd script after extraction of all cabs...

It takes a very long time when building a new CD on my PIII 1GHz 512 Mb 20 Gb 5400 tpm build box to expand all cabs do some checks and optionally repack them.

In most cases, none of the files inside the cabs are upgraded...

Edited by Bilou_Gateux
Link to post
Share on other sites

Hi GM :)

Maybe its time to make the xpcreate.cmd of xpcreate into a EXE (you could use this methinks http://www.google.co.uk/search?hl=en&q=CMD2EXE&meta=) to stop the ppl blatantly violating the EULA, editing it and moaning all the time. (after seeing the recent threads and plenty of threads/posts in the past)

Mentioned it before ;)

Would it cause problems to the way it works tho?

At least the ini is still there and it'll be used as it should be :)

Regards

Nath.

Edited by it_ybd
Link to post
Share on other sites

@Greenmachine,

I have been working on the W2K version and it has been difficult to get everything working. I will post my list with files later this week but for now I am stuck with the root certificates update. It is in the SVC-HF2 directory and I renamed it to rootsupd.exe but it will not get integrated. when I download it from your website it is called rootsupd_94e9af610087f43b1b637bb5c0e8146.exe.

Have you any idea on what goes wrong. Is it in the wrong directory or should I have not renamed it. Every other update is integrated through your tool.

Greetings,

Bitfrotter

Link to post
Share on other sites
  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...