Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Recommended Posts

I am not sure how it all of a sudden started working.

27yvaeb.jpg

We will find out in 6 hours. :D

Share this post


Link to post
Share on other sites

I am not sure how it all of a sudden started working.

27yvaeb.jpg

We will find out in 6 hours. :D

well i am glad it is working for you now, kinda strange it jsut kicked in but that is ok :) RC1 will be out here pretty quick so you will get to try it with that build also :)

Share this post


Link to post
Share on other sites

fizban2, I am glad too that Autounattend.xml works no problems.

I am sure the install went well in VMware. Just that due to compatibility issues, I guess, it has ended up with a blank screen.

27zkjrr.jpg

In a real PC, this should definitely work error free.

Let me please confirm this one more time. In the autounattend.xml, for burning a DVD to install in a real PC, the follow snippet of XML is correct, isn't it? (to test in VMware I had to change X:\ to F:\).

<ImageInstall>
<OSImage>
<InstallFrom>
<Path>X:\sources\install.wim</Path>
</InstallFrom>
<InstallTo>
</InstallTo>
</OSImage>
</ImageInstall>

Thanks,

McoreD

Edit: The Autounattend.xml however did have no effect on FolderLocations. See http://www.msfn.org/board/index.php?s=&amp...st&p=555909

Edited by McoreD

Share this post


Link to post
Share on other sites

correct, X: is used by the PE when it starts, it always uses X:

Share this post


Link to post
Share on other sites

Much appreciated fizban2. Without your guidance and sample xml, I wouldn't have come this far!

As the basic autounattend.xml appears to be working (a Virtual PC test is currently on test), requesting permission to create a new thread for extending xml functinoality: Unattended Vista with Multiple Partitions. :)

Cheers,

McoreD

Edit: The "Windows is unable to install to the selected location" seems to vanish after

1. DISKPART, SELECT DISK 0, CREATE PARTITION PRIMARY

2. Restart Windows setup

or

1. Using GUI, press NEW, FORMAT

2. Restart Windows setup

Edited by McoreD

Share this post


Link to post
Share on other sites

Hi Guys,

downloaded RC1 build 5600 and the BDD beta 1 but somehow I cannot get things to work very well. First, the WAIK included in the BDD cannot load the wim´s catalog file, second creating a new catalog file always results in an error message (Exception from HRESULT: 0x800F0808)

edit: Seems to be a compatability problem with the WAIK and RC1. MS Newsgroups report that a new version of the WSIM is needed.

Second I am a bit lost when it comes to the whole process of making Vista unattended. Maybe someone can explain how the BDD, WAIK, XImage etc. interact to create an unattended Vista DVD. I have tried reading the help files but I still don´t understand.

edit: Getting clearer now after reading the WAIK Users Guide. I still don´t know why the BDD is needed at all but maybe someonce can clear that up ...

Third, I realize that an xml based answer file is being used to automate the Windows installation but how can we import registry tweaks to the default profile, install updates, applications etc. ? Does runonceex still exist or is it done differently in Vista ?

Adding applications and even drivers seems to be possible using the same answer file but I still have not found a way to edit the default profile or add registry tweaks to it ...

And last but not least, does an application installer like Wihu already work for Vista ?

thanks,

Alex

Edited by midiboy

Share this post


Link to post
Share on other sites

Hi midiboy,

You can simply personalize your Autoattended.xml file from

instructions here by fizban2:

http://www.msfn.org/board/index.php?s=&amp...st&p=522924

here is my current customized file:

http://www.msfn.org/board/index.php?s=&amp...st&p=556385

(I am back to square 1 after failing a real PC test)

You can open the original ISO using MagicISO

drag the Autounattend.xml to the ISO root

Save as new ISO

Cheers,

McoreD

Share this post


Link to post
Share on other sites

Hi Guys,

Last attemp to get this working just fails miserably.

vistarc1installtoxf4.jpg

This is a real PC, Vista + Autounattend.xml burnt to a DVD.

Guess I should give up now. :)

Cheers,

McoreD

Share this post


Link to post
Share on other sites
Hi Guys,

downloaded RC1 build 5600 and the BDD beta 1 but somehow I cannot get things to work very well. First, the WAIK included in the BDD cannot load the wim´s catalog file, second creating a new catalog file always results in an error message (Exception from HRESULT: 0x800F0808)

edit: Seems to be a compatability problem with the WAIK and RC1. MS Newsgroups report that a new version of the WSIM is needed.

I experienced those issues with RC1 and the BDD Beta as well. Any information if an updated BDD version is scheduled to release?

Share this post


Link to post
Share on other sites

Note for all, i will be doing an updated Unattended Vista somtime next week or the week after, :) i have 2 MCP tests then i will be back into vista full force

Share this post


Link to post
Share on other sites

@ fizban2: An up to date guide would be very nice!

EDIT: Ok, Drivers and OEM is working now. I put them on a CD-RW that contains the AutoUnattend.xml and insert it into my second optical drive while setup runs. USB Stick would be an alternative.

Edited by Dynaletik

Share this post


Link to post
Share on other sites

In case anyone is wondering the OEM Information is now stored within the registry...

Before it used to be OEMinfo.ini, or some such, but it's now stored in the following registry key...

HKLM\Software\Microsoft\Windows\Currenversion\OEMInformation

It's blank unless you typed something in, in the autounattend.xml

However, if you want to manually enter information you can just grab the section titles from the Windows SIM OEM Section (What the string names should be)

Basically you'd a string key called "Manufacturer" and then type in what you want to be shown... If you type logo you'll need to type in the complete path to the location of the logo. The logo must also be 120x120, which is SMALLER than XP's logo... I had to remake mine...

The logo information is lisetd in the unattend help, but the rest I figured I'd throw in here.....

Any ideas on how to tell setup to make the run menu available in the start menu when setup completes? I know you can right click, select properties, and chose to show run from deep in there, but it'd be nice to not HAVE to do that....

Edit:

"HKCU\software\microsoft\windows\currentversion\explorer\advanced\Start_ShowRun" Is the registry key to show the Run command in startup, changing it from '0' to '1' shows it after a reboot...

Another lcoation, which may be more beneficial

"HKLM\software\microsoft\windows\currentversion\explorer\startpanel\DefaultValue", settings this to 1 during setup SHOULD make Run show up when setup is complete, though I haven't tried yet...

Also, what's the best way to get the install to copy files where they need to be? Does the OEM directory work exactly like the Windoes XP one?

Edited by Nakatomi2010

Share this post


Link to post
Share on other sites
...

Also, what's the best way to get the install to copy files where they need to be? Does the OEM directory work exactly like the Windoes XP one?

Open the WSIM and click on HELP. Go to "Deployment Tools Technical Reference"/"Windows System Image Manager Technical Reference" and read the "Understanding Distribution Shares and Configuration Sets" section.

There you will find how $OEM$-Folder works in Vista Setup.

Martin

Share this post


Link to post
Share on other sites

Looks like the download invitation is not available anymore. Anymore can provide me a link where I can get it?

Share this post


Link to post
Share on other sites
Looks like the download invitation is not available anymore. Anymore can provide me a link where I can get it?

You can get it Here

Edited by Nakatomi2010

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...