Jump to content

the guide of "Using autoit for silent install"


master_mtz
 Share

Recommended Posts

Thanks for the answer, but the question was "why a COMPILED au3 hangs at the end, not pressing the Finish button, while the same AS SCRIPT pushes it"...

The use of ccleaner was only an example, in particular i was simply applying the guide to the first install-exe found and useful... and it hangs at the end...

Anyway, thanks for your script OnAutoItStart, i'll use it :-)

p.s.: applying the same guide to the new yahoo-less ccleaner (ccsetup127_basic.exe): all works perfectly... bah!

Edited by mrshark
Link to comment
Share on other sites


Thanks for the answer, but the question was "why a COMPILED au3 hangs at the end, not pressing the Finish button, while the same AS SCRIPT pushes it"...

My guess is the last line should be replaced with

Send("!f")

That is how I would send Alt-f to the last button. You could add a small Sleep() just before it, if the button is disabled for a short period of time.

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 months later...

With so many people talking about AutoIt scripts I decided to give it a try. I'm not a programmer and only understand enough of unattended installs to create one for myself. The AutoIt way of doing things totally confused me and left me without a means to automate programs without silent installs. My solution was to place the programs on the desktop and run them after an unattended installation.

But your guide with the companion software did the trick. Every program I had to manually install (4 of them) are all fully automatic. This has made AutoIt 'doable' for me.

I don't need to learn all the other 'stuff' as this is a simple excercise in learning to keep my computer updated and easy to repair. Now I can go back to all my other hobbies.

Thanks for the guide and keep up the good work.

Link to comment
Share on other sites

  • 3 months later...
  • 1 month later...

Hi,

I have used this guide to create a autoit script for Pinnacle studio 9. If i start it manually from the desktop or whereever then it starts to install and works just fine but as soon as i add the whole thing in WPI to install it just starts the installer and then hangs. Does someone perhaps know what this problem can be?

I added the script as attachment here.

Tnx in advance

blaat.au3

Link to comment
Share on other sites

Yagermeister,

This is your script optimized some.

$SF_1 = "Welcome.exe"

If WinExists ( $SF_1 ) Then Exit
AutoItWinSetTitle ( $SF_1)

Run('Welcome.exe')
_WinWaitActive("Studio 9 Plus - InstallShield Wizard","Select the language ")
Send("{UP}{ENTER}")
_WinWaitActive("Studio 9","Geef de volgende inf")
Send("{TAB}blaat{TAB 3}XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX{TAB 3}{SPACE}{TAB 11}{ENTER}")
_WinWaitActive("Studio 9 (Pinnacle Systems - Registratie)","")
Send("{TAB 5}{ALTDOWN}{ALTUP}{DOWN 2}{ENTER}")
_WinWaitActive("Installatie van Windows XP , Version 9.3","Licentieovereenkomst")
Send("{TAB 4}{SPACE}{TAB 3}{ENTER}")
_WinWaitActive("Installatie van Windows XP , Version 9.3","Selecteer het type i")
Send("{ENTER}")
_WinWaitActive("Installatie van Windows XP , Version 9.3","Huidige instellingen")
Send("{ENTER}")
_WinWaitActive("classname=#32770","Bezig met installere")
Send("{PAUSE 5}")
_WinWaitActive("Vraag","Moet er een shortcut")
Send("{ENTER}")
_WinWaitActive("Installatie van Windows XP , Version 9.3","Ja, ik wil mijn comp")
Send("{DOWN}{ENTER}")

Func _WinWaitActive($title, $text = "")
WinWait($title, $text)
If Not WinActive($title, $text) Then
WinActivate($title, $text)
EndIf
WinWaitActive($title, $text)
EndFunc

An issue is that you are using a classname for a window title without setting an option to use them as below.

Opt('WinTitleMatchMode', 4)

With that window title, I'm not even sure if you should have it within the script and you just press the (PAUSE) keys 5 times? The classname title looks like an explorer window which you can just use WinClose on. I would assume by looking at it that the rest does looks normal.

Make sure that a window called "Welcome.exe" is not running when you start your script as it will exit as your first few lines will ensure that.

If possible, you may find it better to use AutoItMacroGenerator to generate a script for installations using Control*() functions. AutoItMacroGenerator is an included tool in CMenu, SendToA3X, or the Scite4AutoIt3 editor.

Edit:

SendToA3X v1.1 has now an item to tidy Au3Recorder generated scripts like the above code as shown above as easy as a wink. ;)

Edited by MHz
Link to comment
Share on other sites

  • 2 weeks later...

im a complete noob to all this, and ive managed to follow our instructions, is there some were that will give me a tutorial on creating a rarsfx, cant find one, and after trying to figure it out for the past hour is gettin annoying!

thanks for the tutorial :)

Link to comment
Share on other sites

I have a question about silent installs maked with Autoit Scite Script Writer.

Is it possible that you don't see the install screen?

No it isn't, the only way to do that is by compleatly rewriting the installation package.
Link to comment
Share on other sites

  • 1 year later...
  • 5 months later...

hi mtz,

I need your help :blushing:

when I launched au3record I must flag also 'record mouse' as if I unflag it, after stopping au33record, I obtain only following lines:

Opt("WinWaitDelay",100)

Opt("WinTitleMatchMode",4)

Opt("WinDetectHiddenText",1)

Opt("MouseCoordMode",0)

Run('D:\Sotware indispensabili\WinRAR.v3.71.Regged.Italiano-YAG\WinRAR.v3.71.Regged.Italiano-YAG\wrar371it.exe')

meanwhile if I flag 'record mouse' I obtained all script as follow:

Opt("WinWaitDelay",100)

Opt("WinTitleMatchMode",4)

Opt("WinDetectHiddenText",1)

Opt("MouseCoordMode",0)

Run('D:\Sotware indispensabili\WinRAR.v3.71.Regged.Italiano-YAG\WinRAR.v3.71.Regged.Italiano-YAG\wrar371it.exe')

WinWait("WinRAR 3.71","Copyright © 1993-200")

If Not WinActive("WinRAR 3.71","Copyright © 1993-200") Then WinActivate("WinRAR 3.71","Copyright © 1993-200")

WinWaitActive("WinRAR 3.71","Copyright © 1993-200")

MouseMove(215,381)

MouseDown("left")

MouseUp("left")

WinWait("Configurazione WinRAR","Associa a WinRAR arc")

If Not WinActive("Configurazione WinRAR","Associa a WinRAR arc") Then WinActivate("Configurazione WinRAR","Associa a WinRAR arc")

WinWaitActive("Configurazione WinRAR","Associa a WinRAR arc")

MouseMove(34,95)

MouseDown("left")

MouseUp("left")

MouseMove(30,95)

MouseDown("left")

MouseUp("left")

MouseMove(201,378)

MouseDown("left")

MouseUp("left")

WinWait("Configurazione WinRAR","WinRAR è stato insta")

If Not WinActive("Configurazione WinRAR","WinRAR è stato insta") Then WinActivate("Configurazione WinRAR","WinRAR è stato insta")

WinWaitActive("Configurazione WinRAR","WinRAR è stato insta")

MouseMove(251,389)

MouseDown("left")

MouseUp("left")

WinWait("WinRAR","FolderView")

If Not WinActive("WinRAR","FolderView") Then WinActivate("WinRAR","FolderView")

WinWaitActive("WinRAR","FolderView")

MouseMove(783,14)

MouseDown("left")

MouseUp("left")

where is my mistake?

can you help me?

thank in advanced

dottBin

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...