Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Unattended and Updated Boot CD for Windows 98


Recommended Posts

Thanks for your reply,

I've covered most of the things you've suggested last night including checking my source disk (with a standard install), boot sector and recopying the win98 dir to HDD. Still no go.

Something I have found is that even though windows bugs out (which is after second restart by-the-way) I can restart and get in to safe mode, odd!

I'm gonna try afew more things and get back to you.

Edit:

Sorry soporific, I've wasted your time.

This is a VMware issue, I've just tested in VirtualPC and all works fine. People can say what they like about M$ but atleast it bloody works. More over is flippin free :realmad: .

Anyway, I'm a prat! Looking back I didn't state that I was testing in VMware. I'll think before I post next time :blushing: .

Thanks for your help anyway.

I'm gonna start on integrating your Seven Years Later project into my multi-boot disc now, so you'll probably hear from me again. Hopefully with better questions next time.

Edited by kof94
Link to post
Share on other sites
  • 2 weeks later...

  • 3 weeks later...
OK fair enough I see that your problem is more generic than just this project ... i will try to help!

OK, first the easy solution: a lot of people forget that you have to FORMAT your hard drive before you can properly use a Win98 boot CD. This isn't a problem with a WinXP one but it will give you the error that you can't write to the partition. I know that some people forget and then wonder why things don't work. But maybe you know this and the problem is something else.

If the above isn't the problem, please reply to the following questions:

1) Can you get to a DOS prompt at any stage during operation but before the problem occurs?

2) If you can, what has been assigned to the C drive? Is it blank (ie recently formatted), or does it report the CD drive contents. What is assigned to the A drive? (the boot files inside your Win98 boot image should be all there when you type DIR at the A:\ prompt.) Can you type DIR and report what it says?

Next, make sure you are using a proper Win98 boot image -- I remember that I had trouble with the one I made from my Retail edition CD and had to download someone elses from the net. Make sure that your Win98 setup can be installed separate from the multi-boot CD, even if you can't test unattendedly. If this is the problem, I have a boot image that will work with CD shell ...

Next, if you have two CD drives connected, disconnect one of them and see if you get the same error.

Next, confirm your setup files aren't corrupted. I don't think this is the problem, but if it none of the above, i'm starting to run out of ideas so you may as well check.

See how you go with all that.

All what I did is:

I copied the '@msbatch.inf' to the Win98 folder then tried to install Windows 98se in Virual Machine (VMware Workstation) using the command line in the autoexec.bat: path=a:\;%CDROM%\

%CDROM%

cd \WIN98

setup.exe @msbatch.inf

It started copying all neccessary files to the disk. Hereafter, it restarted the computer automatically.

Now it displays the following on Dump screen:

" Cannot read or write to Partition C: press any key to continue "

When I press any key I have this message:

" Cannot load or read KRNL386.exe"

One more question:

How to bypass the scandisk process during installation?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...