Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


MDGx

98SE2ME = Killer Replacements: ME -> 98 SE

Recommended Posts

@MDGx

Is there a way to do the transplant without installing win98SE first? I mean replace those files on the source disc to get a win98SEME ISO.

Share this post


Link to post
Share on other sites

@MDGx

Is there a way to do the transplant without installing win98SE first? I mean replace those files on the source disc  to get a win98SEME ISO.

I bet there is, but unfortunately at the moment I don't have the time to come up with the scripts.

To abide by MS guidelines, this requires among other things to repack all setup CABs, and I don't have the info on how exactly each CAB depends on/links to the others.

Maybe some day I'll research this stuff...

Hope this helps.

Share this post


Link to post
Share on other sites

MDGx,

I am trying to create my own windows disc. Is there any way I can alter the batch files etc. so that they read what I want them to say. Because I want all these Win ME files built into it, and the base is win98se.

Then, how do I add altered 98 and ME files (resource hacked) into the installer?

With your permission, of course.

Just a thought.

And also, as posted on another page, I have problem with my pictures folder and some other automatic thumbnail folders after installing 98se2me. Changing the folder to classic in Customise Folder Wizard, then altering the wvleft.gif to match wvleft.bmp, this fixes problem for one specific folder, but how do I make this a global change??

Edited by VWIMaster

Share this post


Link to post
Share on other sites
MDGx,

I am trying to create my own windows disc. Is there any way I can alter the batch files etc. so that they read what I want them to say. Because I want all these Win ME files built into it, and the base is win98se.

Then, how do I add altered 98 and ME files (resource hacked) into the installer?

With your permission, of course.

Just a thought.

And also, as posted on another page, I have problem with my pictures folder and some other automatic thumbnail folders after installing 98se2me. Changing the folder to classic in Customise Folder Wizard, then altering the wvleft.gif to match wvleft.bmp, this fixes problem for one specific folder, but how do I make this a global change??

98SE2ME files are open source [more details in READ1ST.TXT + INNOFILE.TXT], therefore u can modify them any way u want for the purpose of using/testing stuff on your own computer(s).

If u plan on improving 98SE2ME, please post your scripts/ideas here so we can all benefit.

To include ME files into a 98SE setup CD, u need to know exactly how CABs are linked so u can properly replace files and repack the CABs. I don't have that info, but Microsoft does.

As long as u do this right, it doesn't matter if u add/replace hexed or original files, u just need to make sure checksum detection [iNF code mostly] corresponds with the altered/replaced files code.

The catch is that you're talking about modding an entire OS here, so this will be tedious and lengthy work if u plan on pursuing this project.

I wish u the best of luck.

And please post here your scripts/ideas, so we can all benefit.

Edit:

Added this Q&A into READ1ST.TXT under the "FAQ" chapter:

READ1ST.TXT

________________________________________

About thumbnail folders:

I need more details, please, like: how exactly happens, which Windows Explorer folder view were u using, do u get any error dialogs, if u do please post them here, which 98SE2ME option(s) did u install right before this happened, which 98SE2ME edition were u using, are u sure it's an 98SE2ME option that caused this, which exact steps u took to fix exactly what.

PS:

thumbnail view errors have been fixed:

please d/l 98SE2ME newest edition:

http://www.msfn.org/board/index.php?showtopic=46349

Hope this helps.

Share this post


Link to post
Share on other sites

MDGx,

I've noticed a problem with the FORMAT command in one of the latest releases that I'm using.

It doesn't provide for me to copy system files, which some programs (like Partition Magic Pro 7.0) will pull up that FORMAT window in order to make a boot disk.

I guess when the FORMAT command was substituted for the ME version, they dropped that feature out of the dialog box.

Thanks,

Steve Sybesma

Share this post


Link to post
Share on other sites

-MDGx, I noticed you removed a lot of font updates, because "Internet Font Packs, XP SP2 + 2003 SP1 install newer builds"... ?

-the only Internet Font Pack I've seen is supposed to be only for win95... ?... and yanking the fonts out of xpsp2/2003sp1 probably isn't the easiest thing to do, for some of your less-technically-oriented fans... -do u have any personally-built font packs, or at least the scripts to do it, or maybe links, etc? Would be nice...

:)

Share this post


Link to post
Share on other sites

MDGx,

I have noticed a bug for sometime which I wonder if you knew about and has been fixed already.

This happens when I want to do a Search and do a "Browse for Folder".

I always see two "My Documents" folders in the list.

Don't know why. Probably a registry thing.

Maybe one of them represents the folder from 'pure' Windows 98 SE and the

other represents the folder created by components in the 98SE2ME update.

Steve

Share this post


Link to post
Share on other sites
MDGx,

I've noticed a problem with the FORMAT command in one of the latest releases that I'm using.

It doesn't provide for me to copy system files, which some programs (like Partition Magic Pro 7.0) will pull up that FORMAT window in order to make a boot disk.

I guess when the FORMAT command was substituted for the ME version, they dropped that feature out of the dialog box.

Thanks,

Steve Sybesma

Steve,

98SE2ME does not replace FORMAT.COM.

FORMAT.COM and most other DOS mode tools from ME will not work under 98SE, unless u load SETVER.EXE from CONFIG.SYS or AUTOEXEC.BAT to fake their version number.

Please see this page for complete list of ME files replaced by 98SE2ME:

http://www.mdgx.com/98-5.htm#FME

Hope this helps.

Share this post


Link to post
Share on other sites
MDGx,

I have noticed a bug for sometime which I wonder if you knew about and has been fixed already.

This happens when I want to do a Search and do a "Browse for Folder".

I always see two "My Documents" folders in the list.

Don't know why. Probably a registry thing.

Maybe one of them represents the folder from 'pure' Windows 98 SE and the

other represents the folder created by components in the 98SE2ME update.

Steve

Please post more details about when, how, why exactly this happens so I can reproduce all steps on my PC.

Thanks.

Share this post


Link to post
Share on other sites
-MDGx, I noticed you removed a lot of font updates, because "Internet Font Packs, XP SP2 + 2003 SP1 install newer builds"... ? 

-the only Internet Font Pack I've seen is supposed to be only for win95... ?... and yanking the fonts out of xpsp2/2003sp1 probably isn't the easiest thing to do, for some of your less-technically-oriented fans... -do u have any personally-built font packs, or at least the scripts to do it, or maybe links, etc?  Would be nice...

Oooops... busted! :)

I actually plan on creating a font pack with all updates I can get my hands on.

Until then, u can get these:

http://www.mdgx.com/add.htm

Windows NT4 True Type Fonts (TTF) Euro Patch [2.16 MB]:

http://download.microsoft.com/download/9/9...1b/OffTTUpd.EXE

Windows 9x/NT4/2000/ME/XP Extra Euro Enabled Fonts [2.48 MB]:

http://download.microsoft.com/download/pub...N-US/PubUpd.exe

Windows 95/OSR1/OSR2/NT4 Euro Enabled Tahoma True Type Font (TTF):

http://support.microsoft.com/?id=188081

Direct download [306 KB]:

http://download.microsoft.com/download/off...us/tahoma32.exe

Microsoft Internet Font Packs for Windows 3.1x/95/NT (free):

http://beebo.org/corefonts/

Hope this helps.

Edited by MDGx

Share this post


Link to post
Share on other sites

Oooops... busted! - Part 2. ;)

Fresh out of the oven...

* Unofficial Windows 9x/NT4/2000/ME/XP/2003 43 True Type Fonts (TTF) Pack [3.75 MB, English]:

http://www.mdgx.com/files/TTFPAK.EXE

These TTFs are part of:

- MS IE 6.0 SP1:

http://www.mdgx.com/toy.htm#IEX

- MS Euro TTF Packs + Patches:

http://www.mdgx.com/add.htm#EUR

- MS Internet TTF Packs:

http://beebo.org/corefonts/

- MS Windows 2000 SP4:

http://www.microsoft.com/windows2000/downl...rvicepacks/sp4/

- MS Windows XP SP2:

http://www.microsoft.com/windowsxp/sp2/

- MS Windows 2003 SP1:

http://www.microsoft.com/windowsserver2003...rvicepacks/sp1/

Posted here:

http://www.mdgx.com/add.htm#TTF

and here:

http://www.msfn.org/board/?showtopic=46581

Enjoy.

Edited by MDGx

Share this post


Link to post
Share on other sites

Short ? What happens if you use SFC[system file checker] w/ sp 2 & 98se2ME installed, will it messup installation & revert things back to disk files?

Share this post


Link to post
Share on other sites

MDGx,

Thanks for the support, I'll try and get the disc started soon, at the moment I am still modifying 98/ME files.

Can't get the screenshots yet though, but the error message for my pics problem is as follows.

WiaMgr.Devices.Length is null or not an object

Code: 0

URL: file://C:\WINDOWS\Web\ImgView.htt

The solution was to right click folder, go into Customise the Folder Wizard, set folder type to classic view (thus, removing the thumbnails), go into the hidden subfolder (can't remember what it was called now) and delete the wvleft.gif, and then save the wvleft.bmp as a gif. This make it look like other folders. But you have to do this manually for each folder. And then the hidden subfolder had same prob. Repeating customise wizard creates another buggy subfolder, and so on.

The problem seems to be in the main Imgview.htt file although if u try to change it u get lots of funny errors appearing.

Hope this helps :D

Rjd123

Share this post


Link to post
Share on other sites

Um, I didn't get the System Properties general tab change back to 98 2nd Edition. It still says I'm running Me.

Also, when the system rebooted following the 98SE2ME batch run it froze while initializing the desktop and I needed to ctrl-alt-delete. When it booted up again the startup screen appeared saying Windows didn't boot properly and offering to start in Safe Mode. I declined, and it started up fine in normal mode this time.

I ran system file checker and the wdm audio files were updated as advertised, so the 98SE2ME did run. I needed to check because for some reason the splash screen had stayed up while the 98SE2ME batch was running so I couldn't view the dos messages (like "so many files copied with 0 errors" etc).

All is running fine, but I didn't get the general tab to change back to 98SE like you said.

I also don't know the effect of the Me WDM audio files since I'm using vxd audio at the moment.

A question. Does 98SE2ME do anything to USB joystick files? I ask because I've never been able to use my Saitek Gamepad P-880 on 98SE. But, since I've had the pad I've always run 98SE2ME so I don't know if the Saitek drivers would mess up Windows if I didn't have 98SE2ME installed. The pad and drivers run fine, but the "About" tab in the Saitek joystick control panel will freeze the control panel and Windows will have restart and shutdown problems with the Saitek driver installed. And they interfere with my USB printer as well. So I don't use the pad on 98SE. I've written Saitek, because I'd like to! We'll see if they reply with anything constructive. The Sidewinder Gamepad Pro USB and the Sidewinder Gamepad 1.0 don't give me any problems. Just the Saitek stuff. I just wondered if the Me joystick drivers are copied over and if perhaps they have something to do with the problem. Funny that the Sidewinder drivers and software (3.02 and 4.0) don't mess up anything.

Share this post


Link to post
Share on other sites
Um, I didn't get the System Properties general tab change back to 98 2nd Edition.  It still says I'm running Me.

Also, when the system rebooted following the 98SE2ME batch run it froze while initializing the desktop and I needed to ctrl-alt-delete.  When it booted up again the startup screen appeared saying Windows didn't boot properly and offering to start in Safe Mode.  I declined, and it started up fine in normal mode this time.

I ran system file checker and the wdm audio files were updated as advertised, so the 98SE2ME did run.  I needed to check because for some reason the splash screen had stayed up while the 98SE2ME batch was running so I couldn't view the dos messages (like "so many files copied with 0 errors" etc).

All is running fine, but I didn't get the general tab to change back to 98SE like you said.

I also don't know the effect of the Me WDM audio files since I'm using vxd audio at the moment.

A question.  Does 98SE2ME do anything to USB joystick files?  I ask because I've never been able to use my Saitek Gamepad P-880 on 98SE.  But, since I've had the pad I've always run 98SE2ME so I don't know if the Saitek drivers would mess up Windows if I didn't have 98SE2ME installed.  The pad and drivers run fine, but the "About" tab in the Saitek joystick control panel will freeze the control panel and Windows will have restart and shutdown problems with the Saitek driver installed.  And they interfere with my USB printer as well.  So I don't use the pad on 98SE.  I've written Saitek, because I'd like to!  We'll see if they reply with anything constructive.  The Sidewinder Gamepad Pro USB and the Sidewinder Gamepad 1.0 don't give me any problems.  Just the Saitek stuff.  I just wondered if the Me joystick drivers are copied over and if perhaps they have something to do with the problem.  Funny that the Sidewinder drivers and software (3.02 and 4.0) don't mess up anything.

Same here, but it has been happening since 6-30 ver.--but when you ctrl alt del

and it trys to start in safe mode and you move to normal mode it starts in Windows

and update files. The file it skipped on you was SYSDM.CPL just go to 9me folder

and move it out to replace yours with new 98 2nd Edition title in System Properties general tab.

I thought that their was something wrong on my computer when it keeps hanging

when it rebooted into windows--I get a blank screen with the hourglass that just sits their running until you ctrl-alt-del. Once done everything is just fine.

Glad to know its not just my OS!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...