Jump to content

Adoe Illustrator CS2


 Share

Recommended Posts

Not working for me... Setup hung at the very first screen.

I'm using this script and it finally successfull!

; AutoIt Options.
AutoItSetOption("TrayIconHide", 1)
AutoItSetOption("WinTitleMatchMode", 4)

Run('msiexec /i "' & @ScriptDir & '\Adobe_Illustrator_CS2.msi"')

; Welcome dialog.
If WinWait("Adobe Illustrator CS2 - Setup", "The InstallShield® Wizard will install Adobe Illustrator CS2") Then
ControlClick("Adobe Illustrator CS2 - Setup", "The InstallShield® Wizard will install Adobe Illustrator CS2", "Button1")
EndIf

; License Agreement.
If WinWait("Adobe Illustrator CS2 - License Agreement") Then
ControlClick("Adobe Illustrator CS2 - License Agreement", "", "Button5")
EndIf

; Customer Information.
If WinWait("Adobe Illustrator CS2 - Setup", "The following information must be entered before installation") Then
ControlClick("Adobe Illustrator CS2 - Setup", "The following information must be entered before installation", "Button2")
EndIf

; Destination Folder.
If WinWait("Adobe Illustrator CS2 - Setup", "Destination Folder") Then
ControlClick("Adobe Illustrator CS2 - Setup", "Destination Folder", "Button1")
EndIf

; Ready to Install the Program.
If WinWait("Adobe Illustrator CS2 - Setup", "Ready to Install the Program") Then
ControlClick("Adobe Illustrator CS2 - Setup", "Ready to Install the Program", "Button1")
EndIf

Sleep(5000)
AdlibEnable('_Adlib', 500)

; InstallShield Wizard Completed.
If WinWait("Adobe Illustrator CS2 - Setup", "InstallShield Wizard Completed") Then
ControlClick("Adobe Illustrator CS2 - Setup", "InstallShield Wizard Completed", "Button1")
EndIf

AdlibDisable()

Exit

Func OnAutoItStart()
; Single script instance only
If WinExists(@ScriptName & '_Interpreter') Then Exit
AutoItWinSetTitle(@ScriptName & '_Interpreter')
EndFunc

Func _Adlib()
; QuickTime 6 is required.
If WinExists("Adobe Illustrator CS2 - Setup", "QuickTime 6 is required") Then
ControlClick("Adobe Illustrator CS2 - Setup", "QuickTime 6 is required", "Button1")
EndIf
EndFunc

Link to comment
Share on other sites

  • 1 month later...

Final solution for installing Illustrator CS2 with AutoIt. Verified to work on both virtual and real format.

1. Edit the registration and userinformation fields in Abcpy.ini. (Leave the other options as default).

SERIALNUMBER=XXXX-XXXX-XXXX-XXXX-XXXX-XXXX
USERNAME=XXXXX
COMPANYNAME=XXXXXXXX

2. Run the following AutoIt script (compiled to .exe) with no switches from WPI/RunOnceExe or whatever you use to install applications.

; AutoIt Options.
AutoItSetOption("TrayIconHide", 1)
AutoItSetOption("WinTitleMatchMode", 4)

Run('msiexec /i "' & @ScriptDir & '\Adobe Illustrator CS2.msi"')

; Welcome dialog.
If WinWait("Adobe Illustrator CS2 - Setup", "The InstallShield(R) Wizard will install Adobe Illustrator CS2") Then
ControlClick("Adobe Illustrator CS2 - Setup", "The InstallShield(R) Wizard will install Adobe Illustrator CS2", "Button1")
EndIf

; License Agreement.
If WinWait("Adobe Illustrator CS2 - License Agreement") Then
ControlClick("Adobe Illustrator CS2 - License Agreement", "", "Button5")
EndIf

; Customer Information.
If WinWait("Adobe Illustrator CS2 - Setup", "The following information must be entered before installation") Then
ControlClick("Adobe Illustrator CS2 - Setup", "The following information must be entered before installation", "Button2")
EndIf

; Destination Folder.
If WinWait("Adobe Illustrator CS2 - Setup", "Destination Folder") Then
ControlClick("Adobe Illustrator CS2 - Setup", "Destination Folder", "Button1")
EndIf

; Ready to Install the Program.
If WinWait("Adobe Illustrator CS2 - Setup", "Ready to Install the Program") Then
ControlClick("Adobe Illustrator CS2 - Setup", "Ready to Install the Program", "Button1")
EndIf

; QuickTime 6 is required.
If WinWait("Adobe Illustrator CS2 - Setup", "QuickTime 6 is required", 900) Then
ControlClick("Adobe Illustrator CS2 - Setup", "QuickTime 6 is required", "Button1")
EndIf

; InstallShield Wizard Completed.
If WinWait("Adobe Illustrator CS2 - Setup", "InstallShield Wizard Completed") Then
ControlClick("Adobe Illustrator CS2 - Setup", "InstallShield Wizard Completed", "Button3")
EndIf

EXIT

;eof

:thumbup

I have messed my Abcpy.ini and now everytime i install illustrator using the script above, illustrator prompt me to enter the serial number, (I am using the autoit script mentioned above), what is weird for me is that if i try to install it by double clicking the Illustrator.exe which is the autoit file it installs perfectly without interruption but if i am doing it from an unattended xp it hungs on this windows "The following information must be entered before installation" when i enter my serial number, the autoit script continue normally

below is my Abcpy.ini

;***************************************************************

;Adobe Installer External Configuration File: Abcpy.ini

;***************************************************************

;***************************************************************

;Main Section

;The (Product) key is a required key

;***************************************************************

[MAIN]

Product=Adobe Illustrator CS2

AbcpyVersion=2.0

;***************************************************************

;OEM Installation Options

;***************************************************************

[OEM Install]

SERIALNUMBER=XXXX-XXXX-XXXX-XXXX-XXXX-XXXX

USERNAME=Nakkoush

COMPANYNAME=Home

INSTALLDIR=

ARPHELPLINK=

ARPHELPTELEPHONE=

ARPNOMODIFY=

do i need to put the serial number in this format?

SERIALNUMBER="XXXX-XXXX-XXXX-XXXX-XXXX-XXXX"

or maybe the sequence has to be the same as illustrator asks which is:

[OEM Install]

USERNAME=Nakkoush

COMPANYNAME=Home

SERIALNUMBER=XXXX-XXXX-XXXX-XXXX-XXXX-XXXX

Thanks in advance

Link to comment
Share on other sites

  • 2 weeks later...
do i need to put the serial number in this format?

SERIALNUMBER="XXXX-XXXX-XXXX-XXXX-XXXX-XXXX"

or maybe the sequence has to be the same as illustrator asks which is:

[OEM Install]

USERNAME=Nakkoush

COMPANYNAME=Home

SERIALNUMBER=XXXX-XXXX-XXXX-XXXX-XXXX-XXXX

Thanks in advance

both are correct

Link to comment
Share on other sites

So why it stops everytime telling me that there are some information i need to enter so i have to click "Back" and then enter the serial manually

then after i click next the Autoit continues...

Can you please plost me your Autoit...just hide your serial please if possible

Thanks in advance

Edited by Nakkoush
Link to comment
Share on other sites

  • 3 months later...
So why it stops everytime telling me that there are some information i need to enter so i have to click "Back" and then enter the serial manually

then after i click next the Autoit continues...

Can you please plost me your Autoit...just hide your serial please if possible

Thanks in advance

Hi,

I have the same probleme,

The Autoit script work but it still ask me the serial. My serial work and is in the Abcpy.ini.

When i launch the msi file without autoit it dont find my serial in Abcpy.ini ! I don't understand.

My Abcpy.ini look like :

[OEM Install]

USERNAME=Bluberry

COMPANYNAME=Home

SERIALNUMBER=XXXX-XXXX-XXXX-XXXX-XXXX-XXXX

Is this possible to enter the serial with autoit ? and how ?

Thanks, You're great :thumbup

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...