Jump to content

Acrobat Reader 7 install problems


Recommended Posts

Allright, I got a problem with the latest ar7 and I can't seem to solve it (yes, I've searched ;)).

After the installation of my uA CD, I try to open Acrobat Reader 7. It gives a "configuring"-MSI progress bar and then says it can't find the CD. How do you get rid of this bar? It would be great help if you could help me. I'm all new at this Unattended stuff. :)

If it matters, here's my installation code:

 <item display="Adobe Acrobat Reader 7.0">
 <execute display='Programma'>
   <program>#SOURCEDRIVE#\Install\Apps\ar\Adobe Reader 7.0.msi</program>
 <execute display='Snelheidsaanpassingen'>
 <execute display='Registeraanpassingen'>
   <arguments>/S #SOURCEDRIVE#\Install\Apps\ar\reader70.reg</arguments>

Link to comment
Share on other sites

/QB is a progress bar :)

But that's not the problem, let me try to explain it

- Windows installs

- at T-12 all applications installs

- First boot

- I open Acrobat Reader 7

- Launches a MSI windows syaing it's configuring acrobat reader.

- Pops up a "insert disk" error

I want Acrobat Reader to boot normally after a first install, without having to insert my disk just once. :)

Link to comment
Share on other sites

The only two files you need are the .msi and the data.cab file. I've just tested the install with the following command:

msiexec /i Acrobat.msi /qb

Acrobat installs displaying a progress window then exits the installer and I can go to start->programs and run it.

Make sure your working directory is the one the msi and cab are in otherwise you'll get an error saying it can't find the cab.


Link to comment
Share on other sites

But I _do_ install everything in T-12 and from CD. When I was instelling everything on first boot and from HDD it worked like a charm.

It DOES install, it just wants to configure afterwards, needing the original MSI.

Link to comment
Share on other sites

This happens because its an MSI advertised shortcut, not actual....

It might be far easier to use the quick installing package from here - http://ryanvm.net/msfn/.

That's the one made specifically for unattended installs. Its switchless too, so no switches needed just directly execute it.

Oh, and are you using a non-English version? If so, then we'll try a different method.

Link to comment
Share on other sites

Thanks! :)

I decided to stick with the RyanVM installer for now and make my own pack later, when the Dutch version is released. So now I can go complain about some other problems I have. :D

Edit: EXACTLY the same problem with RyanVM's. "Error 1706: no vallid source could be found for the product." after the first boot of ar7. Then it shuts down. :(

Edit2: looks like it was the moving of the plugins which caused the problem. Strange, as it worked fine a couple of days ago.

Link to comment
Share on other sites

cmdow @ /HID

MOVE "%ProgramFiles%\Adobe\Acrobat 7.0\Reader\plug_ins" "%ProgramFiles%\Adobe\Acrobat 7.0\Reader\plug_ins.BAK"
MD "%ProgramFiles%\Adobe\Acrobat 7.0\Reader\plug_ins"
COPY "%ProgramFiles%\Adobe\Acrobat 7.0\Reader\plug_ins.BAK\EWH32.api" "%ProgramFiles%\Adobe\Acrobat 7.0\Reader\plug_ins\."
COPY "%ProgramFiles%\Adobe\Acrobat 7.0\Reader\plug_ins.BAK\reflow.api" "%ProgramFiles%\Adobe\Acrobat 7.0\Reader\plug_ins\."
COPY "%ProgramFiles%\Adobe\Acrobat 7.0\Reader\plug_ins.BAK\Search.api" "%ProgramFiles%\Adobe\Acrobat 7.0\Reader\plug_ins\."


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...