Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

ActiveSync 3.8, how 2 unattend


MikeO
 Share

Recommended Posts

Here's how you can sillent install ActiveSync 3.8

Download ActiveSync 3.8

1. Start MSASYNC.EXE

2. Wait until the setup stop for user input.

3. Go to the folder: C:\Documents and Settings\(username)\Local Settings\Temp\IXP000.tmp (don't close the installation of MSASYNC.EXE)

4. Copy the content of that folder to C:\XPCD\$OEM$\$1\Install\Microsoft ActiveSync

5. Close MSASYNC.EXE (you don't need this)

6. Create in C:\XPCD\$OEM$\$1\Install\Microsoft ActiveSync a file called Silent.ini

6a. In that file you put:

; Settings for silent install

[ActiveSync]

InstallDir = %ProgramFilesDir%\Microsoft ActiveSync

UsePreviousPort = 1

CommPort =

ResetRasServerPorts = 1

DesktopIcon = 1

Reboot = 1

7. Put in your RunOnceEx.cmd

REG ADD %KEY%\035 /VE /D "Installing Microsoft ActiveSync 3.8" /f

REG ADD %KEY%\035 /V 1 /D "%systemdrive%\Install\Microsoft ActiveSync 3.8\setup.exe /s "silent.ini"" /f

That works for me.

Link to comment
Share on other sites

  • 3 months later...

Mike0

I am installing it the way you say, and that works. But I have one question.

When instaling it doesn't wait to finish. I mean as it is installing my RunOnce is going to the next ap etc...

Is there a way to let RunOnce wait to finish install of msasync, and only getting further when install is finished?

D@RKNeSS

Link to comment
Share on other sites

  • 2 weeks later...

Hej,

Try to use at the beginning of the command line;

start /wait %systemdrive%\Install\Microsoft ActiveSync 3.8\setup.exe /s "silent.ini"" /f

or

Start /w

This will wait untill the application above is finished installing.

Link to comment
Share on other sites

Mike0

I am installing it the way you say, and that works. But I have one question.

When instaling it doesn't wait to finish. I mean as it is installing my RunOnce is going to the next ap etc...

Is there a way to let RunOnce wait to finish install of msasync, and only getting further when install is finished?

D@RKNeSS

I resolved this by putting calling a sleep for 30 seconds. It seems that the installer calls for another installer, while closing the first one, making RunOnceEx think that the original one is done, and thus continuing on.

Add this command and you're done:

REG ADD %KEY%\### /V 2 /D "sleep.exe 30" /f"

(### standing for the correct numbers, of course.)

Also don't forget that you should have sleep.exe in your windows\system32 folder.

Link to comment
Share on other sites

@ Priapus Thanks

Going to try that. I was using this code.

REG ADD %KEY%\990 /VE /D "Instalatie van Microsoft ActiveSync 3.8" /f
REG ADD %KEY%\990 /V 1 /D "%systemdrive%\Install\PDA\setup.exe /s "silent.ini"" /f

I never have seen the wiat code before in RunOnceExe thought it was only used in batch comands. I think the NEWBIE is at place here :blushing::blushing:

@ Ben.Hahlen

And I am going to try ths also This is (I hope) solve my problem wit MSASYNC.

Thanks

D@RKNeSS

Link to comment
Share on other sites

@ Ben.Hahlen

I dont have sleep.exe in system 32. can you point me were I can get it?

@ Priapus

I have tryed your sugestion buy that didn't work. Am I using the code corect?

REG ADD %KEY%\99 /VE /D "Instalatie van Microsoft ActiveSync 3.8" /f
REG ADD %KEY%\99 /V 1 /D "start /wait %systemdrive%\Install\PDA\setup.exe /s "silent.ini"" /f

D@RKNeSS

Link to comment
Share on other sites

  • 5 months later...

I am trying, but failing, to create a script to silently install a number of applications and the first app on the list is ActiveSync 3.8.

I have followed the instructions in the OP regarding the source and decompression of ActiveSync 3.8 and I am using the following command in my .cmd script:

START /wait ~%dp0setup.exe /s "Silent.ini" /f
~%dp0 expands to 'E:\Software\ActiveSync_3.8\' so the command, which I echo to the screen to confirm, is:
START /wait E:\Software\ActiveSync_3.8\setup.exe /s "Silent.ini" /f

The decompressed files were copied to the E:\Software\ActiveSync_3.8 folder and is also the folder that contains my Silent.ini - the script also runs from this folder.

When the command runs the Microsoft ActiveSync Setup dialog is displayed stating that it is preparing the install shield. Once this reachs 100% a Setup error is displayed:

An internal read error has occured on E:\Software\ActiveSync_3.8\.INS. Unable to load installation instructions.

Error 703.

Any ideas or suggestions as to the cause if not the solution itself?

Many thanks.

Edited by lamaslany
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...