Jump to content

Help with adding user to WinXP SP2


 Share

Recommended Posts

Hi..

Please I need your help I'm traying to put user+Pass to my unattended WinXP SP2 CD ,,and i've followed the way wich in the www.unattended.msfn.org but it always given me errors..so I need Your help Please...

This is what I have do ...

$OEM$\cmdlines.txt:

[Commands]

"regedit /s settings.reg" ;To add Reg keys

"useraccounts.cmd" ;To add user+pass

$OEM$\useraccounts.cmd:

net user Ali 123123 /add

net localgroup Administrators Ali /add

net accounts /maxpwage:unlimited

REGEDIT /S autologon.reg

EXIT

$OEM$\autologon.reg:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]

"DefaultUserName"="Ali"

"DefaultPassword"="123123"

"AutoAdminLogon"="1"

And this is my winnt.sif:

[Data]

AutoPartition=0

MsDosInitiated="0"

UnattendedInstall="Yes"

[unattended]

UnattendMode=FullUnattended

OemSkipEula=Yes

OemPreinstall=yes

UnattendSwitch="yes"

TargetPath=WinXP

WaitForReboot="No"

FileSystem=*

DriverSigningPolicy=Ignore

NonDriverSigningPolicy=Ignore

[GuiUnattended]

AdminPassword=*

EncryptedAdminPassword=No

OEMSkipRegional=1

TimeZone=165

OemSkipWelcome=1

[userData]

ProductID=xxxx-xxxx-xxxx-xxxx

FullName="USER"

OrgName="Home"

ComputerName=ADMINISTRATOR

.......els not emportant..............

eror0.jpg

So where is my foalt.........???Please help me...............SOS.............SOS..........

it is always geven me this messege:

**I'v search in the threed about other ways but I'v found that is this the easiest way...but...still..no..working to me.....i'm sure the error from me....

Link to comment
Share on other sites


HI..........

I have changed the Computer name but it is geven me this Eror also !!

1.jpg

this what I have changed in the winnt.sif:

[userData]

ProductID=xxxx-xxxx-xxxx-xxxx

FullName="USER"

OrgName="Home"

ComputerName=prof

Link to comment
Share on other sites

I would suggest that when you get to this point manually type the password in and see if same thing happens.

Else, try and use a word like, "password" rather than numbers as your password for the admin user as all seems to look ok.

Reading tis url http://unattended.msfn.org/xp/autologon.htm I notice you don't have the line to AutoLogon set, add this and see how you get on.

Link to comment
Share on other sites

Same problem here, btw, in the last try in my winnt.sif there was

[GuiUnattended]EncryptedAdminPassword = No

AdminPassword = "password"

ProfilesDir = "\Profiles"

AutoLogon = Yes

TimeZone = 110

OEMSkipRegional = 1

OemSkipWelcome = 1

...and after login manually with Administrator:password it has given me an error about homedir of Administrator...in \Profiles\Administrator neither Start Menu or Desktop dir were present...

mrmr

Link to comment
Share on other sites

Hi..

Please I need your help I'm traying to put user+Pass to my unattended WinXP SP2 CD ,,and i've followed the way wich in the www.unattended.msfn.org but it always given me errors..so I need Your help Please...

This is what I have do ...

$OEM$\cmdlines.txt:

[Commands]

"regedit /s settings.reg"  ;To add Reg keys

"useraccounts.cmd"        ;To add user+pass

$OEM$\useraccounts.cmd:

net user Ali 123123 /add

net localgroup Administrators Ali /add

net accounts /maxpwage:unlimited

REGEDIT /S autologon.reg

EXIT

$OEM$\autologon.reg:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]

"DefaultUserName"="Ali"

"DefaultPassword"="123123"

"AutoAdminLogon"="1"

And this is my winnt.sif:

[Data]

    AutoPartition=0

    MsDosInitiated="0"

    UnattendedInstall="Yes"

[unattended]

    UnattendMode=FullUnattended

    OemSkipEula=Yes

    OemPreinstall=yes

    UnattendSwitch="yes"   

    TargetPath=WinXP  This should be \windows

    WaitForReboot="No"

    FileSystem=*

    DriverSigningPolicy=Ignore

NonDriverSigningPolicy=Ignore

   

[GuiUnattended]

    AdminPassword=*  set a password for this

    EncryptedAdminPassword=No

    OEMSkipRegional=1

    TimeZone=165

    OemSkipWelcome=1

 

[userData]

    ProductID=xxxx-xxxx-xxxx-xxxx

    FullName="USER"

    OrgName="Home"

    ComputerName=ADMINISTRATOR

.......els not emportant..............

eror0.jpg

So where is my foalt.........???Please help me...............SOS.............SOS..........

it is always geven me this messege:

**I'v search in the threed about other ways but I'v found that is this the easiest way...but...still..no..working to me.....i'm sure the error from me....

I made a few comments in your post. I am also including my winnt.sif and useraccounts.cmd file. This works great for me.

My useraccounts.cmd file

net user Tracy passwordgoeshere /add

net localgroup Administrators Tracy /add

net accounts /maxpwage:unlimited

REGEDIT /S autologon.reg

EXIT

My winnt.sif file:

;SetupMgrTag

[Data]

AutoPartition=0

MsDosInitiated="0"

UnattendedInstall="Yes"

[unattended]

UnattendMode=FullUnattended

OemSkipEula=Yes

OemPreinstall=Yes

TargetPath=\WINDOWS

FileSystem=*

UnattendSwitch="yes"

WaitForReboot="No"

DriverSigningPolicy=Ignore

[GuiUnattended]

AdminPassword=use a password here

EncryptedAdminPassword=No

OEMSkipRegional=1

TimeZone=35

OemSkipWelcome=1

[userData]

ProductKey=xxxxx-xxxxx-xxxxx-xxxxx-xxxxx

FullName="------"

OrgName="Personal"

ComputerName=Home

[Display]

BitsPerPel=32

Xresolution=1024

YResolution=768

Vrefresh=60

[identification]

JoinWorkgroup=MSHOME

[Networking]

InstallDefaultComponents=Yes

[branding]

BrandIEUsingUnattended=Yes

Home_Page=http://www.google.com

Don't know if that will help but that is what I use and it works every time.

Tracy

Link to comment
Share on other sites

Hi..

Please I need your help I'm traying to put user+Pass to my unattended WinXP SP2 CD ,,and i've followed the way wich in the www.unattended.msfn.org but it always given me errors..so I need Your help Please...

This is what I have do ...

$OEM$\cmdlines.txt:

[Commands]

"regedit /s settings.reg"    ;To add Reg keys

"useraccounts.cmd"          ;To add user+pass

$OEM$\useraccounts.cmd:

net user Ali 123123 /add

net localgroup Administrators Ali /add

net accounts /maxpwage:unlimited

REGEDIT /S autologon.reg

EXIT

$OEM$\autologon.reg:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]

"DefaultUserName"="Ali"

"DefaultPassword"="123123"

"AutoAdminLogon"="1"

And this is my winnt.sif:

[userData]

    ProductID=xxxx-xxxx-xxxx-xxxx

    FullName="USER"

    OrgName="Home"

    ComputerName=ADMINISTRATOR

So where is my foalt.........???Please help me...............SOS.............SOS..........

it is always geven me this messege:

**I'v search in the threed about other ways but I'v found that is this the easiest way...but...still..no..working to me.....i'm sure the error from me....

Firstly, I think "useraccounts.cmd" should be before "regedit /s settings.reg" in the cmdlines.txt

Secondly, you cannot use 'Administrator' as the 'Computer Name'.

Finally, let me ask you something, are you trying this in VMWare or are you having this problem with a real installation? The reason I ask this is, that I was getting the same message when I was trying my CD in VMWare, but when I tried a real installation with a real CD, everything went just fine.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...