Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
mark

ohcil1394.sys problem

Recommended Posts

Hey nuhi...
I experienced the same problem with ohci1394.sys in one of my builds with 1.0.1.
BUT: the ohci1394.sys was not damaged at all. In comparison with a file from a working iso it was exactly identical.
The reason why during initial setup message like ohci1394.sys is damaged came is:
6 files, including "1394BUS.SY_" were MODIFIED as UNUSABLE, i.e. when opening them with hex editor you could see that they don't have the original header anymore.
The most interesting thing about it is that they have not been altered by nlite. They just had the same date/timestamp as on the original CD.
I then just replaced these 6 files by files from my original CD... and it then worked after making an ISO out of the folder again!
So I just guess during extracting, making of the DRIVER.CAB, something went wrong.
it has NOTHING to do with lowercase/uppercase of ohci1394.sys.
nuhi.. maybe u can check this?

Share this post


Link to post
Share on other sites

Well I don't need to tell you that it's so rare that it's almost impossible to figure out.
Now we may have something if you tell me this:
-is it same as it was on original cd or is it replaced by a broken version from driver.cab?
Compare to both and see which is actually corrupted. Also check sp2.cab could be there too.

Share this post


Link to post
Share on other sites
I actually don't have the files anymore (don't ask me why I did not save them but replaced these 6 files by working ones :( )...
But I know that it was not the same as on original cd. the size and date/timestamp were exactly the same as on cd. but the content was different. so it must have been the second choice..
I know it is difficult to debug that... only happened to me one time in almost 1 3/4 years where I am working with nlite.
the only thing that i am also remembering about that build.. i was doing a lot of others tasks on my computer while nlite (and so extracting/making the cabs) was working in the background. maybe the corruption came because of this. maybe it is just better (and i almost always do it like that) when it runs as only main task while running...

Share this post


Link to post
Share on other sites
Ok, anyway keep your eyes open with next version.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...