Jump to content

Drive Letter Problem


 Share

Recommended Posts

I'm having trouble getting windows to setup my drives with the correct letters. I've been testing this in MS VirtualPC 2004.

What I have is:

Device (0,0,0) A brand-new, blank drive, unformated.

Device (0,1,0) A current, fat32 drive with some data on it.

I want to be able to format the new drive during setup and have it set to drive C: while the older drive become drive D:

So, in my winnt.sif file, i have these relevant settings:

[Data]
   AutoPartition=0
   MsDosInitiated="0"
   UnattendedInstall="Yes"

[Unattended]
   UnattendMode=FullUnattended
   OemSkipEula=Yes
   OemPreinstall=Yes
   UnattendSwitch="yes"
   TargetPath=\WINDOWS
   Repartition="no"

[GuiUnattended]
   OEMSkipRegional=1
   TimeZone=35
   OemSkipWelcome=1
   ProfilesDir ="D:\Documents and Settings\"

So anyway, when I boot from cd first time, i get the parition screen, and I choose to partition the new drive as NTFS, the old drive shows up as fat32 and because Its the only partitioned drive I says c:.

After it restarts again I go back to the partition screen just to check and it says:

c: ntfs

d: fat32

with the correct drive sizes corresponding, I must be all set.

Well, doesn't work out that way. When setup finishes and I go to login, I get something like "windows could not create a temporary profiles directory" and "windows could not load your user profile - Access Denied"

Notice I have my profilesdir set to D:\Documents and Settings, and that should put the profiles on the fat32 partition.

So, if I'm an administrator it lets me login with a system profile and it shows that:

c: fat32

d: cdrom

e: ntfs

Any Ideas on what I can do here to get this to work?

I will say that I'm using dynamically expanding virtual drives, would it work better If I used a fixed sized virtual drive? I thought it was transparent, the error messages say nothing about drive space.

Link to comment
Share on other sites


yeah sure it cant create any files or acces ur profile dir, b/c u said

c: fat32

d: cdrom

e: ntfs

and what a wonder, windows has no write access on your cdrom :)

im not sure what you wanna do, do you just want to use the ntfs partition as data hdd or do you want to install winxp on it?

u could set ur profiles dir to C:\docu.. b/c as u said when you login as administrator ur fat32 part. with ur profiles dir is drive lettered to C:\

if you want to clean install winxp on ur ntfs partition i recommend to disconnect ur fat32 for the setup of winxp and reconnect it when xp is installed. the ntfs partition should/must be C:\ now, b/c it was the only drive connected during install. if you connect hdds later they would never replace the C:\ letter, its 'reserved' by Windows. It would automatically get D:\ or something higher depends on what other drives are connected to ur pc. in your case it should get E:\ because ur cdrom drive was already connected, so it has drive letter d:\ (remember the ntfs partition has drive letter c:\

so u have 2 choices:

change ProfilesDir ="D:\Documents and Settings\" to ProfilesDir ="E:\Documents and Settings\" in your winnt.sif and install xp or keep it in D:\, install Windows, boot up, change drive letter from cdrom to e:\ or something higher. connect ur fat32 partition and it should automatically get drive letter D:\ which fits to your configuration.

btw, go sure to set the bios to boot from your new ntfs partition

c: fat32

d: cdrom

e: ntfs

looks like you booted from ur fat32 partition !

Link to comment
Share on other sites

Thanks Tribble, I guess I'll have to disconnect the HD during install then.

I might have to disconnect the cdrom as well so it doesn't make that D:

I wish there was some way you could force windows to change this, like set the cdroms to w: and x: so they're out of the way.

looks like you booted from ur fat32 partition !

It might seem that way but oddly e: is the boot drive. - the fat32 drive doesn't even have anything on it. (in my virtual pc test setup)

Link to comment
Share on other sites

Ok, tried installing with only 1 hdd (this time using VMWare trial, which has much better performance)

So now my system disk is c: but the cdrom is still d: and when I add the other disk it's e:

:-(

What I did was boot first time (textmode) to set up partition without the 2nd disk. Then when it restarted I shutdown the machine and installed the second disk, then started the machine.

I actually tried taking the cdrom offline but apparently setup still needs stuff from the cd during GUI Mode, so it restarted and I had to add the cdrom again.

I'm thinking It would be easier to set the profile directory to the sytem drive (c:) then move the profile directory after I install.

I'm not exactly sure how to do this. I know that you can change some settings in the [.../profilelist] key but I actually tried doing that with my previous tests (using e: for the 2nd hdd) and it didn't work.

So how would I go about moving the profile directory after install?

Link to comment
Share on other sites

change ProfilesDir ="D:\Documents and Settings\" to ProfilesDir ="E:\Documents and Settings\" in your winnt.sif and install xp

u tried this? b/c u said the cdrom was set to d:\ again and when u connected ur fat32 hdd it was set to e:\ .. this should work.

Link to comment
Share on other sites

@proneax

the driveletter problem is only while installing, after the OS is set-up,

you can change the driveletters with windisk (disk management)

(do this before you do/install anything else)

you can fist set the CD to Z: then D: is free again and you can use that for the second disk

gr /\/\o\/\/

gr /\/\o\/\/

Link to comment
Share on other sites

the whole problem was that the drive letter weren't set up properly when windows was putting stuff in 'all users' during installation.

What i finally ended up doing was using a boot program called Bootit-ng to set up an ntfs partition (not formated)

Then when I booted into setup it recognized the ntfs disk as c: (it was device 0) and the fat32 as d:

I also used the "slide" function of Bootit-ng to align the clusters on my fat32 drive so I could convert to NTFS without getting the 512byte clusters that you usually get. It worked great and my clusters are 4k.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...