Jump to content

nLite - Windows reduction tool


nuhi
 Share

Recommended Posts

just curious, their seems 2 be lots of ppl removing IE without any problems really, just wondering how much space i will save if i do this?

thanks :)

Link to comment
Share on other sites


the root problem is not something i would worry about

most of us wont ever use it in the root of a drive anyway simply because windows adds the recycle bin and system info. folders in there

i havent gone in depth on seeing why its doing it for me (but it could just be something within my system, some app/driver ive installed or something maybe)

but if i have some spare time i may look into it

and about those entries

if you want i could help with listing all the entries that are missing with each reduction set if you want

il have plenty of time tomorrow and over the weekend to play wiith it... just let me know if i could be of assistance in the beta testing

looking forward to the next version :)

this is going to become an awesome addition to any admin/utils collection

Link to comment
Share on other sites

Not sure if I'm doing anything wrong, but I have been noticing IE and OE missing or "acting up" when using nLite. Can't remember when I first noticed IE and OE missing since I have tested many of the betas, but here is what has happened with 9.2.

Image created with XPCREATE slip streamed updates

-- IE and OE installed, shortcuts in place.

-- all updates loaded and windows update showing none missing.

XPCREATE image extracted then nLite applied and nLite Image created

--IE and OE left unchecked in nLite (Internet Config wizard removed tho)

--IE installed, shortcut on desktop, but no in shortcut (programs - IE)

--OE installed, no shortcut in programs - OE

-- also 2 updates shown on windows update as not installed (KB835732 & KB826939)

I'll re run the images, try maybe a basic XPSP1 cd and apply nLite and see what happens with IE/OE, but mainly I think the problem is with IE installing or not installing. The updates might just be caused by IE not being installed or recognized properly. Like you said tho maybe this will go away in another version :).

Hope this helps and again great work nuhi!

Link to comment
Share on other sites

Ohh, man Ok a DISASTER.... i think i spoke too soon in my previous posts...

Ok the bugs are as follows :-

1. IE installed, but its hidded with the +s and +h attributes, so although the IE shortcut is im my startpanel, it takes me to internet properties window

2. Although i dint select the cursors to be removed, all the cursors were removed, man wass happenin ?? and the funny part is that i tested the SAME iso in vmware before i deleted my main OS, so wass this ?? very phunny !

3. Ok, have to agree with Zulu, i dint select wordpad for removal, but the **** thing removed it, funyy thing was that wordpad.inf was still there..

4. OK, so far everything easy to understand and tolerate, now the MORE buggys things, I cant set the firewall properties cuzz on the page in which the fw thingy appears, it says.. "Windows cannot display the properties of this connection. The WMI information maybe corrupted. To correct this, use System restore to restore windows to an earlier state, blah blah blah" :D man, this is s***... cant believe this, nothing of this sort happened in my vmware intallation !!

5. OMG this is gonna blow u off... i cant open the Local serurity snapin in Administrative Tools, :rolleyes: gives the error "Snapin Failed to initilaize. name unknown, clsid <some big text with numbers>" Then when i press OK, it comes Snapin creation failed again......

Man, all this happened to my main primary OS... i'm wreked :D Please suggest me, somethin !! if atleast i can get the 4, and 5th error rectified in my current instal, i atleast wont have to reinstall evrything...

The most annoying thing that happened to me was that, i accedentaly deleted my past 3years of emails :) , duh, i know this is not nlites fault, but its just my luck incompatibility issues with my stars.....

Ok, i hope this helps anyone... HELP MEEE !!!!

BYe,

Jazz

PS :- using 9.2 nLite, and Ohh, i get the following hotfixes in the list of to be installed in WinUpdate site..

Security Update for Windows XP (KB828741)

Security Update for Windows XP (KB835732)

Critical Update for Windows Media Player Script Commands (KB828026)

Update Rollup 1 for Microsoft Windows XP (KB826939)

816093: Security Update Microsoft Virtual Machine (Microsoft VM)

I'm posting my selected.ini ...

Log___Selected.txt

Log___Selected.txt

Link to comment
Share on other sites

Hi all,

i am using a german Version of Win XP Pro. (Corporate Edition), with Sp 1 (not 1a) integrated). If i try to reduce the size of my Installation Cd with NLite, it doesnt work for me. The NLite Log File shows nothing except the following Line:

28.05.2004 10:06:53 | Making ISO: ISOPathSelectWithButton

I really dont know, what i am doing wrong. I read the whole Thread yesterday, but i could not find any help. Anyone here, who can help?

Link to comment
Share on other sites

@Milgathia

Done this with v.9.0 (or was it 8.2?). If i rightly remember i run then in the problem with some DRM***.dlls (don't remember the right names). Reinstalling WMP works then, but i was not able to reinstall IE. I think someone here posted a workaround for that all and perhaps in v9.2 it is history because i haven't tested more till then. Perhabs i should try once more...

IE can be fast like a locomotive, but it can't never be my first choice...lack of functionality. I need Popup-blocking, Multi-Tabs (oh yes! I must have this....), very easy and fast switch to no Javascript-Support, open 20 sites on one click...and so on. IE is only possible for my with tools like MyIE. And i don't want talk about security...it is not the strongest side of IE  :rolleyes: ...so i only take IE for website-test.

But thanks for advice Milgathia :)

All is good that brings more speed!

About the IE reinstallation problem:

http://www.msfn.org/board/index.php?showtopic=19196&st=250#

As for its lack of funcionality, well, what about to use a wonderfull frontend like avantbrowser?

http://www.avantbrowser.com

I use opera, but sometimes i have to use IE too, so in those moments, I love to use something more "modern" and here avantbrowser comes! ;D

Kind Regards

Link to comment
Share on other sites

start nLite, browse for your XP CD folder [E:\XPCD as an example]

[NEXT] choose what u wanna remove

[NEXT] options screen

[NEXT] Custom file list

[NEXT] apply changes and make custom iso or click finish

hope this clarifies some (Not sure if nLite only works on english versions or not, that COULD be the prob) someone else could clarify that better maybe if it does or doesnt

Link to comment
Share on other sites

UPs,

thx MCT, now i found my mistake. I thought its just enough to choose "Make an ISO", after choosing the files i want to remove :)

Ah,

by the Way:

As i wrote, i use german XP Prof. (Corporate) and i got during the installation (Virtual Pc 2004) the message, that this files are missing:

Music.wma

music.asx

So it is probably not only a bug given using nlite with xp home edition

Link to comment
Share on other sites

@Milgathia: Thanks for posting the path to the IE reinstallation problem :D

About IE: I have written:"...IE is only possible for my with tools like MyIE..."

whitch don't mean that i have MyIE installed on my computer, but AvantBrowser is (since longer) :rolleyes:

Every Browsersolution based on the IE-Engine never will be really top-secure (ActiveX...)...there is no chance to bring me full on the IE-road.

I have learned Web-Publisher...first i loved IE, but how longer i gone to scool the more i hate this browser and all the plans of MS with Web-Standarts. Javascript was here and MS created JScript. SVG has come to a W3C Standart and MS take it, bring something in and...it's Avalon. Nothing against IE, but when you try to take clean W3C-Standarts, it is not a better browser then other. Many people says:"Hey, only IE does show me all sides correct!" Surely IE is good-natured when faults are in code of websites, but it is not the job of a browser to show faults in a correct way. And that sites buildet in Word (Oh, my God!) or Frontpage mostly run good on IE isn't a secret, but the look in the code make all hairs stand up (if you haven't lost before :) ).

Ok, perhaps it is now better with Frontpage then it was before but the rules that counts in Webstandarts are coming from W3C and not from only one concern called Microsoft.

I had to stop now, because this isn't a Brower-Thread. :D

Greetz

ZuluDC

Link to comment
Share on other sites

@HeiDiDo

look on the first page theirs a solution 2 yer prob

KNOWN BUGS:

- if you get missing files: music.wma, music.bmp and music.asx don't select Music Sample component until it's fixed (home edition)

Link to comment
Share on other sites

@sandman_qc, try first using nLite then tamper with installation...it may help

@MCT, almost nothing, it will only prevent it from installation and maybe deletes 2mb, fixing it today

@cb3dsl i don't get it, do you put your installation to 'c:\' or 'c:\somedir'

If it's in at least one dir you shouldn't have any problems.

You can send me a list of missing files, i only found 2 help files from speech component.

@Nemesis300,

IE and OE problem...select Recommended and no Experimental stuff, it must work

About missing updates, search few previous pages.

@Jazz

-ie stuff...that's how ms sees not installing it...i'm going to skip corefiles list in order to fully remove ie.

-cursors should stay if you didn't select them...what the...

-haven't look wordpad thing just yet

-wmi corrupted...you tampered somehow with installation additionally...i always install nlited windows on my real pc, no such problems

-snapin problem is connected to wmi and services...

-hotfixes are mistery

Conclusion is that you made some kind of mistake...it can't be that nlite suddenly stoped working.

Or even the funnier thing is that you tested on VMWare and everything was ok.

Try nLite on clean windows, add unattended stuff later.

(maybe xpcreate can be used before)

@ZuluDC, you're going to make me select ie :)

edit:

@HeiDiDo, ok, so it's language dependable...i never had music problem so i can't fix it...but some day i'll get exotic infs

Link to comment
Share on other sites

Read what HeiDiDo said again, more carefully this time.

i was aware what he wrote, he never said he fixed it, so i posted instructions on how 2 fix it..

Link to comment
Share on other sites

I still think the tab for creating the iso should be all the way at the end , to follow the flow of the process, but.. :)

<starting to collect latest drivers for my clean install tomorrow>

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...