Jump to content

No audio on Z690


abashera
 Share

Recommended Posts

I've installed Windows 7 Professional on a MSI MAG Z690 and i7-12700K, and so far everything's working perfectly except for the audio. What I'm pretty sure is the onboard sound card is showing up in the device manager as "Realtek USB2.0 Audio" as it disappears when I disable HD Audio Controller in the BIOS settings. I've tried installing drivers from MSI's website and older versions from Realtek directly but nothing's worked. Anyone know how to fix this?

mmc_1rMkO6IHeY.png

Link to comment
Share on other sites


  • 3 weeks later...

unfortunately those Realtek USB audio drivers for several MSI Z690 boards are in modern UAD/DCH format, which only work on recent 64bit Win10 versions (build 16299 or higher).  the RtDUsbAD_msi.inf file included in those USB audio drivers mention "NTamd64.10.0...16299", meaning NT 10.0 build 16299 is the minimum windows requirement and the RtUsbA64.sys driver file loads only with at least Win10 v1709

UAD/DCH drivers never work on anything less than Win10 v1709/RS3 (not even in Win7/8.x) and use HSA (aka. Hardware Support Application) based apps downloaded from Microsoft Store (and MS store also don't work on Win7)

edit - plus those Z690 boards from MSI came with Realtek ALC4080/ALC4082 audio chipsets which came out a few years ago in spring 2020, when Win7 was already EOL

Edited by erpdude8
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...