Jump to content

Windows 10 Stability Issues Which Version ' Update


RUSerious
 Share

Recommended Posts

Seeking feedback on which Win 10 Version ' Update is the most stable.
Was using, and now back to 16299-1709 in VHDX / MBR -- which was very solid.
Recently tried 19043.1110 VHDX / GPT which is very unstable on same hardware -- frequent BSOD ' lockups.
Using the awesome WinNTSetup as installer.
With default Windows drivers.
Feel free to recommend an app for updating drivers from what Windows uses.
Thanks
 

 

Edited by RUSerious
Link to comment
Share on other sites


anything 1904x (2004, 20H2 and 21H1) has huge issues with integrity. It runs fine for the first month, then after a while it starts decaying with broken C++ and update histories disappearing. This is because 19041.1 was finalized in December 2019, making all those versions about 2 years old now, with almost 24 cumulative updates available.

Avoid 1607. Update system is extremely flawed and its more wasted time than anything.

1507 is possible but no .NET 4.8 so many apps don't work anymore. Same with 1511.

I would say 1703, 1709, 1803, 1809, 1903 or 1909 was the period of time where Windows 10 was actually looking somewhat OK.

  • Like 1
Link to comment
Share on other sites

THANKS for the insights on Windows 10 builds.  I'm trying some different things.
I thought it might have been one of the optional updates >> drivers, that were offered (that I installed) that caused the issue.  There is a Realtec driver in there that I will definitely not install again (major PITA from Realtec drivers on other hardware in the past).
Very valuable to know of issues others have had with anything 1904x.  THANKS
Surprised that the update process varies so much between builds.

Edited by RUSerious
grammer
Link to comment
Share on other sites

  • 2 months later...
On 9/5/2021 at 12:00 PM, Tonny52 said:

 

Avoid 1607. Update system is extremely flawed and its more wasted time than anything.

 

I beg to differ on 1607 as that one became stable for me for most of my old PCs, especially with the LTSB 2016 variant of 1607 near the end of 2016 & beginning of 2017 and later

edit - and try telling that to this guy who runs 1607 & no other version but that one

Edited by erpdude8
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...