Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Unable to open MS-DOS command prompt window with GeForce GTX 1660 Ti


Recommended Posts

When I tried to launch an MS-DOS command prompt window in Windows 98 SE, my screen went blank. I could restart my computer by pressing Ctrl+Alt+Del, so the OS didn't freeze.
I didn't notice the issue because I can boot to command prompt without problem. And I guess other modern GPUs may have same issue because 32-bit operating systems are no longer supported.

I can open MS-DOS command prompt window with old integrated Radeon R7 Graphics (Kaveri).

Link to comment
Share on other sites

15 hours ago, halohalo said:

my screen went blank

can u check that ur 1660ti is support legacy videos modes (EGA 640x350 and lower)?
look as my problem with 1070....
i partially solved it by patching vdd.vxd, and can boot to 9x gui, run games like Worms, but here remain (other?) problem with opening in MSDOS window... and i can NOT debug it even with softice. :(

Edited by MERCURY127
Link to comment
Share on other sites

Try Alt-Enter to check if full screen works.

Or modify the shortcut properties.


Also, try to set a hotkey which changes the desktop resolution to another supported one. This way you can blind-type "exit" in the command prompt, then use the hotkey to recover your desktop without restarting.

Link to comment
Share on other sites

I tried to compare GeForce GTX 1660 Ti and Radeon R7 Graphics again by running DOS version of Zsnes.

Integrated Radeon R7 supports VESA2. It also supports VGA, SVGA (crashing), and SXGA (supported legacy video modes).

GeForce GTX 1660 Ti can't initialize VESA2. It supports SXGA (HDMI) and QHD (Displayport). I can open MS-DOS command prompt in full-screen mode, but the workaround does not always work.

Link to comment
Share on other sites

I am using inbox VGA driver.


I tried VBEMP and the SVGA driver few years ago. I need to open MS-DOS command prompt window, so VBEMP is not a perfect solution. Unfortunately, the SVGA driver from Windows 3.1 results in graphical glitches because the OS is Traditional Chinese version. If I have different motherboard, maybe I can run the emulator at SVGA mode with Integrated Radeon R7, but it is not my purpose.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...