Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Windows 98 - why the startup 'stops' 1 minute?


Joaquim
 Share

Recommended Posts

- i turn on the laptop;

- i see the Windows slash screen on startup;
- why, here, the boot 'stops' 1 minute(more or less) and then continues?

Link to comment
Share on other sites


I've had a desktop a long time ago that had similar quirks. There'd be a bit of Windows splash screen, a bit of BIOS left over screen with added Windows' messages about setting code page and at some point it would just sit there for several seconds with no disk activity. Granted, it wasn't that long (cca. 10s) and TBH, I don't recall anymore if there was just one waiting period or even two.

That PC had 233 MHz Pentium, 128 MB of RAM, some variant of ATI Mach and 2x 2 GB disks communicating via SCSI interface. It was used to run quirky (regarding compatibility with newer OS) accounting software. Eventually realized there wasn't much point in running it on that slow and noisy turtle since a better option was available, so I decomissioned it and migrated the software to the much more capable machine. The software was put inside a Windows 2000 virtual machine.

I never knew whether the waiting part was just the way it was or something could be done about it.

  • Like 1
Link to comment
Share on other sites

Posted (edited)

I do not know either but if you look into bootlog.txt after a logged start then after IO it usually loads drivers for the disk so I would make sure all of your hard-drive is in good shape. Make sure you back up everything before you do a defrag because if the disk bias recording level requirement (is my closest analogy like magnetic tapes) is not uniform throughout the media then there can be a read-write error and the file that happens to be unlucky and reside on the read-write error spot it will have to be deleted. It is important to set the recycle bin off for this as it will not be able to delete it otherwise. Best not to defrag first and check the drive with scan disk thorough and check all surface check. Perhaps your swap file is huge. It is the registry loading that takes the time so do a scanregw as well to make sure the registry is OK and I would run a RAM checking utility to check RAM is good too.

Edited by Goodmaneuver
  • Like 1
Link to comment
Share on other sites

3 minutes ago, RainyShadow said:

This usually happens to me after installing the network.

there is bug with DHCP on some cards. Try set static IP. I had hang on boot on my Pentium 3 since it

  • Like 1
Link to comment
Share on other sites

It is not a bug, let alone a bag ;), it is by design, (though poorly implemented in Win9x), some related info:

https://techgenix.com/w98tcpip/

Surprisingly Microsoft has still a related troubleshoot guide:

https://docs.microsoft.com/en-us/windows-server/troubleshoot/how-to-use-automatic-tcpip-addressing-without-a-dh

turning APIPA off may :dubbio: help, but the "right thing" to do is to use static IP addresses and using not DHCP (on the Win9x systems).

jaclaz 

 

  • Like 2
Link to comment
Share on other sites

8 minutes ago, MERCURY127 said:

static ip - very bad solution in real life...
so we need find or make good patch for vdhcp - it wiil better solution.

Define "real life".

To me "real life" (for a Win9x system) is not carrying it around and connect to *any* network, the machine(s) stay put in one place and connect only to the home network.

Of course having a "better" vdhcp would be a better solution :thumbup (BUT *tomorrow* :(), *today*, in "real life" :yes:, static IP is the only available one, more a workaround than a solution, still ....

jaclaz

  • Like 1
Link to comment
Share on other sites

9 hours ago, jaclaz said:

Define "real life".

cheap modern chinese ADSL or GPON router... which installed for user by local provide, w/o ask user opinion.
yes, here often is possible assign fixed ip for the machine, in router configuration page, but not always... :(

  • Like 1
Link to comment
Share on other sites

Network login is later on in the boot sequence. Networking can be disabled. If C: drive is OK then it can be any drive. Unplug all USB drives or turn off USB booting. Old BIOS has this feature displayed as USB function for DOS. 1 minute is not too bad, worst case is it does not boot at all. It can get faster with time and registry settings like system.ini PageBuffers=300; DMABufferSize=128; Make sure discs are operating in 32bit mode.

  • Like 1
Link to comment
Share on other sites

If it's a router, then it should allocate a range of addresses to choose from for the internal network. You wouldn't use a low power Win98 PC as the sole computer connected to a modem, or accept a random address that makes locating the computer for file transfer or other services difficult. You could always add a good router behind the Chinese device.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...