Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

QtWeb 3.8.4 crashes under Windows NT 4.0


Recommended Posts

 

I'm currently trying to run QtWeb 3.8.4 with QtWebKit v2.2 (QtWeb-qtwebkit22.exe) that is designed to work under Windows NT 4.0.

I'm currently running Windows NT 4.0 under VMware Workstation Player v16.1.2 and when attempting to run QtWeb 3.8.4, the browser crashes with the following error provided by Dr. Watson:

924623473_QtWeberror.thumb.png.f47c354a8cc0be515910d0a5520c60c3.png

The error message that I received was a Illegal Instruction (0xC000001D) and this error might have also occured when attempting to run a Virtual PC 5.2 virtual machine under Windows NT 4.0 guest.

Does anyone have any idea what I could be missing here and how this can be resolved?

Link to comment
Share on other sites


QtWeb needs SSE instructions. I don't know if VPC supports it or not. VMWare supports SSE if your host CPU supports it.

and NT4 needs installing SSE driver to enable usage of SSE instructions.

Edited by roytam1
Link to comment
Share on other sites

Posted (edited)
27 minutes ago, roytam1 said:

QtWeb needs SSE instructions. I don't know if VPC supports it or not. VMWare supports SSE if your host CPU supports it.

and NT4 needs installing SSE driver to enable usage of SSE instructions.

Thank you for telling me. Apparently, when Connectix released Virtual PC 5.2, it apparently made improvements to the CPU that requires SSE instructions.

The driver that I need is the Windows NT Intel SSE driver (intlfxsr.sys) which is included in Service Pack 5. How can I install it?

Edited by ppgrainbow
Link to comment
Share on other sites

31 minutes ago, ppgrainbow said:

Thank you for telling me. Apparently, when Connectix released Virtual PC 5.2, it apparently made improvements to the CPU that requires SSE instructions.

The driver that I need is the Windows NT Intel SSE driver (intlfxsr.sys) which is included in Service Pack 5. How can I install it?

there should be an INF file come among with the sys file, right-click on INF file and select "Install" to install. if your host CPU is not Intel, you have to patch the sys file.

Edited by roytam1
Link to comment
Share on other sites

5 minutes ago, roytam1 said:

there should be an INF file come among with the sys file, right-click on INF file and select "Install" to install. if your host CPU is not Intel, you have to patch the sys file.

Okay, I ran the installer manually by using RUNDLL32 with this command:

Quote

rundll32 setupapi.dll,InstallHinfSection IntelSection 132 "K:\Temp\SP6a\update\update.inf",

The installer requested the file \intlfxsr.sys and the file was in K:\Temp\SP6a\ sub-directory. After I rebooted, I checked the Event Viewer and found that a Event 3 warning has occurred in intlfxsr driver:

Quote

Streaming SIMD extensions are not supported by some of the processors in this system.

My host CPU is AMD FX-4300. How can I patch the intlfxsr.sys file to make it work with AMD host processors? :}

Link to comment
Share on other sites

Posted (edited)
11 hours ago, roytam1 said:

Thank you so much! :)

I tried your ntsse.zip patch file found here, I managed to install your patch, by running the nt4sse.reg file and replacing the intlfxsr.sys file that was shpped with SP6 with your patched versiom and...what do you know. QTWeb now works! :)

QTWebWorking.thumb.png.4eaf0eeedbf1a32c54fc06e0b3682eb2.png

I'm gonna try testing out the last working versions of VLC Media Player and Connectix Virtual PC 5.2 to see if it works now that the patch has been applied! :D

I tried to find the ntsse.zip file on your original website, but it seems that it's no longer there. The webpage appears to be blank.

Edited by ppgrainbow
Link to comment
Share on other sites

1 hour ago, ppgrainbow said:

Thank you so much! :)

I tried your ntsse.zip patch file found here, I managed to install your patch, by running the nt4sse.reg file and replacing the intlfxsr.sys file that was shpped with SP6 with your patched versiom and...what do you know. QTWeb now works! :)

QTWebWorking.thumb.png.4eaf0eeedbf1a32c54fc06e0b3682eb2.png

I'm gonna try testing out the last working versions of VLC Media Player and Connectix Virtual PC 5.2 to see if it works now that the patch has been applied! :D

I tried to find the ntsse.zip file on your original website, but it seems that it's no longer there. The webpage appears to be blank.

that ddns domain provider is no longer exist.

Link to comment
Share on other sites

1 hour ago, roytam1 said:

that ddns domain provider is no longer exist.

Thank you for telling me.

I also managed to get VLC Media Player 0.8.6e and Connectix Virtual PC 5.2 build 418 to work under Windows NT 4.0 SP6 with your SSE patch:

539065998_VPCVLC.thumb.png.03daa26c230d7cf29868662d56c5ee62.png

Sorry if the output of the screenshot is turning out not so good, but I need to reduce the size of the image to be under the 191.36 KB maximum image size. :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...