Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Extreme Explorer 360 Chromium 78-86 General Discussion


Recommended Posts

On 7/22/2021 at 4:15 AM, ArcticFoxie said:

Okay, I decided to put my money where my mouth is.

I think you'll agree this to be proof.

We know that UA-CH did not exist in Chrome 80 and we know that UA-CH is enabled by default in Chrome 92.

html5test.com gives that "imitates" in the results for Chrome 80 and for Chrome 92 - has nothing to do with UA-CH (which I "think" was your claim, not sure? I can't follow your posts at times).  And as my geometry teacher used to say  --  Q. E. D.  :roll1:

spacer.png

 

spacer.png

Like you ordered , with proof . 

I decided to bash them with something more sophisticated. It is not easy , to fake an iPhone agent , you will need to write a programme for this.

I've succesfuly blocked the vendor string detection by UA ! UA wasn't able to collect any hints about my real vendor . 

Now you can try to use any iPhone useragent for yourself or use the one below .

Choose an iPhone useragent with your extension and try https://html5test.com/ . It will still detect that your cheating.

Oh , and I'm just really curious , you see , I do upvote your posts , will you upvote mine , cause it really shines and it's a huge breakthrough in terms of privacy . No ? How so ? Something personal ?

Agents for this testing taken from here . https://whatmyuseragent.com/browser/mf/mobile-safari/14 

Mozilla/5.0 (iPhone; CPU iPhone OS 14_4 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.0 Mobile/15E148 Safari/604.1

Mozilla/5.0 (iPhone; CPU iPhone OS 14_6 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.0 Mobile/15E148 Safari/605.1.15

Mozilla/5.0 (iPhone; CPU iPhone OS 14_6 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.0 Mobile/15E148 Safari/604.1

Mozilla/5.0 (iPhone; CPU iPhone OS 14_5_1 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.5 Mobile/15E148 Safari/605.1.15

Mozilla/5.0 (iPhone; CPU iPhone OS 14_5_1 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.0 Mobile/15E148 Safari/605.1.15

Mozilla/5.0 (iPhone; CPU iPhone OS 14_5_1 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.0 Mobile/15E148 Safari/604.1

Mozilla/5.0 (iPhone; CPU iPhone OS 14_5 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.1 Mobile/15E148 Safari/604.1

Mozilla/5.0 (iPhone; CPU iPhone OS 14_5 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.0 Mobile/15E148 Safari/605.1.15

 

360_proof.png

Edited by Dixel
Added agents
  • Upvote 1
Link to comment
Share on other sites


Has anyone figured out what .css entry/entries can be tweaked to fix this nuance?

I'm in v13 and I think this nuance exists in earlier versions also but not 100% sure on that.

When you are in settings and on the Advanced tab, open the Content settings dialog.

Take note of how everything is positioned on the Content settings dialog - particularly the header title.

Now open any of the Manage buttons.

Another dialog will open above the Content settings dialog.

But the header title of the Content settings dialog disappears and everything below it shifts up.

Watch the small portions of the Content settings dialong that are still visible along the left edge of the Manage dialog that is now on top, close the Manage dialog and you'll watch everything shift back down and the header title reappear.

  • Like 1
Link to comment
Share on other sites

Task Manager memory usage, no extensions, no page visited  --

v13 build 2206 rebuild 2  ==  83,508K

v13 build 2206 RuPack  ==  81,700K

v13 build 2206 rebuild 3  ==  80,388K

Edited by ArcticFoxie
Link to comment
Share on other sites

Thanks to some suggestions by @Humming Owl from his Modified v12, I can hereby report that v13 build 2206 rebuild 3 makes ZERO connections on First Run.

Let it sit open for 20 minutes on about:blank without visting any sites, never made any connections in that entire 20 minutes (this was the case for rebuild 2 also, aside from First Run gstatic connection within seconds of launch).

Navigated every settings page, never made any connections the entire time (never actually tested this in rebuild 2, it might have done a favicon connection in the Search Engines settings, not positive).

Closed and relaunched three times, never made any connections (this was also the case for rebuild 2).

I should be ready to upload v13 build 2206 rebuild 3 sometime tomorrow.

Link to comment
Share on other sites

12 hours ago, ArcticFoxie said:

Has anyone figured out what .css entry/entries can be tweaked to fix this nuance?

I'm in v13 and I think this nuance exists in earlier versions also but not 100% sure on that.

When you are in settings and on the Advanced tab, open the Content settings dialog.

Take note of how everything is positioned on the Content settings dialog - particularly the header title.

Now open any of the Manage buttons.

Another dialog will open above the Content settings dialog.

But the header title of the Content settings dialog disappears and everything below it shifts up.

Watch the small portions of the Content settings dialong that are still visible along the left edge of the Manage dialog that is now on top, close the Manage dialog and you'll watch everything shift back down and the header title reappear.

I just saw it and it is pretty funny. However the title is still there, just moved up (saw it with the developer tools). I have no idea how to fix it as dealing with margins and relative positions of objects in CSS is a bit complex.

Link to comment
Share on other sites

v13 build 2206 rebuild 2 file size  ==  90.0 MB

v13 build 2206 rebuild 3 file size  ==  70.2 MB

login resources have been removed (which also removed Avatar context menu [may bring it back in a later rebuild to use as dropdown for chrome URLs])

@Humming Owl's v12 modfications have been ported to v13  --  no more gstatic connection on First Run   ---   I have not tested for possible side effects but will report if I do find any

all settings pages fit in one 1920x1080 viewport - it always bugged me that you could be three dialogs in, close that third dialog, and the second dialog defaulted itself back to the top and you have to find where you were at, just annoying so I fit all to one page

 

https://dl.dropboxusercontent.com/s/qyyimm3h58r3963/360Chrome%202206%20rebuild%203%20-%20unran%20-%20MSFN.zip

  • Like 4
Link to comment
Share on other sites

On 7/25/2021 at 7:26 PM, ArcticFoxie said:

v13 build 2206 rebuild 2 file size  ==  90.0 MB

v13 build 2206 rebuild 3 file size  ==  70.2 MB

login resources have been removed (which also removed Avatar context menu [may bring it back in a later rebuild to use as dropdown for chrome URLs])

@Humming Owl's v12 modfications have been ported to v13  --  no more gstatic connection on First Run   ---   I have not tested for possible side effects but will report if I do find any

all settings pages fit in one 1920x1080 viewport - it always bugged me that you could be three dialogs in, close that third dialog, and the second dialog defaulted itself back to the top and you have to find where you were at, just annoying so I fit all to one page

 

https://dl.dropboxusercontent.com/s/qyyimm3h58r3963/360Chrome%202206%20rebuild%203%20-%20unran%20-%20MSFN.zip

I will try it Tomorrow or the day after

Link to comment
Share on other sites

On 3/31/2021 at 6:51 AM, ArcticFoxie said:

Um, is this a "real" post/enquiry ???

What kind of a s***-ty thing to say is that.

If you don't know the answer then you need not reply.

Edited by Hunterw
clarity
  • Upvote 1
Link to comment
Share on other sites

On 3/31/2021 at 4:32 AM, Hunterw said:

This thing is letting the screen saver cover full screen video.

Is there a way to prevent it?

Stirring the pot?

That was on page 20 and we are now on page 57.

That was March 31 and we are now July 29.

 

Your original enquiry was four months ago and you return with that sort of reply?

I will quote you, "what kind of a sh!77y thing to say is that" ?

 

Here is the answer to your enquiry from four months ago.

What you are encountering (screen saver kicking in during full screen video) is nothing new, Media Player 11 had it's own setting to prevent this because the OS doesn't always know if an app is in full screen or not, it was a very common complaint while playing PowerPoint 2010 slideshows, et cetera.  This issue is over a decade old and newer operating systems do a better job at detecting whether an application is in full screen mode or not.  But alas, XP doesn't do as well as newer operating systems in this regard.

 

Here is the application that I personally use when I don't want my screens to go black during times where the computer is chugging, chugging, chugging and there is nothing for me to do with the mouse or keyboard until that chugging is completed.  It's called "Caffeine" and sits in the systray next to your clock.  You toggle it off or on and when it is on, your screen will not go black despite no mouse or keyboard activity.  The about-screen for it shows this address  --  www.zhornsoftware.co.uk

Link to comment
Share on other sites

Quote

Stirring the pot?

That was on page 20 and we are now on page 57.

That was March 31 and we are now July 29.

And? Did I not wait long enough for a reply? I wouldn't even have brought it up if you hadn't made your non-reply to it. I wasn't even talking to you. I was just asking the forum for help and YOU stirred this sh-it up. Not me. I just asked an innocent question. I didn't ask for your opinion on it.

Quote

 

Your original enquiry was four months ago and you return with that sort of reply?

I will quote you, "what kind of a sh!77y thing to say is that" ?

 

You're quoting something I wrote about your reply because I don't come here often? O...k...

Quote

Here is the answer to your enquiry from four months ago.

Finally.

Quote

 

What you are encountering (screen saver kicking in during full screen video) is nothing new, Media Player 11 had it's own setting to prevent this because the OS doesn't always know if an app is in full screen or not, it was a very common complaint while playing PowerPoint 2010 slideshows, et cetera.  This issue is over a decade old and newer operating systems do a better job at detecting whether an application is in full screen mode or not.  But alas, XP doesn't do as well as newer operating systems in this regard.

Here is the application that I personally use when I don't want my screens to go black during times where the computer is chugging, chugging, chugging and there is nothing for me to do with the mouse or keyboard until that chugging is completed.  It's called "Caffeine" and sits in the systray next to your clock.  You toggle it off or on and when it is on, your screen will not go black despite no mouse or keyboard activity.  The about-screen for it shows this address  --  www.zhornsoftware.co.uk

 

Thank you for the suggestion. I hope you will understand why this is unsatisfactory. Don't blame XP. Firefox doesn't do this. Chrome doesn't do this. They had a way of maintaining activity without peripheral inputs. I am frustrated by 360's inability here, because I watch a lot of video. A little confusing even since it's Chromium but apparently the part that handles the screen saver/monitor sleeping isn't included. I'm on 360 v12.

I can just turn those things off for everything, which is an annoying pain in the a**, IMO not too much different from installing a special program and manually switching it on so that the half broken browser can get worked around.

  • Upvote 1
Link to comment
Share on other sites

@Hunterw, you can try my suggestion for your screen going off . You need a player that is called "Aiseesoft Bluray Player portable" . Just do not install it ! It's chinese , you've been warned , though I didn't notice anything bad . Block it the firewall , of course ! Also , you need to look for a portable version , then just open it and leave it be . It will prevent the screen saver and your monitor from going off while watching videos in 360 browser or even playing . It was the only solution that worked for me . I do not even use the player itself , I just open when I want my screen to remain on. The suggestion by the member  @ArcticFoxie doesn't work for me , maybe because I'm on Vista , not XP. BTW , you're very lucky he didn't go caps-locking on you , lol. 

Edited by Dixel
missed a letter
  • Upvote 1
Link to comment
Share on other sites

5 minutes ago, Hunterw said:

Thank you for the suggestion. I hope you will understand why this is unsatisfactory. Don't blame XP. Firefox doesn't do this. Chrome doesn't do this. They had a way of maintaining activity without peripheral inputs. I am frustrated by 360's inability here, because I watch a lot of video. A little confusing even since it's Chromium but apparently the part that handles the screen saver/monitor sleeping isn't included. I'm on 360 v12.

You're welcome.

I don't actually use "screen savers".

If you monitor CPU usage, you'll find they pretty much always increase CPU usage as opposed to just letting the screen go black via XP's "Power Schemes".

I use Performance Monitor from http://www.hexagora.com/en_dw_davperf.asp to monitor CPU usage.

I stopped running "screen savers" when it revealed the CPU has been running at 60% for hours on end instead of a normal <2% for "idle"  --  kill the CPU but "save" the screen?  Screen doesn't do me any good if the CPU dies  :puke:

I haven't had much luck with 360 v12 so I'm a bit limited in guiding you further.

Googling isn't much help either, tons of finds and this issue has been around for quite some time.

I did find some solutions for the OPPOSITE - for folks who are on fullscreen mode but WANT the screensaver to kick in when an HTML5 video is playing fullscreen.

 

I did find ONE post that said the fix for them was to DISABLE HARDWARE ACCELERATION.

Do you have Hardware Acceleration enabled by chance?  If so, maybe disabling that will work?

Link to comment
Share on other sites

4 hours ago, ArcticFoxie said:

Do you have Hardware Acceleration enabled by chance?  If so, maybe disabling that will work?

Nah, it's off.

I just checked the CPU usage for the screen saver I was using, and it's...nothing really. Looks the same as idle. I was actually using the "Windows XP" screen saver for years until I noticed it always hijacked focus from the active window (the other screensavers don't do this - of course). So I switched to "starfield." I just like the effect.

I plan on trying out one or two of Humming Owl's builds, at least, to see how stable they are. I have the "Russian" version and it is not awful actually, I have to switch the kernel back to webkit a few times a day and I get a CTD maybe every couple of days - I know not to stress it, and I've been copying text before I submit it a lot - but it's ok because it saves the session.

Compared to Opera on Windows 7 it's definitely somewhat slower (I'm going to try v11 later), and there are occasional pages it hates or just won't load, but the usability is actually not too far off.

Link to comment
Share on other sites

My screens don't need saving as none are CRT, though I have a screensaver that runs for 5 min before screen goes off. It's just for show.

CPU/GPU usage depends on how it's coded and how intensive scene it shows. There are others out there than just the ones that come with Windows.

Windows doesn't really detect fullscreen to prevent screensaver, it's up to applications to tell the OS it's not OK to fire up screensaver, turn off monitor, go to standby...

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...