Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Missing <Edit> Button/Control


Recommended Posts

3 hours ago, XPerceniol said:

Testing with - Mozilla/5.0 (Windows NT 5.1; rv:68.0) Gecko/20100101 Goanna/4.7 Firefox/68.0 Basilisk/52.9.0 - A Roytan1 Build.

Cleared the cache and still, I see many blank square buttons as I did when I just posted with new moon (palemoon).

1.thumb.JPG.e91ca6b72727698988520929e4dc5699.JPG

Yes , that is exactly my issue too ! Finally , a nice fella to back me up ! 

  • Like 1
  • Upvote 1
Link to post
Share on other sites

8 minutes ago, D.Draker said:

But where do you see "rounded edges" in my text ?

I was just saying how I like the rounded edges. Not saying you mentioned it.

3 minutes ago, XPerceniol said:

Testing with - Mozilla/5.0 (Windows NT 5.1; rv:68.0) Gecko/20100101 Goanna/4.7 Firefox/68.0 Basilisk/52.9.0 - A Roytan1 Build.

Cleared the cache and still, I see many blank square buttons as I did when I just posted with new moon (palemoon).

1.thumb.JPG.e91ca6b72727698988520929e4dc5699.JPG

Interesting. No squares here with Firefox 78.6.0 on vista. I do get those types of squares on Discord sometimes though.

  • Upvote 1
Link to post
Share on other sites
3 hours ago, Ximonite said:

I was just saying how I like the rounded edges. Not saying you mentioned it.

Interesting. No squares here with Firefox 78.6.0 on vista. I do get those types of squares on Discord sometimes though.

I too didn't have squares with the old design on firefox 78. But you said you have them sometimes too , at least on Discord , well just wait , perhaps they will appear here. See the previous post from  @XPerceniol who has them too.

  • Like 1
Link to post
Share on other sites

The missing icons could be caused by something blocking them.
Have you tried temporarily switching off any ad blockers or script blockers you may be using?
No help to you of course, but my old Firefox 52.9 ESR seems to display everything on the new forum layout absolutely fine, so it would be strange if a much newer version of Firefox was malfunctioning with it.
:dubbio:

Link to post
Share on other sites

@D.Draker@Ximonite@Dave-H@dencorso@xper and other MSFN moderators/staff

Guess what... Problem solved YAY - in both my palemoon [new moon] and basilisk [Serpent[ browsers - both @roytam1 browser builds.

untitled.thumb.JPG.de6265f0f8df662dc0251abd7e77df42.JPG

As you can (clearly) see, now, everything - all the buttons appear as they should!

Here are the changes I made to my prefs.js file..

I Removed the following lines - which in turn, will now allow the following (user_pref("gfx.) settings to run at their default(s). So, it appears to be something having to do with "gfx", at least in my case.

user_pref("gfx.blacklist.direct2d", 3);
user_pref("gfx.canvas.azure.backends", "cairo");
user_pref("gfx.canvas.skiagl.dynamic-cache", false);
user_pref("gfx.crash-guard.d3d11layers.feature-d2d", false);
user_pref("gfx.crash-guard.d3d11layers.feature-d3d11", false);
user_pref("gfx.crash-guard.status.d3d11layers", 2);
user_pref("gfx.direct2d.disabled", true);
user_pref("gfx.downloadable_fonts.disable_cache", true);
user_pref("gfx.downloadable_fonts.enabled", false);
user_pref("gfx.downloadable_fonts.woff2.enabled", false);
user_pref("gfx.font_rendering.cleartype.use_for_downloadable_fonts", false);
user_pref("gfx.font_rendering.graphite.enabled", false);
user_pref("gfx.font_rendering.opentype_svg.enabled", false);

EDIT:

Don't ask me why.. I just had a 'hunch' is was something to do with those settings :)

Edited by XPerceniol
  • Like 1
Link to post
Share on other sites
13 minutes ago, XPerceniol said:

user_pref("gfx.downloadable_fonts.disable_cache", true);
user_pref("gfx.downloadable_fonts.enabled", false);
user_pref("gfx.downloadable_fonts.woff2.enabled", false);

I'd almost bet one of the three settings above, or maybe even all 3 of 'em, are critical ones.
But even in case I'm wrong, congrats for the successful troubleshooting! :thumbup

  • Like 2
Link to post
Share on other sites

@XPerceniol
user_pref("gfx.downloadable_fonts.enabled", false);
user_pref("gfx.downloadable_fonts.woff2.enabled", false);

That means you had forbidden to download icon FONTS at every page visit. Usually linked directly from googlefonts (probably great for tracking), as all major websites do nowadays. Your other settings are probably innocent...

  • Like 2
Link to post
Share on other sites

For fellow sufferers on really OLD Browsers, e.g. K-Meleon1.6/Firefox3.5 or KM74/Firefox24 or similar, have yesterday fiddled with 2 little workarounds. Not pretty but at least avoids needing to disable ALL page styles completely.

1) Unhide the REPORT / EDIT-Links:
https://msfn.org/board/topic/180462-my-browser-builds-part-2/?do=findComment&comment=1193762

2) Flip up the MENU on Profile name (on top, if logged in)
https://msfn.org/board/topic/180462-my-browser-builds-part-2/?do=findComment&comment=1193769

This may stop working anytime, as the forum software update isn't quite finished yet.
Those codes go into file userContent.css in profile folder/chrome/, or whatever other method anyone may use.
.

Edited by siria
Link to post
Share on other sites

Glad I could be of some help here for a change - I was beginning to think I was "leaching" here rather than being of some benefit to the forum Lol..

Yeah, @siria google does what google does best...don't they :rolleyes:

 

Link to post
Share on other sites

LOL! That's what forums are here for after all :D

("Mysterious" messed rectangles / icon fonts)
But guess what? Just realized I can see those Rectangle-Icons as graphics too, at least those in top header line etc, in my ancient machine! Although I had suspected this all along, since investigating that stuff some 2 years ago, but meanwhile partly forgotten again. Now found to my surprise, I had actually at some point downloaded and installed this infamous "Awesomefont" locally! So now just tried to add it to my browser default fonts, but didn't work at first. Then toggled browser setting "Allow websites to use other fonts" - and bingo! :)
(browser.display.use_document_fonts = 1)

Installing Awesomefont locally means the font download can be forbidden again in prefs.

That was fun for a moment, but now it also dimly dawns again, guess it had worked in the past too, at some point. Not all letters on this old machine, only those on the "lower unicode planes", but then had trouble with allowing "other fonts". Many websites started looking worse, using another font as Arial, so I toggled it off again. And will do that again now, just try to remember for the future how it works when wanting to check for a moment which letters some website shows...
.

Link to post
Share on other sites

Thanks for the suggestion , @XPerceniol. But there's no way I'm allowing any remote fonts.  And even if I do , it won't help with the not working pop-up menus. And I'm really sorry for users who prefer (at least some privacy) on older OS and esp. users with old browsers . Good luck with the new changes.

  • Like 1
Link to post
Share on other sites

here's a good read for ya , from the respected member @sdfox7

https://msfn.org/board/topic/176837-disable-web-fonts-in-google-chromemozilla-firefox/

  • Like 1
Link to post
Share on other sites

The website is completely broken for me . Any pop-up menu is not working , even sign-in . I can't edit posts , I can't select options in the messenger . Everything worked fine right until the recent changes. Clear cache and reboot PC is not helping ( surpise xD ) . I'm on Chrome 88 and Vista.

  • Upvote 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...