Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Windows XP does not ask Android for password on LAN


Recommended Posts

I can view shared files from any Android phone on a Windows XP computer on the same network without Windows XP asking for the network password.
Why does this happen?
How can I force Windows XP to ask for the password at least the first time?

Link to post
Share on other sites

14 hours ago, RainyShadow said:

How are those files shared on the Android side?

I use the Samba Filesharing app and it has a setting for password.

 

You can use "Map Network Drive" in Explorer to save a password for a remote share.

I go to the file explorer and share the folder with right click + properties + share folder.
I have simple file sharing on FAT32.
I have tried the following:
-Disable simple file sharing.
-Deactivate "control userpasswords2" (I have it on automatic password when logging in).
-I have also read about this option:
Administrative Tools + Local Security Settings + Local Policies:
Network Access: Sharing and security model for local accounts
But surprise !!! In this Windows XP copy that option is not listed.
On Local Policies I only have 7 options listed. In other Windows XP copies there are more than 50 options listed on Local Policies.
The version is Windows XP Professional and comes from the same installation disc.
I will try "Map Network Drive" on Windows XP explorer.
On Android I use ES File Explorer and various DLNA explorers.

Edited by Cixert
Link to post
Share on other sites

Ok, try this:

In "Folder options" deactivate "Simple file sharing".

Open the settings for a share, click the "Permissions" button and remove "Everyone". Add specific accounts that have a password, or a group like "Administrators", "Power users", etc.
On NTFS shares you can also check the "Security" tab and make the same changes. This isn't available for FAT folders.

Click "Apply", grab an Android device and test again.

 

About local policies, try starting gpedit.msc instead. Check the options in "Computer configuration" > "Windows settings" > "Local policies" > "Security options"

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...