Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Shimgvw.dll working in Windows 98SE


Recommended Posts

I recently started messing about Windows 98 SE again with RP7 aan 98SE2ME. I read in older form posts that shimgvw.dll from Windows Me could be transferred to 98, but from my understanding with mixed results.

So my question is, is it possible to get shimgvw.dll from Windows Me working in 98SE? 

I have tried RP7 in combination with 98SE2ME but with no luck sadly.

Link to post
Share on other sites

> I have tried RP7 in combination with 98SE2ME but with no luck sadly.

What is the issue in more-specific terms?

I have been using RP7 and 98SE2ME together for many years with no apparent problems. I always install U98SESP3, 98SE2ME, KernelEx, and RP7, in that order. IIRC, in my experience, RP7 does not install correctly without KernelEx.

Also, i do not have a shimgvw.dll anywhere on my system.

- Doug B.

Link to post
Share on other sites

In Windows Me you have a preview of the pictures in the explorer windows, where you can zoom in/out etc. The file that is responsible for that is shimgvw.dll, and would be nice to have in 98SE in my opinion :).

I also do not have any errors with 98SE2ME or RP7, although I havent tried the latter with KernelEx. 

Yeah from older form posts here on MSFN I found that 98SE2ME used to include the copying of shimgvw.dll (can still be seen in the o3.bat) but was later disabled due to it not working right, so by default it is not copyied to the system folder. 

Link to post
Share on other sites

I am surprised that 98SE does not have the My Pictures folder image preview implemented. Explorer has thumbnail preview with basic info about the file at the LHS of the window. It is not zoomable though and does not use SHIMGVW for this. The thumbnail viewer is for various file types with settings in the registry. Image Preview or mainly IMAGING.dll was used up to Whistler 2454 approximately and if you use SHIMGVW you will need a compatible IMAGING.dll as well. SHIMGVW is loaded when My Pictures folder is opened. Image preview is zoomable here with rotation print and full screen view buttons. The size of and position of the image preview within the My Pictures folder is governed by IMGVIEW.htt from within the WEB folder. The WEB folder files are setup from the registration of WEBVW.dll. If you like the 98/ME color scheme, registering the SP WEBVW will alter the LHS folder color to white. Reregistering the original file will fix this. ME's SHIMGVW has got slideshow functions where as Whistler ones did not have these. Whistler 2223 had a similar preview setup as ME having 04/2000 link time stamp. IMAGING.dll from 2223 is compatible but not as good as ME's IMAGING.dll as ME's can parse differently formatted Jpeg types. IMAGING.dll will need registering.

Edited by Goodmaneuver
Link to post
Share on other sites

It works very nice, but after some more experimentation if found an script error. If I were to change the way the folder looks from the image preview to the "standard" folder option I get a script error in folder settings\folder.htt The error can be removed by editing the desktop.ini file inside the folder and change PersistMoniker=file://Folder Settings\Folder.htt to PersistMoniker=file:\\%webdir%\Folder.htt. Is this something that can be fixed or is it way to complicated and should I just never change from the preview format? 

Link to post
Share on other sites

I think you may have solved it but you could take a copy of original FOLDER.htt ( if it exists ) before swapping to Image Preview. For a standard folder view, folders do not need FOLDER.htt and DESKTOP.ini, and for image view, only DESKTOP.ini is required in the folder. I did not know about creating Image Preview folders until now and only have My Pictures folder with image preview implemented. FOLDER.htt for the folders of Windows, Program Files and System contain much more info than the WEB directory FOLDER.htt. My DeskTop.ini is shown below for the My pictures folder if that helps? The JavaScript error should say what line and character ( distance in ) of the FOLDER.htt the error starts at.

[ExtShellFolderViews]
Default={8BEBB290-52D0-11D0-B7F4-00C04FD706EC}
{8BEBB290-52D0-11D0-B7F4-00C04FD706EC}={8BEBB290-52D0-11D0-B7F4-00C04FD706EC}
{5984FFE0-28D4-11CF-AE66-08002B2E1262}={5984FFE0-28D4-11CF-AE66-08002B2E1262}
[{5984FFE0-28D4-11CF-AE66-08002B2E1262}]
WebViewTemplate.NT5=%WebDir%\ImgView.htt
[.ShellClassInfo]
InfoTip=Stores your pictures
IconFile=%SystemRoot%\System\mydocs.dll
IconIndex=-101
ConfirmFileOp=0

Edited by Goodmaneuver
Same as it was
Link to post
Share on other sites

I think I have fixed it by replacing standard.htt fro ME in the web directory of 98 and then delete the desktop.ini file, then automatically the ME's template file is loaded which fixes the issue. By doing so it breaks printers.htt but this can be fixed by replacing the default with ME's printers.htt. And from current testing this works without any script errors. And ofcourse the imgview.htt from ME needs to be replaced in 98 otherwise it doens't work at all. Only thing left to do is script it in 98SE2ME and then it should be done.

Link to post
Share on other sites

So you are not using ME's WEBVW.dll? Registering this file fills the WEB folder with ME's HyperText files. You must be using an updated SP file of WEBVW.dll I think. It is tricky to get it all correct as you are finding out and once you have it correct take a copy of the registry and the WEB folder. Various WEBVW versions may be used, as the registry string SHELL32.dll references are the same, well into Whistler development but If you register those files script errors will occur and Control Panel, My Pictures, My Network Places and My Printers may not work. Not to be tried in my opinion unless you have a registry and WEB folder backed up. The best idea is to stick with ME's WEBVW registration settings. Manual modifying the HyperText files is OK of course if you know what you are doing and is suggested in the ME's custom folder options. Because I am using 1920x1080 desktop viewing resolution I made the image view panel width 400 pixels wide instead of 300. You did good to get it all working.

Edited by Goodmaneuver
Link to post
Share on other sites

I believe that I am using the ME version of WEBVW.dll, if I recall correctly I have version 5.50..... which should be ME's (it comes from 98SE2ME). I have custom translated and fixed quite some bugs of 98SE2ME so it might be possible that I have introduced one somewhere. I also want to make changes to the HTT scripts for some better localization in my opinion and do not really want to dive in the resource editor to make the changes happen inside WEBVW.dll :D.  I am experimenting inside a VM so any breaks are quickly fixed or rolled back, once more final I will try it on actual hardware to see if it still plays nice with the other script.

Link to post
Share on other sites
  • 1 month later...

I have tested the above instructions and can confirm, everything works. Maybe email MDGx and he can update 98SE2ME. If not, I will add it to U98SESP3.EXE which is no longer available for public release. All V.I.P will have access to stable and private updates of SP3. Thank you guys for all of your support.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...