Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


asdf2345

How would I exactly install AMD Radeon 15.6 drivers onto Vista x64?

Recommended Posts

I've searched through this forum, and can't find much from people that actually used the 15.6 drivers. I do remember from somewhere that @greenhillmaniac found working newer drivers that worked with the R9 300 series, but I can't find a post about that anywhere, but I swear I remember seeing it. I've only found a post where one person got 15.6 working on Vista, and I guess everyone repeated that 15.6 works because of it.

Earlier in 2020, I tried installing 15.6, and had a quite unstable Windows that froze for a period of time after booting, which doesn't happen with my current install on a PC with the 13.12 drivers. I do have one issue with the 13.12 drivers though. My monitor has quite a bit of underscan at 1080p on my 1080p monitor, and I think upgrading my drivers would fix it. So I tried looking, and could only find a way to get the 14.12 drivers working on x64 Vista. Others said the fix unofficially worked on 15.6, but that's what I tried, and it didn't work out for me.

Could someone compile everything important about this into one post, or make a guide onto how to install these newer drivers?

Share this post


Link to post
Share on other sites

Yeah, I posted it in a thread somewhere and it got lost to time (I can't find it either!). I still have those drivers archived: https://mega.nz/file/wgxAFCzJ#N8_D1L59p8isZ2Gz4nmgBPxkdXlFqS52uxbctbvumDQ

They're AMD Embedded drivers based on an early 15.100 branch, still compatible with Vista. To use your R9 300 GPU (or any other, since it has few cards listed) with them you need to edit the INF and add your HWID (I think I added my GPU's HWID in that archive, the R9 380, so you could use that as the baseline for changes specific to your card).

Share this post


Link to post
Share on other sites
1 hour ago, greenhillmaniac said:

Yeah, I posted it in a thread somewhere and it got lost to time (I can't find it either!). I still have those drivers archived: https://mega.nz/file/wgxAFCzJ#N8_D1L59p8isZ2Gz4nmgBPxkdXlFqS52uxbctbvumDQ

They're AMD Embedded drivers based on an early 15.100 branch, still compatible with Vista. To use your R9 300 GPU (or any other, since it has few cards listed) with them you need to edit the INF and add your HWID (I think I added my GPU's HWID in that archive, the R9 380, so you could use that as the baseline for changes specific to your card).

Tried adding the things needed for my HD 6870, but I keep getting an error when trying to install the driver

"The driver selected for this device does not support Windows Vista"

Share this post


Link to post
Share on other sites
Posted (edited)
On 8/15/2020 at 5:18 AM, asdf2345 said:

Tried adding the things needed for my HD 6870, but I keep getting an error when trying to install the driver

"The driver selected for this device does not support Windows Vista"

Think I figured out why it didn't work. There's absolutely no code in the driver for my GPU, so I'd be stuck with 15.6, which I don't know how to properly install.

I did get 14.12 working, but I'd like to get a newer driver working.

Edited by asdf2345

Share this post


Link to post
Share on other sites

Got it working

It wouldn't install the drivers for my HD 6870, but I pointed it to install some FirePro V drivers, and it installed

If I'm able to change the FirePro V driver name, I'll post image

Also, I forgot to replace the files with those included with the ,zip, guess the Vista extended kernel has all the needed functions

Share this post


Link to post
Share on other sites
5 hours ago, asdf2345 said:

Got it working

It wouldn't install the drivers for my HD 6870, but I pointed it to install some FirePro V drivers, and it installed

If I'm able to change the FirePro V driver name, I'll post image

Also, I forgot to replace the files with those included with the ,zip, guess the Vista extended kernel has all the needed functions

 

ScreenShot_20200819004620.jpg

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...