Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


reboot12

YT may not work on old browsers anymore, starting March 2020

Recommended Posts

14 hours ago, reboot12 said:

you can no longer disable Polymer like this: https://www.youtube.com/?disable_polymer=true

... Being slightly pedantic, but the URL query parameter should be: 

disable_polymer=1

Be that as it may, the query no longer works for the main YT homepage,

https://www.youtube.com/?disable_polymer=1

(classic style is not restored), but still works for independent video URIs:

https://www.youtube.com/watch?v=W-z7hoEWaH4&disable_polymer=1

pzmyMkT.jpg

A Google-bot SSUAO however does, as of this writing, work in both cases...

[I'm using just "Googlebot/2.1 (+http://www.googlebot.com/bot.html)"]

  • Like 4

Share this post


Link to post
Share on other sites

Posted (edited)
19 hours ago, VistaLover said:

... Being slightly pedantic, but the URL query parameter should be: 


disable_polymer=1

Be that as it may, the query no longer works for the main YT homepage,

https://www.youtube.com/?disable_polymer=1

(classic style is not restored), but still works for independent video URIs:

https://www.youtube.com/watch?v=W-z7hoEWaH4&disable_polymer=1

true also disables polymer:

https://www.youtube.com/watch?v=W-z7hoEWaH4&disable_polymer=true

Edited by reboot12
  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Some videos do not work in full screen mode in polymer on Chrome 49, e.g. in this:

https://www.youtube.com/watch?v=hqi2Jy0UMiA

Clicking the Full Screen button or pressing f key switches the browser to full screen mode - just like pressing F11 key and the video is still playing in the window

Edited by reboot12
  • Upvote 1

Share this post


Link to post
Share on other sites
Posted (edited)

And the prize goes to siria.

June 2020, I wrote:

Quote

BTW, https://addons.mozilla.org/en-US/firefox/addon/custom-user-agent-revived/

works on Firefox 52.9 (XP). On the settings page, enter "Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)" as the custom useragent for youtube.com.

Of course, this s*** will probably all vanish in a week or three when Google deletes the actual templates that make the non polymer system work, but I am grateful nonetheless for a reprieve, and for the dim possibility that this will be stable for a longer period.

You need to restrict the user agent to youtube.com or it will wreak havok in other areas. For instance, it's not possible to sign in to YouTube (if you aren't already) as a Google bot.

 

-------------------------

 

On this end, by default the polymer site loads correctly in Firefox 52 and Chrome 49. They're awful, of course. And the worst thing (for those of use who really use YouTube) is that the video manager has been replaced with the godawful polymer studio. You know. To respond faster to user requests and add all the great features you want. That part of the site is just really slow and messed up, in particular uploading.

Edited by Hunterw
detail

Share this post


Link to post
Share on other sites
16 hours ago, Hunterw said:

And the prize goes to siria.

June 2020, I wrote:

I wanted to react to your June 2020 post, but I cannot find it. AFAIK, the “googlebot” agent solution was first mentioned at MSFN by UCyborg in a June 22 post.

Share this post


Link to post
Share on other sites
On 7/3/2020 at 5:12 PM, reboot12 said:

Some videos do not work in full screen mode in polymer on Chrome 49, e.g. in this:

https://www.youtube.com/watch?v=hqi2Jy0UMiA

Clicking the Full Screen button or pressing f key switches the browser to full screen mode - just like pressing F11 key - and the video is still playing in the window

I can confirm:

sZtbFN8.jpg

=>

fNCIqNB.jpg

Works as expected, though, in "classic" style...

Share this post


Link to post
Share on other sites
14 hours ago, Vistapocalypse said:

I wanted to react to your June 2020 post, but I cannot find it. AFAIK, the “googlebot” agent solution was first mentioned at MSFN by UCyborg in a June 22 post.

We know that. That's who siria linked to. There was no other content in his post. siria was the first person to bring it up in the relevant topic.

My instructions were not posted here. They're on reddit, where that solution was shared earlier. Meanwhile people here have been going in circles with various browsers, useragents and URL tricks.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

No idea who discovered those great youtube tricks as first person in the world, but never mind in this case. For such well-known old tricks which were only forgotten for awhile until someone, or many, remembered to try them again, all attempts to identify Who-dunnit-first will go in circles anyway. Like UA-googlebot in general, or anti-polymer key in youtube-URL. In that mentioned long REDDIT topic the earliest UA discoverer seems to be one of the addon-authors, Mirza, a few weeks ago. But whatever, such great tricks should be spread, and the tinkerers among us will surely remember sooner next time to try pesky sites with UA googlebot :-)
What a disaster that such useragent tricks will probably fail soon on many main sites, since all big browser makers last year happily announced to transfer those same data -plus more- in future builds only in stealth and unfakeable ways. Much deeper under the hood, requiring modern browsers and new server request methods, so finally all older engines can be identified 100% and get blocked much easier, grrr.

But origin or not, since you like to spread such user tricks, here's a tiny, crucial yt-fix which could use more spreading too (while it still works...)
Figured it out myself last year after long struggling due to old browser probs, where that pesky "Show more" button for video description is broken since years. It's so basic that probably a bunch of other people found it on their own too, no big feat. Nevertheless haven't seen it posted elsewhere yet, and it's not mentioned in that long reddit-topic either although the prob was discussed there. Looks like semi-modern browsers now suddenly have the same prob, video description cropped and button broken, description remains hidden. But installing a whole addon or a javascript file user.js just to fix this button seems overkill to me. So this fix could please be spread a bit more too...

This is just a tiny userCSS for youtube CLASSIC view, which makes the complete youtube description text visible at page load. No need to click that "Show more" button anymore. Minor catch: this useless button still remains visible too, looks confusing, but can live with it ;-P
Can be added to slightly older Mozilla browers e.g. in current profile, in file /chrome/userContent.css

@-moz-document domain(youtube.com) {
#watch-description-text {height: auto !important; max-height: none !important;}
}

While at it, a reminder of yet another crucial UA trick: to get .3gp movies with TINY file size.
Posted by a kind soul (thanks!) awhile back. Only useful for people desperate for extremely tiny filesize, due to bandwith probs or limited disk size, no matter how horrible the quality. Even if those videos have almost stamp size: UA Mobile IPAD still gets those offered, and the page source still contains direct download links too (itag ":36,")
example
Mozilla/5.0 (iPad; CPU OS 6_0 like Mac OS X) AppleWebKit/536.26 (KHTML, like Gecko) Version/6.0 Mobile/10A403 Safari/8536.25

Edited by siria
  • Like 2

Share this post


Link to post
Share on other sites
Posted (edited)

Wow that usercontent thing for the descriptions worked. :) I didnt want to install any addon's to fix that dumb thing so i always ignored it before i saw your post. -- i always had to keep going to View => Page Style => No style -- scroll the page all the way down to read video descriptions, a little annoying

But this way you mentioned works finally. Thanks.

Edited by kuja killer

Share this post


Link to post
Share on other sites

Can anybody confirm that YouTube with the Classic interface no longer works with the "Mozilla/5.0 (compatible; Googlebot/2.1) User Agent override? R.I.P YouTube Classic, July 10th 2020.

  • Upvote 1

Share this post


Link to post
Share on other sites

Yup, it's gone.

Share this post


Link to post
Share on other sites
34 minutes ago, ClassicNick said:

Can anybody confirm that YouTube with the Classic interface no longer works with the "Mozilla/5.0 (compatible; Googlebot/2.1) User Agent override? R.I.P YouTube Classic, July 10th 2020.

Still works fine for me. Make sure you reapply the pref cookie trick (f6=8 or f6=9) if you didn't. Using this variant of GoogleBot Desktop UA tho:

Mozilla/5.0 AppleWebKit/537.36 (KHTML, like Gecko; compatible; Googlebot/2.1; +http://www.google.com/bot.html) Chrome/83.0.4103.97 Safari/537.36	

So you might want to replace the latter Google Chrome part with Firefox's

  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites

Anyone know of a WebExtension that allows me to change the viewport height that YouTube sees? On a 1920x1080 monitor, YouTube's old design has a somewhat small video window, but setting zoom to 90%, or changing the viewport height to a higher number increases the video size.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...