Jump to content

Help: System drive (C:) shows as USB-removable in system tray


Recommended Posts

Hi guys,

My WinXP 64 SP2 (updated to the latest) machine runs absolutely fine, except for a little annoyance: my system disk (Drive C:) shows in the system tray as USB-removable - see attached pic below.

I have searched on the Internets for a solution, and tried a few things, but nothing seems to work. I also came across some posting in which a guy claimed that it is a bug in WinXP64.

Anyways, if someone can help out, it will be greatly appreciated.

My machine's specs:

- MoBo: GA-K8N51GMF-9; chipset NVIDIA GeForce 6100 and NVIDIA nForce 430

- CPU: AMD Athlon 64 X2 4400+ Toledo, socket 939

- System HDD (C:): WDC400JD, SATAII

- Storage HDD (D:): HDT7250, PATA UDMA6

- DVD-ROM Drive (E:): GWA4164B, PATA UDMA2

- BIOS does not seem to support AHCI, only IDE. There is no "hot-plug" option.

Interesting thing is that I use exactly the same machine with a different HDD (WDC800JD) to run Win XP Home SP3. The problem is not present; it only appears under WinXP64.

Thank you for your attention :-)

 

1.jpg

Edited by assenort
Link to post
Share on other sites

IIRC, all SATA ports have to support hot-plug. It is the driver that specifies whether it shows this way in Windows.

You may be able to solve this by using the registry, however you would have to do some looking to determine the correct key to change. In this example:

HKLM\SYSTEM\CurrentControlSet\Services\msahci\Controller0\Channel0

you can add a TreatAsInternalPort entry. I put bold above to note that your hard drive may not be identified to this particular service. If it is not, then setting it on msahci will probably not make any difference. So then you'll have to find which service your drives are under. Without having a XP64 system to look at, I can tell you using Win7 as a reference. In device manager, find the section for IDE controllers, and inside should be your SATA controller. In the properties of that, under details tab, change the drop-down to service. That should be the name of the Service in the registry.

Additional caveat: This may not work in XP64. Also I do not know if there is a 64bit registry or not (I never used regedit in XP64)

Ref: https://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/my-internal-sata-device-appears-in-devices-and/722221d6-d59c-4cf7-803c-8203e6344b93

  • Like 1
Link to post
Share on other sites

Under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\atapi\Parameters, there is a key labelled "NonRemovableMedia", with a list of controllers and storage devices. Theoretically, you could add your HDD under the name it identifies as in device manager to that list. That is in 2003 x86, so it should also exist in XP x64.

 

Edited by win32
  • Like 1
Link to post
Share on other sites

Thank you for your answers and suggestions, guys. I will get around to trying these, and will post here to report success or failure.

Greets :-)

 

PS. Tried it, unfortunately for me both of the proposed solutions did not produce results. Guess I have to live with it.

Thanks again for trying to help.

Best :-)

Edited by assenort
Link to post
Share on other sites
  • 1 month later...
On 2/22/2020 at 11:34 AM, ED_Sln said:

Install the standard IDE controller driver instead of the nForce IDE driver.

How exactly to do this? Manufacturer (nVidia) provides their own drivers... look for generic drivers on the Internet?

Link to post
Share on other sites
4 hours ago, assenort said:

How exactly to do this? Manufacturer (nVidia) provides their own drivers... look for generic drivers on the Internet?

No, you don’t need to download anything, the driver is in the system.

1. Go to Control Panel and open System.
2. Click the Hardware tab and then click the Device Manager button.
3. In Device Manager expand “IDE ATA/ATAPI controllers” by clicking the + sign.

4. Right click on the FIRST controller in the list and select Update Driver, it should be the one with a manufacturer name, such as nForce or Intel etc.

update-IDE-ATA-change-hdd1.png
5. Select “No, not this time” when asked “Can Windows connect to Windows Update to search for software?” and click Next.
6. Select “Install from a list or specific location (Advanced)” and click Next.

installadvanced-driver.png
7. Select “Don’t search. I will choose the driver to install” and click Next.
8. Select “Standard Dual Channel PCI IDE Controller” and click Next.

standard-dual-channel-pci-ide-controller

 

Link to post
Share on other sites

Hello ED_Sln:

Thank you very much for taking so much time and efforts to help with the problem. Really appreciate it.

I tried to do what you suggested, however I already have the standard IDE controller installed - see pic.

1.JPG

When I try to see if there any other SATA Controller to install, I only have this option:

2.JPG

Edited by assenort
Link to post
Share on other sites

No, you need to install the driver on the nForce 410/430 Serial ATA Controller. If the IDE mode is enabled in the BIOS, then IDE drivers are installed on these two controllers. (If after the experiments the system stops loading, with BSOD 7B, then you need to press F8 when the system starts, to call up the boot menu and select "Last Known Good Configuration" there). There are no settings in the properties of the controllers, maybe something can be switched there?

Link to post
Share on other sites

I have to apologize for wasting other people' time and efforts. Obviously age is catching up with me and I would do better to stop tinkering with hardware.

Problem was resolved in the most banal and obvious manner - by updating chipset driver.

Latest driver from Gigabyte for this particular MoBo was from August 2006. That is what I had originally installed on my machine.

Went to nVidia site and downloaded latest driver for the nForce 4 Series (GeForec6100/nForce430) version 15.26 from March 2009. Installed, and problem is gone. Simple as that.

Should have thought of that to begin with, but ....

Anyways, thanks again to everyone who tried to help me through my stupidity.

Best :-)

1.JPG

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...