Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
i430VX

[Solved] Infrared Transfer is not working.

Recommended Posts

Hello guys. I have an HP compaq nc4010 with some issues with it's infared transceiver. The first issue is that the Infared "Wireless Link" applet in the control panel refuses to open, simply doing nothing upon being clicked.  The Second issue is that when attempting to transfer files to or from this HP, the other computer gets the Infared prompt, but this one does not. Attempting anyway on the other computer always ends in "the other machine actively refused it." The infared service is running, and proper drivers appear to be installed.


Thanks for any help.

:)

 

Edited by i430VX
Infared is not a "port", per se.

Share this post


Link to post
Share on other sites

> Infared is not a "port", per se.

Infared is (an adapter connected to) a serial port. In the system BIOS, make sure the IR serial port is enabled. If it already is, disabled it to see how the system reacts.

Edited by jumper

Share this post


Link to post
Share on other sites

I tried disabling and re-enabling infared at the bios level, didnt seem to help, unfortunately.

Share this post


Link to post
Share on other sites

But when disabled did the messages (or anything else) change?

Share this post


Link to post
Share on other sites

Well, sorta. The messages stopped altogether as the laptop with working infrared could no longer detect the HP as it's infared is disabled. Re-enabling it and trying again produces the same issues as before.

Share this post


Link to post
Share on other sites

<pedantic mode, sorry>

Folks, it's "infrared"

To be fair @i430VX did get it right once:

3 hours ago, i430VX said:

The messages stopped altogether as the laptop with working infrared could no longer detect the HP

 

Share this post


Link to post
Share on other sites
1 hour ago, Mathwiz said:

<pedantic mode, sorry>

Folks, it's "infrared"

To be fair @i430VX did get it right once:

 

Typo. I do know the real spelling, I just sorta had a brainlapse a couple of times, I'll fix the title

  • Upvote 1

Share this post


Link to post
Share on other sites

I opened up irftp.exe in dependancy walker, and I noticed wer.dll was missing. I replaced that from another computer which made dependancy walker happy but the IR functionality still does not work.

Share this post


Link to post
Share on other sites

Well, after another time running Tweaking.com - Windows Repair, and another time reinstalling the Infrared drivers, it somehow started working this time. And, FWIW, the text display issue mentioned in the last post also somehow resolved itself.

Share this post


Link to post
Share on other sites

Glad you got it working!

17 hours ago, i430VX said:

Typo. I do know the real spelling, I just sorta had a brainlapse a couple of times, I'll fix the title

No biggie, but thanks! It did sort of grate on my nerves a bit, especially when jumper chimed in with the same misspelling!

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...