Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


roytam1

My browser builds (part 2)

Recommended Posts

2 hours ago, RainyShadow said:

You both don't say which browser you use...

I also couldn't access that site in NM27, but it works in Serpent52.

Absolutely right. So sorry about that , NM28. If it helps I also had to disable ublock origin in the official palemoon win7set up to be able to access Spiegel International.

Cheers

Share this post


Link to post
Share on other sites

7 hours ago, RainyShadow said:

Roy does NM27 builds for systems without SSE2 support (like mine).

Nobody shared a SSE-only build of NM28 so far.

 

I wonder how complete is the SSEPlus project and what would it take to use it in NM28? @roytam1?

 

btw. i just found that the latest NM27 build breaks the Add Bookmark Helper . In older builds it used to show the bookmark editor dialog when adding a bookmark, but now it doesn't. Other options don't seem to be working too.

I imagine it would be trivial to do so. I've built Palemoon 28 on GNU/Linux for machines without SSE2 before, and all I had to do was specify -mno-sse2 to my GCC compiler options.

Share this post


Link to post
Share on other sites
1 minute ago, sparty411 said:

I imagine it would be trivial to do so. I've built Palemoon 28 on GNU/Linux for machines without SSE2 before, and all I had to do was specify -mno-sse2 to my GCC compiler options.

If so, why don't you go ahead and do it?  :dubbio:

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
13 hours ago, dencorso said:

If so, why don't you go ahead and do it?  :dubbio:

You mad, bro? I do my own builds on GNU/Linux. I have no reason to do an XP build, seeing as how I no longer use it in any serious capacity. You become hostile toward anyone ITT who dares ask for a single thing. What gives? 

Edited by sparty411

Share this post


Link to post
Share on other sites
On 7/12/2020 at 1:48 PM, sparty411 said:

You become hostile toward anyone ITT who dares ask for a single thing. What gives?

No, not hostile... defensive, maybe. Fact is I think Roy's keeping too many builds alive and up-to-date, already. And no, if you had read the thread, you'd find out there actually is a reason why he's not making non-SSE PM 28. Not only it is not "trivial", but actually it does not work, IIRR. When one makes a disparaging remark, one should be prepared to receive a pointed retort, isn't it? No offense meant, though.

Share this post


Link to post
Share on other sites
On 7/12/2020 at 5:04 AM, Tangy said:

Absolutely right. So sorry about that , NM28. If it helps I also had to disable ublock origin in the official palemoon win7set up to be able to access Spiegel International.

Cheers

 

On 7/12/2020 at 2:22 AM, RainyShadow said:

You both don't say which browser you use...

I also couldn't access that site in NM27, but it works in Serpent52.

Thank you both for your feedbacks.

So, NM27 + 28 cannot but Serpent (52/55) can access "spiegel.de" with 'JS on', right?
And how about PM28?? Guess that NM28 is (for the most part) ported from PM28. So that one ought to fail here, too??
That "scripting" horror continues...

Share this post


Link to post
Share on other sites
1 hour ago, bernd said:

 

Thank you both for your feedbacks.

So, NM27 + 28 cannot but Serpent (52/55) can access "spiegel.de" with 'JS on', right?
And how about PM28?? Guess that NM28 is (for the most part) ported from PM28. So that one ought to fail here, too??
That "scripting" horror continues...

In both New Moon 28 and Pale Moon 28, I can access https://www.spiegel.de/international/ with 'JS on' and uBlock Origin enabled.

Maybe a filter issue?

Share this post


Link to post
Share on other sites
Posted (edited)
42 minutes ago, nicolaasjan said:

In both New Moon 28 and Pale Moon 28, I can access https://www.spiegel.de/international/ with 'JS on' and uBlock Origin enabled.

Maybe a filter issue?

Could you please wise me up how you exactly do that?

Got Cookies + NoScript (all allowed) + uBO (as seen)

Forgot to mention I'm using NM27

spiegel.thumb.png.066fca95b18290a6937cdf318b6e9549.png

Edited by bernd

Share this post


Link to post
Share on other sites
2 hours ago, bernd said:

 

Thank you both for your feedbacks.

So, NM27 + 28 cannot but Serpent (52/55) can access "spiegel.de" with 'JS on', right?
And how about PM28?? Guess that NM28 is (for the most part) ported from PM28. So that one ought to fail here, too??
That "scripting" horror continues...

I have no problem. NM28 ublock origin 1.16.4.23 onlyDerspiegel.thumb.JPG.4f6d0f433daa06e5eda04cf9f555c934.JPG

  • Like 1

Share this post


Link to post
Share on other sites
10 minutes ago, bernd said:

Could you please wise me up how you exactly do that?

Got Cookies + NoScript (all allowed) + uBO (as seen)

spiegel.thumb.png.066fca95b18290a6937cdf318b6e9549.png

I use uBo in normal mode with eMatrix and while allowing everything in eMatrix, uBo looks like this:

screenshot1.png.334326b3dd7b5207d9240772b1667897.png

uBo filters:

Screenshot

And a system-wide HOSTS file, containing the ones also included in uBo (but not selected).

  • Like 1

Share this post


Link to post
Share on other sites
5 minutes ago, Jaroslaw said:

I have no problem. NM28 ublock origin 1.16.4.23 only

Thank you both Jaroslaw and Nicolaas!

Got the same settings as you.

About a fortnight ago I could access that site with no problems at all.

I don't believe that NM27 is to be blamed here.

So, could be old uBlock Origin 1.16.4.21 instead of latest (absolutely necessary) uBlock Origin 1.16.4.23 the culprit??

What to do now??

Share this post


Link to post
Share on other sites
12 minutes ago, bernd said:

Thank you both Jaroslaw and Nicolaas!

Got the same settings as you.

About a fortnight ago I could access that site with no problems at all.

I don't believe that NM27 is to be blamed here.

So, could be old uBlock Origin 1.16.4.21 instead of latest (absolutely necessary) uBlock Origin 1.16.4.23 the culprit??

What to do now??

You cannot use UBO v.23 with NM27.
Check if disabling UBO the web page works.

NM27 users who use UBO should consider switching to Adblock Latitude.

  • Like 1

Share this post


Link to post
Share on other sites
5 minutes ago, bernd said:

Thank you both Jaroslaw and Nicolaas!

Got the same settings as you.

About a fortnight ago I could access that site with no problems at all.

I don't believe that NM27 is to be blamed here.

So, could be old uBlock Origin 1.16.4.21 instead of latest (absolutely necessary) uBlock Origin 1.16.4.23 the culprit??

What to do now??

Difficult to answer...

Perhaps you can have more success asking on the uBo subreddit

Or at https://github.com/uBlockOrigin/uAssets/issues

 

Share this post


Link to post
Share on other sites
31 minutes ago, nicolaasjan said:

I use uBo in normal mode with eMatrix and while allowing everything in eMatrix, uBo looks like this:

screenshot1.png.334326b3dd7b5207d9240772b1667897.png

uBo filters:

Screenshot

And a system-wide HOSTS file, containing the ones also included in uBo (but not selected).

Hi,:hello:

Too many "My Filters".
The lists update over time.
Check if eliminating some rules you always have problems.

If the test is positive you can try to eliminate most of the filters.

Share this post


Link to post
Share on other sites
Posted (edited)
28 minutes ago, Sampei.Nihira said:

Hi,:hello:

Too many "My Filters".
The lists update over time.
Check if eliminating some rules you always have problems.

If the test is positive you can try to eliminate most of the filters.

You haven't seen "my Filters" ;)

Most of them are cosmetic.

But perhaps there are some that can be removed now. I'll look into it when I'm bored.

It's not really an issue with 16GB of RAM (and 3.5GB for my XP virtual machine)... :)

Edited by nicolaasjan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...