Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

roytam1

My browser builds (part 2)

Recommended Posts

5 minutes ago, looking4awayout said:

Would it be possible to implement the Tiled Compositing routines of 45 ESR into 52?

not quite possible as mozilla has millions of commits between them, many APIs are changed. Simply reverting random commit(s) might make the situation worse.

  • Like 1

Share this post


Link to post
Share on other sites

1 minute ago, roytam1 said:

not quite possible as mozilla has millions of commits between them, many APIs are changed. Simply reverting random commit(s) might make the situation worse.

Dammit. Is there an alternative?

Share this post


Link to post
Share on other sites
2 minutes ago, looking4awayout said:

Dammit. Is there an alternative?

find the glitchy commit and try to reverting it, but you need lots of time to do that.

Share this post


Link to post
Share on other sites
1 minute ago, roytam1 said:

find the glitchy commit and try to reverting it, but you need lots of time to do that.

I am not a programmer, can't do that unfortunately. I wish I could... :(

Share this post


Link to post
Share on other sites
5 hours ago, 3dreal said:

WOW-big christmas present also for my pension on my SSE-PC.
But: 1a) it will still give the already posted error-only i have to ignore..-see image.

2a) I ran the installer in administrator-account, i start-section i remove the old links which i set.. Have now these problems:
2b) Where to see in browser which version?
2c) i only see my browsers: Firefox Nightly 45.9.18(blue), KM_Goana, Palemoon SSE in administrators-account.
in restricted account i see only Firefox 4530(6050) ESR. 6050 not shown in browser. In Programme(german)-folder i see palemoonsse and km-goanna(with its resp. subfolders) but they are empty(restricted account, i installed in admin-account. FF 45.30 ESR i see but where is FF45SSE Nightly(45.9.18.7265)?

Before installer worked i had to start from folders and start-links were set.
Can only run the three installed browsers in administrator-account!

 

1a. I still cannot replicate that error on any of my machines.

2 a, b and c:
Sorry, i didnt mean literally the "Administrator" account, just an account with admin privileges. please install from your normal account as you were doing, because if it worked before you evidently have sufficient rights there.

 

 

Also, @roytam1 I can provide that screenshot you ask for when i get home later today

Share this post


Link to post
Share on other sites
On 12/4/2019 at 5:10 PM, roytam1 said:

I expected, due to the K6 having a half-baked MMX.

not really. lack of CMOV instruction set is the problem.

In PCem, only Cyrix  6x86MX series emulates CMOV instructions, and it runs sp52-ia32.

McN7xVx.png

and I can make a list of processors that can run sp52-ia32 (which support CMOV instruction):

Intel: Pentium Pro or later

AMD: K7 (original Athlon/Duron) or later

VIA: C7 or later

Transmeta: all CPUs are capable to run sp52-ia32.

Cyrix/IBM: 6x86MX or later, MediaGXm(MediaGX-S) or later

National Semiconductor/AMD: Geode GX or later

DM&P/Vortex86: Vortex86DX3 or later

Edited by roytam1
  • Like 3

Share this post


Link to post
Share on other sites
14 hours ago, Destro said:

AMD K8 Slot A, Pentium II, P55C, K6, Pentium Pro and Xeon II are pretty much the only CPUs that benefit from MMX only build and all of those users combined is less users than Pentium III users who have SSE. To be totally honest PIII is long in the tooth as it is and even with DUAL socket pentium III 1000 Browsing the web is slow and you still can't watch youtube cuz its slow

K8 has MMX, SSE, SSE2, Enhanced 3DNow!, NX bit, AMD64, and Cool'n'Quiet.

Share this post


Link to post
Share on other sites

I'm without any proxy/VPN now ...

 

If Zenmate extension enabled, I've this message page on all websites:

"Your connection is not secure. ..." Click Advanced --> "Peer's certificate has expired."

- so I'm not able to surf the web ... After disable my proxy extension, restart the page, website's content is here, OK.

This happens to me in all browsers where I've downloaded proxy extension: Serpent 55, Serpent 52, New Moon 28, Firefox 45. For a long time.

Can someone have an suggestion, a solution for this problem, please?...

Share this post


Link to post
Share on other sites
20 minutes ago, msfntor said:

I'm without any proxy/VPN now ...

 

If Zenmate extension enabled, I've this message page on all websites:

"Your connection is not secure. ..." Click Advanced --> "Peer's certificate has expired."

- so I'm not able to surf the web ... After disable my proxy extension, restart the page, website's content is here, OK.

This happens to me in all browsers where I've downloaded proxy extension: Serpent 55, Serpent 52, New Moon 28, Firefox 45. For a long time.

Can someone have an suggestion, a solution for this problem, please?...

check your system time, and try with new profile

  • Like 1

Share this post


Link to post
Share on other sites

@roytam1 It looks like you have now seen your own proof it works without SSE, but here is mine anyway, just in case you want to see.

Snapshot%2015.jpg

The browser is a bit sluggish, as expected, due to no real GPU and an old budget processor, but it does indeed work on this MMX-only Mendocino CPU.

Snapshot%2016.jpg

 

 

 

Edited by i430VX
fixed images
  • Like 4

Share this post


Link to post
Share on other sites
3 hours ago, i430VX said:

It looks like you have now seen your own proof it works without SSE, but here is mine anyway, just in case you want to see.

OK thanks, it is nice to see it run on bare metal of old hardware.

then I'd keep IA32 branch intact. what else build should I build? as it is predicted pm28/bnav build will be almost the same performance as sp52.

Edited by roytam1
  • Upvote 1

Share this post


Link to post
Share on other sites

Hey @roytam1, Serpent SSE is running wonderfully on my Athlon XP 2800+! Big thanks for the build! This machine will definitely be seeing more action :D

Serpent.PNG

  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, roytam1 said:

OK thanks, it is nice to see it run on bare metal of old hardware.

then I'd keep IA32 branch intact. what else build should I build? as it is predicted pm28/bnav build will be almost the same performance as sp52.

 

What about FF45 ESR with Goanna? Or even replacing the UI of FF45 ESR with the UI of K-Meleon?

If you manage to reduce the overhead on FF45 ESR SSE it would be great. I noticed that FF45 ESR SSE, more so the latest versions, is much more slow than the 38 ESR based browsers on my computer. The UOC Patch speeds it up as it should but loading webpages takes a toll on the CPU, something I do not see on New Moon 27. NM27 starts instantly when you load it and the "search" word in the box appears immediately.

I also noticed another bug. When you start the browser, as it loads the home page, it will freeze for some seconds and the "Search" word in the search box does not appear. Once the word appears the browser becomes operable. I cannot use the browser until that word appears. My computer has no viri nor malwares. Firefox Sync is disabled. This also happens if I set about:blank as home page. 

This does not happen on New Moon 27. I tested FF45 ESR SSE without add-ons and without the Patch and I have the same issues, even on more powerful hardware.

If you can sort that out, or at least find the culprit behind this increased CPU overhead, that would be fab. Ironically, the fastest browsers in terms of CPU overhead on my RDD are New Moon 27 and K-Meleon Goanna, but unfortunately I cannot use them (especially the latter) as K-Meleon doesn't support the add-ons I use.

Edited by looking4awayout
  • Like 1

Share this post


Link to post
Share on other sites
21 hours ago, i430VX said:

1a. I still cannot replicate that error on any of my machines.

2 a, b and c:
Sorry, i didnt mean literally the "Administrator" account, just an account with admin privileges. please install from your normal account as you were doing, because if it worked before you evidently have sufficient rights there.

 

 

The three browsers are shown on desktop of administrator account. Trying to install ontop of existing browser in restricted account with admin-right failed or i cannot find. they are visible in program(programme-folder). so it seems i must remove them. no deinstaller then?

Share this post


Link to post
Share on other sites

msfntor said:
> At the same time as I was logging in to MSFN via Serpent 55, I had an open Slimjet browser
> avec Zenmate enabled (but not functionning - why?), maybe there was any influence on the behavior of Serpent 55...

> If Zenmate extension enabled, I've this message page on all websites:
> "Your connection is not secure. ..." Click Advanced --> "Peer's certificate has expired."
> After disable my proxy extension, restart the page, website's content is here, OK.
> This happens to me in all browsers where I've downloaded proxy extension:
> Serpent 55, Serpent 52, New Moon 28, Firefox 45. For a long time.

Sorry I know hardly anything about proxies, but your problem seems completely independant from browsers. My non-expert impression:
the prob is only your systemwide, independant zenmate APP, which connects to its own server directly. Obviously your version is just too old, if it contains only outdated certs/ciphers. Or perhaps it uses the very old ciphers of the system.
But the used browsers don't matter, since they get the data only afterwards. After the app has already downloaded them from its own server, using a direct connection and it's own outdated ciphers. Roytam's fresh builds certainly contain modern ciphers.

You could try disabling that global app and connect with a normal browser proxy directly to the zenmate server, if knowing the necessary connection data, probably different for each fake country.
Zenmate offers own browser addons, but only in WebExt type.
For browsers using only 'legacy' power addons, a general proxy addon should work too, if IP etc is known.
K-Meleon has a proxy function already built in, configuration in F2>Network/Performance>Proxy

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...