Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


JTB3

Chrome 74 - Glass no longer supported in title bars!

Recommended Posts

Posted (edited)

Chrome was recently updated to version 74 and appears to no longer support native W10 title bars (and the AeroGlass effect).  The #windows10-custom-titlebar flag is also no longer available along with the ability to 'Disable' it.

Does anyone know of an alternative/workaround to re-enable AeroGlass support for the new Chrome 74 title bars? :(

Edited by JTB3

Share this post


Link to post
Share on other sites

The workaround relies on the codepaths still in place for Windows 7/8.x. When the support for those systems is dropped, they'll probably dump that code as well...

Share this post


Link to post
Share on other sites
Posted (edited)
 
 
 
23 minutes ago, UCyborg said:
 

Thank you soooo much, @UCyborg!  The compatibility mode setting (for Win 8) worked like a champ! :thumbup

Edited by JTB3

Share this post


Link to post
Share on other sites

@UCyborg  The (Win 8) compatibility setting almost worked, now these annoying black borders are appearing below the Chrome top frame (see screenshot - border bars circled in green).

 

Google_-_Google_Chrome_2019-04-24_16_35_05.png.ab016530f19c9e1c5e7534237d9071ed.png

Do you have any suggestions on how to remove these border bars introduced by the compatibility setting?

Many thanks! -JT :cool:

Share this post


Link to post
Share on other sites

@UCyborg

24 minutes ago, JTB3 said:

@UCyborg  The (Win 8) compatibility setting almost worked, now these annoying black borders are appearing below the Chrome top frame (see screenshot - border bars circled in green).

 

Google_-_Google_Chrome_2019-04-24_16_35_05.png.ab016530f19c9e1c5e7534237d9071ed.png

Do you have any suggestions on how to remove these border bars introduced by the compatibility setting?

Many thanks! -JT :cool:

I just solved the window border issue by using "Winaero Tweaker" and adjusting the Customize Windows Borders "Border Padding" slider down to 0 (initially it was set to 4, the exact width of the problematic new borders highlighted in the image above).

Winaero_Tweaker_2019-04-24_17_04_19.png.546c7c7ea17325a78dc91e98139b32a4.png

I hope this info helps anyone else attempting to work around these annoyances!
-JT

Share this post


Link to post
Share on other sites
Posted (edited)

Apparently my assumptions were incorrect, and so is this thread's title. I searched through Chromium's commit history and found out only the option in chrome://flags was removed, the functionality is still intact and can be invoked using a command line parameter, see here.

So one must add --disable-features=Windows10CustomTitlebar parameter to Chrome's shortcut properties, at the end of the Target field on the Shortcut tab.

61pS3UV.png

This method doesn't have any undesired side effects like running in compatibility mode has.

Edited by UCyborg
  • Like 2
  • Upvote 2

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks UCyborg, works fine but if you pin Chrome to the Classic Shell task bar once started and then use use the pinned Chrome, the transparency doesn't work (it did using the previous method) !

Managed to fix this by right clicking on the taskbar pinned Chrome and then right clicking on Google Chrome on the pop up menu. Select "properties" on the new pop up menu and reedit the "Target" to append "--disable-features=Windows10CustomTitlebar"

Edited by andy_h
Using Classic Shell
  • Upvote 1

Share this post


Link to post
Share on other sites

@andy_h
Yes, pinning it there creates a separate shortcut in some other place, so you have to setup that shortcut properly as well.

Share this post


Link to post
Share on other sites
Posted (edited)

How can I add this? no clear instructions on how to? that I could find? 

 

Thanks 

 

Edited by gitit20

Share this post


Link to post
Share on other sites

Ok so I got it to work using this --disable-features=Windows10CustomTitlebar added to the shortcut however I would like to know how I can re-add this to the flags section so I can just enable it there? thanks for any help on this... 

 

not sure why they had to remove that in the first place 

Share this post


Link to post
Share on other sites
 
 
1
On 4/25/2019 at 1:36 PM, UCyborg said:

Apparently my assumptions were incorrect, and so is this thread's title. I searched through Chromium's commit history and found out only the option in chrome://flags was removed, the functionality is still intact and can be invoked using a command line parameter, see here.

So one must add --disable-features=Windows10CustomTitlebar parameter to Chrome's shortcut properties, at the end of the Target field on the Shortcut tab.

This method doesn't have any undesired side effects like running in compatibility mode has.

OMG @UCyborg !!! 
I'm just seeeing this awesome solution now!!! :cheerleader:  You are a shooting star!!! ★★★
Thank you sooooo much! -JT

Share this post


Link to post
Share on other sites
Posted (edited)

Here's a solution for one remaining issue with the new command-line fix...  @UCyborg

If your Chrome browser is set to start in the background automatically with Windows (for certain extensions like Hangouts, etc.), Here's how one can edit the Chrome AutoLaunch command line in the registry:

  • Open Regedit.exe and navigate to the following key :  HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run
  • Find the string named: "GoogleChromeAutoLaunch_......"  and right-click to modify the text/command line to add the new parameter:
  • (Here's what mine looked like when finished:)
    "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --no-startup-window --disable-features=Windows10CustomTitlebar /prefetch:5

Now Chrome will autostart in the background with the AeroGlass compatible title bars. :cool:
-JT

Edited by JTB3
Typos

Share this post


Link to post
Share on other sites
9 hours ago, JTB3 said:

Here's a solution for one remaining issue with the new command-line fix...  @UCyborg

If your Chrome browser is set to start in the background automatically with windows (for certain extensions like Hangouts, etc.), Here's how one can edit the Chrome Registry AutoLaunch Command Line:

  • Open Regedit.exe and navigate to the following key :  HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run
  • Find the Sting Named: "GoogleChromeAutoLaunch_......"  and right-click to modify the command line to add the new parameter:
  • (here's what mine looked like when finished)
    "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --no-startup-window --disable-features=Windows10CustomTitlebar /prefetch:5

Now Chrome will autostart in the background with the AeroGlass compatible title bars. :cool:
-JT

Also another issues is in html short cuts. By editing this key, it will allow aero when you double click any site shortcuts you may have saved.

HKEY_CLASSES_ROOT\ChromeHTML\shell\open\command
    (default)                REG_SZ                                   "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --disable-features=Windows10CustomTitlebar -- "%1"

  • Like 1

Share this post


Link to post
Share on other sites
On 4/25/2019 at 4:36 PM, UCyborg said:

Apparently my assumptions were incorrect, and so is this thread's title. I searched through Chromium's commit history and found out only the option in chrome://flags was removed, the functionality is still intact and can be invoked using a command line parameter, see here.

So one must add --disable-features=Windows10CustomTitlebar parameter to Chrome's shortcut properties, at the end of the Target field on the Shortcut tab.

61pS3UV.png

This method doesn't have any undesired side effects like running in compatibility mode has.

If I read the link info correctly, the functionality of the flag will end with chrome version 76. hopefully someone will figure out a registry hack to use like the "allow flash always on" that allows not having to shoose ecery time you need flash on a site. 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...