Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Tamris

Broken mouse scroll on Steam?

Recommended Posts

Anyone else with Steam installed on their Vista machine has this issue or is it just me? I've installed Steam again a couple days ago because I wanted to play some of my games I bought specifically for this old laptop of mine, but noticed that mouse scroll seems to not work at all, at least in the browser part of Steam, i.e. when you browse the Steam Store or your profile, but seems to work whenever I click the library tab and want to browse the list of games I have bought. Any ideas on how to fix this? Or should I report it to Valve, hoping that they will fix it though it's kinda doubtful since Vista (and XP) got about a month of support left? I've only tried reinstalling the Steam client, but sadly it didn't help. :(

  • Like 1

Share this post


Link to post
Share on other sites

...I have no idea what's happening then, especially since I last installed Steam, it worked fine too (and that was like a month ago).

  • Like 1

Share this post


Link to post
Share on other sites

Okay, So I've received an answer from Steam support saying they apparently are aware of this issue and are working on a fix (which I feel like we, or rather, I won't get it before XP & Vista are thrown away), in the meantime telling me:

Quote

In the meantime, you can disable DPI scaling in the Steam Client, which should fix the issue you're currently experiencing.

To disable DPI scaling in the Steam Client, click on "Steam" in the top-left > Settings > Interface > uncheck "Scale text and icons to match monitor settings". This option will restart Steam, but when you log back in, the issue should be resolved for now.

But.. I seem to not have this option at all? Is it anyone else that does not have this option or again it's only me? :realmad:

Share this post


Link to post
Share on other sites
14 hours ago, Tamris said:

But.. I seem to not have this option at all? Is it anyone else that does not have this option or again it's only me? :realmad:

That option is only available in Windows 10... Looks like Steam Support just gave you a generic answer.

  • Upvote 1

Share this post


Link to post
Share on other sites

...even though I clearly have mentioned I'm on Vista. Welp, I guess all I can do now is wait till they miraculously fix it, or till they end support for XP and Vista first. And I guess this topic can be closed, since I doubt there's anything else left to say in this regard.

Edited by Tamris

Share this post


Link to post
Share on other sites

Maybe disable DPI scaling system-wide: Right-click desktop -> Personalize -> Adjust Font Size (DPI).

Google "Vista DPI scaling" for more.

  • Upvote 1

Share this post


Link to post
Share on other sites

Don't have such an option, only can change between 96 and 120 dpi and in advanced settings can set a zoom level and if Windows should use dpi scaling like in XP (or smth like that), tried changing all of these, one by one, but it didn't help. :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×