Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

FranceBB

uBlock Origin, Chromium 54 and Firefox 52.9 ESR

Recommended Posts

11 minutes ago, Sampei.Nihira said:

So I am need to deselect uBlock filters - Experimental?:dubbio:

I always turn off "experimental filters" and no problems.

  • Upvote 1

Share this post


Link to post
Share on other sites
21 hours ago, Sampei.Nihira said:

So, do I have to deselect uBlock filters - Experimental?:dubbio:

20 hours ago, Dr. Drill said:

I always turn off "experimental filters" and no problems.

They should've been disabled by default, according to the Wiki:

Quote

The Experimental filters are disabled by default, enable only if you want to help evaluate/fine tune these filters.

"Experimental filters" is now, of course, a moot point, as, if you did leave them at their default setting (disabled), they'll soon vanish altogether from available filters... ;)

FWIW, manual re-introduction is possible via URI:

https://raw.githubusercontent.com/uBlockOrigin/uAssets/master/filters/experimental.txt

:P

Edited by VistaLover

Share this post


Link to post
Share on other sites

I don't understand, I'm already using 1.17.4, which is surely even newer!
Are we talking about the same thing?
:dubbio:

Edited by Dave-H
Re-worded

Share this post


Link to post
Share on other sites
1 hour ago, Dave-H said:

I don't understand, I'm already using 1.17.4, which is surely even newer!
Are we talking about the same thing?
:dubbio:

Same here, and I've had this question before too on a different forum.  Why don't people use 1.17.4 for old Firefox?

Share this post


Link to post
Share on other sites

The development of UBO 1.17.4 has stopped.

The version of UBO Legacy that I and other MSFN users use is still actively developed.

@mockingbird

In fact, I use New Moon.............

  • Like 1

Share this post


Link to post
Share on other sites

So who's developing it, and why would they concentrate on an older version instead of the last FF 52 ESR compatible version?
Does 1.16.x support even earlier browser versions?
:dubbio:

Share this post


Link to post
Share on other sites

It's simple, the developer of UBO Legacy is Just Off.
Which carries on the UBO legacy project especially for Pale Moon and Basilisk.
UBO 1.17.4 cannot be installed with these browsers.

I didn't understand your next question.

Share this post


Link to post
Share on other sites
2 hours ago, Sampei.Nihira said:

The development of UBO 1.17.4 has stopped.

The version of UBO Legacy that I and other MSFN users use is still actively developed.

@mockingbird

In fact, I use New Moon.............

Thanks.  I removed 1.17.4 and installed 1.16.4.18.

Share this post


Link to post
Share on other sites
47 minutes ago, Sampei.Nihira said:

It's simple, the developer of UBO Legacy is Just Off.
Which carries on the UBO legacy project especially for Pale Moon and Basilisk.
UBO 1.17.4 cannot be installed with these browsers.

I didn't understand your next question.

I think you actually just answered the question.
I was thinking that some people were using 1.16 instead of 1.17 because 1.17 didn't support their browsers.
From what you say that does seem to be the case, but 1.17.4 is still the latest version for Firefox 52 ESR.
Is that right, or are you saying that 1.16.4 actually has more up to date code in it than 1.17.4 (I don't mean the block list files)?
:dubbio:

Share this post


Link to post
Share on other sites

uBO 1.17 and up are WebEx versions. 1.16.4.x is the last version using the legacy API, so it's the last version supported by Pale Moon, New Moon, and (official) Basilisk. Developer JustOff recently took over development of the legacy branch from Gorhill, so Gorhill now works exclusively on the WebEx branch and JustOff works on the legacy branch.

Because of the split, 1.16.4.18 is the newest uBO version that will run on FF 52 / Serpent. It's much newer than 1.17.4. (I think the latest WebEx version of uBO is now 1.24, but it won't run on FF 52 / Serpent. BTW, 1.18 will run on those browsers, but it thinks it won't, so you have to jump through some hoops to fool it.)

I do use the legacy branch, but not because it's "newer." I use it because one feature (blocking WebRTC from leaking your IP address) doesn't work on FF 52 / Serpent if you use a WebEx version.

You can download uBO version 1.16.4.18 from https://github.com/gorhill/uBlock-for-firefox-legacy/releases/download/firefox-legacy-1.16.4.18/uBlock0_1.16.4.18.firefox-legacy.xpi . It's an unsigned extension, so make sure xpinstall.signatures.required is set to false in about:config first! You'll also see a warning that uBO "couldn't be verified" after installing, but you can hide that warning with another extension such as Classic Theme Restorer.

You'll probably need to back up your uBO configuration and uninstall 1.17.4 before you can install 1.16.4.18, but once that's done you can restore your configuration and be back to where you were.

Edited by Mathwiz

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...